DVD Info - Intro

DVD своими руками: Введение

Введение

DVD постепенно завоевывает рынок и вопросы применения программ и аппаратных решений для работы с DVD становятся все более и более интересными для многих и многих людей. С аппаратной составляющей все более-менее ясно – есть пишущие DVD приводы двух конкурирующих стандартов, есть аппаратные кодеры MPEG для тех, кто не может ждать часами результатов работы программных кодировщиков. Осталось только понять, какие программы можно и/или нужно использовать для создания DVD-Video дисков.

Вопрос этот не такой простой, как кажется. Еще несколько лет тому назад программ для DVD Authoring было совсем немного, стоили они больших даже по западным понятиям денег (до $30 000) и их применение было уделом всего нескольких тысяч человек, 90% которых работало в США. С появлением компьютерных DVD рекордеров ситуация изменилась, но теперь возник перегиб в другую сторону. Выпуск программы для создания DVD-Video дисков стал как бы делом чести для всех компаний, имеющих хоть какое-то отношение к видео. В рекламных пресс-релизах производителей любая программа DVD-Authoring сейчас преподносится как универсальное средство, идеально подходящее для создания DVD-Video дисков уровня Hollywood Video. В некоторых подобных программах даже есть шаблоны меню, которые так вот скромно называются – Hollywood Quality. На самом деле, конечно, это далеко не так. Для перечисления программ, которые действительно могут создавать Hollywood Quality DVD-Video диски, вполне хватит пальцев одной руки. Массовой разработке программ DVD Authoring способствует и незыблемость стандарта DVD-Video, и изменение этого стандарта вряд ли возможно в обозримом будущем, так как десятки миллионов DVD плееров уже стоят в десятках миллионов квартир и игнорировать при гипотетической смене стандарта такое количество пользователей невозможно.

Но есть один отличительный признак, который позволяет отделить одну группу программ от другой – это подход к созданию меню DVD-Video дисков. Подавляющее большинство новых программ, созданных для массового пользователя, дают возможность только в небольших пределах варьировать как дизайн меню, так и способы выбора в нем, и самое главное, не позволяют использовать в качестве меню видеоклип. Это ограничение существенно уменьшает творческие возможности автора диска.

Но, к сожалению, мы не сможем обсуждать дальше плюсы и минусы программ для создания DVD-Video дисков, не познакомившись хотя бы вкратце с требованиями к DVD-Video диску.

В таблице ниже приведены наиболее важные параметры исходных данных для дальнейшего создания DVD-Video диска (здесь и далее мы считаем, что в качестве системы телевидения используется PAL):

Наименование | Значение
Размер кадра | 720х576, 704х576, 352х576, 352х288
Частота кадров | 25 кадров/сек
Соотношение сторон экрана | 4:3 или 16:9
Параметры GOP** (обязательно наличие заголовка). | 30 полей, 15 кадров
Максимальная скорость потока (видео+аудио) | 9,8 мбит/сек
Минимальная скорость потока (видео+аудио) | 2,0 мбит/сек
Максимальная скорость видеопотока, если в DVD проекте используется PCM звук. | 8 мбит/сек
Максимальная скорость видеопотока, если в DVD проекте используется Dolby Digital Stereo звук. | 9.4 мбит/сек
Формат звука | PCM (несжатый звук),Dolby Digital Stereo или 5.1, DTS (Digital Theatre System) и MPEG-1 Layer II ***

** GOP – Group of Pictures – дословно «группа изображений». MPEG поток всегда состоит из последовательных GOP. Каждая GOP начинается с опорного, или I-кадра, изображение в котором сжато без учета видеоинформации в соседних кадрах. Все остальные кадры GOP содержат только ту информацию, которой нет в I-кадре. DVD совместимый MPEG должен содержать только GOP с заголовками. В заголовке GOP указываются такие параметры, как скорость потока, размер GOP, соотношение сторон изображения и т.п.

*** Не рекомендуемый формат. Воспроизводится только на PAL DVD плеерах.

Если внимательно посмотреть на допустимые параметры видео и звука для DVD-Video, то несложно заметить, что от того, в каком формате записывается звук, например, зависит качество видео – если звук в PCM, то максимальный bitrate видео должен быть намного меньше, чем при кодирование звука в формат Dolby Digital. Кодирование же звука в формат MPEG-1 Layer II дает сравнимый с Dolby Digital bitrate звука, но само качество сжатого звука уступает Dolby Digital при том же bitrate.
Copyright © 1997-2003 Компания Сплайн, все права защищены.
Help file designed & created by Tools from Teko Films


DVD Info - Intro to DVD-Authoring

DVD своими руками: Создание меню

Введение

Записывающие DVD приводы становятся все более распространенными и все больше и больше людей начинают создавать DVD диски с собственными фильмами. Как мы неоднократно подчеркивали, наилучшими программами для DVD-Authoring являются ReelDVD и Scenarist, но у этих замечательных программ, в отличие от более дешевых, есть один существенный недостаток с точки зрения обычного пользователя меню для них надо создавать самому. Для максимального облегчения этого процесса, а также для того, чтобы меню делались правильно с точки зрения их последующего использования в программах DVD-Authoring и написана эта статья.

Прежде чем приступить к рассказу о подготовке меню, мы считаем, что у вас есть следующие программы:

  • Ulead Photoimpact 8 - мы ничего не имеем против Adobe Photoshop, но для создания DVD меню начинающими Photoimpact существенно более удобен. Тем не менее, практически все операции, описанные ниже, можно сделать и в Adobe Photoshop.

  • Ulead MediaStudio Pro версии не ниже 6.5

  • Ulead DVD Workshop - эта программа сама по себе нам не нужна, но при своей установке программа записывает на диск множество шаблонов меню, кнопок, фонов и т.п. После сохранения в другом месте всех файлов шаблонов, саму программу можно удалить. У всех файлов, имеющих нестандартные расширения имен файлов, следует изменить расширение имени на .ufo.

  • ReelDVD или Scenarist.


DVD Info - Still Menu Creation

DVD своими руками: Создание меню : Создание статичного меню

Создание статичного меню

Обычно статичное (still) меню используется как главное (Title или Root) меню. Сначала мы рассмотрим пример статичного меню как Root меню, т.е. главного меню DVD диска. Исходные данные:

  • В качестве фона используем кадр из фильма (если планируется в качестве фона использовать собственную композицию, то размер изображения должен быть 768х576)

  • В качестве элементов выделения используем:

    • подчеркивание текста

    • выделение текста рамкой

Итак, приступим. Сначала запускаем Ulead Photoimpact. Далее:

  1. В качестве фона загружаем кадр из фильма ...
  2. Уберем "гребенку" на его изображении ...
  3. Теперь нужно изменить размер картинки ...
  4. Далее следует перевести наш рисунок в категорию объектов ...
  5. Теперь наносим надписи на меню ...
  6. Теперь вводим собственно надписи меню ...
  7. Рисование элементов subpicture ...

  1. В качестве фона загружаем кадр из фильма, используя команду File/Open

    Для нашего примера выберем файл scanforstillmenu.bmp.

    Наверх

  2. Поскольку этот кадр брался из видеоряда, уберем "гребенку" на его изображении, применив фильтр Deinterlace:

    Наверх

  3. Теперь нужно изменить размер картинки с 720х576 на 768х576. Эта операция нужна для того, чтобы изображение фона и те изображения, которые мы нарисуем далее, при экспорте в программу DVD-Authoring изменились одинаково. Необходимость в ней возникает из-за того, что пиксель изображения в DV прямоугольный, а все графические редакторы работают с квадратными пикселями. Это немного утрированное объяснение, но смысл оно передает. Для изменения размера выбираем Format/Image Size и в появившемся окне выполняем изменения, показанные на рисунке:

    Наверх

  4. Далее следует перевести наш рисунок в категорию объектов, для того, чтобы он занял отдельный слой (layer) и его можно было включать/выключать. Предварительно следует нажать F10 для появления на экране панели Layer Manager, если до этого ее на экране не было. Теперь выбираем сначала Ctrl+A, чтобы выделить весь рисунок, затем Selection/Convert to Object:

    После выполнения этой операции в Layer Manager появится слой с нашей картинкой:

    Наверх

  5. Теперь мы готовы к нанесению надписей на меню. Для этого выбираем слева на панели операцию ввода текста, как показано на рисунке.

    После выбора появится панель атрибутов текста:

    В ней можно выбрать шрифт, его размер, цвет и, обратите внимание на крайний левый параметр, режим ввода текста. В нашем случае выбираем 3В Round. Photoimpact 8 имеет несколько режимов изображения текста, часть из них применяется для создания трехмерного текста и 3D round в том числе. Вы можете сами легко понять смысл всех режимов, просто меняя один на другой после ввода собственно текста. В нашем случае мы оставляем все настройки как показано на рисунке и вводим название нашего фильма вверху фона:

    Как вы видите, мы пока не вышли из режима работы с текстом и он остается выделенным. Теперь вы можете:

    1. Выбрать наиболее понравившуюся форму буквам текста, меняя режим в Mode

    2. Выбрать форму для всего текста, для чего нажать на панели справа соответствующую кнопку:

    3. В появившейся панели выбрать Deform Gallery и образец формы текста, который вам понравится, например, HT28, как на рисунке:

    4. В результате надпись смотрится заметно интереснее:

    5. После деформирования размеры слова могут быть изменены инструментом Transform Tool:

    Конечно, можно выбрать любой другой способ деформации текста, даже просто с помощью Transform Tool можно придать тексту любую форму. Чуть позже, в рассказе о других меню, мы покажем, как использовать тени для того, чтобы можно было писать любым цветом на любом фоне. В данном примере это не нужно, поскольку оранжевый цвет отлично смотрится и читается на синем фоне, не вызывая "факеления" на экране телевизора.

    Наверх

  6. Теперь вводим собственно надписи меню:

    Тем самым, картинка меню завершена:

    Наверх

  7. Наконец, пришло время для рисования элементов subpicture нашего меню. Попробуем создать выделение текста двумя способами - подчеркиванием и обводом. Сначала увеличим масштаб изображения до 300%

    Установим в File/Preferences/General шаг сетки, удобный для последующего ввода subpicture:

    Затем включим режим отображения сетки на экране либо нажатием Ctrl+Shift+R, либо выбором View/Guidelines&Grid/Grid:

    Рисуем первый вариант - подчеркивание элементов меню:

    1. Переводим режим рисования в Object Painting
      .
      Это необходимо для того, чтобы каждый элемент рисунка subpicture стал самостоятельным объектом в отдельном слое.

    2. Выбираем инструмент Кисть (Brush) для рисования линии.

      После выбора на экране появится панель управления параметрами кисти - Brush Panel. В ее закладке Shape установите толщину линии 6 пикселей (строго говоря, выбор толщины линии дело весьма субъективное, но по нашему опыту, для подчеркивания можно использовать 6 или 8, для обводки же лучше тоньше - 2), квадратную форму самой кисти и нулевое размытие (Soft Edge) края линии.

    3. В панели Options установить тип линии "прямая":

    4. В панели Color установить цвет, щелкнув по квадратику с цветом для появления панели выбора цвета:

      Если вы используете классическую панель Windows для выбора цвета, то в ней:

      В нашем случае, поскольку фон, на котором мы нанесем линии для subpicture, темный, мы выберем для рисования красный цвет. Цвет для subpicture в данном случае может быть любым из разрешенных. В программе DVD-Authoring затем можно будет легко изменить цвет при необходимости. Обращаем ваше внимание на то, что цвет для subpicture НИКОГДА НЕ СЛЕДУЕТ ВЫБИРАТЬ ИЗ ПАЛИТРЫ. В противном случае видимость subpicture программой DVD-Authoring не гарантируется (глаз человека вполне может ошибиться), поэтому следует вводить только числовые значение цвета в поля R (красный), G (зеленый) и B (синий).

    Теперь рисуем линии подчеркивания элементов меню:

    Нарисовав такие же линии под каждым элементом меню, мы создали необходимые элементы выделения в будущем меню DVD-Video диска. Проделаем аналогичные операции и создадим элементы выделения в виде рамок. Для этого выберем инструмент Outline Drawing Tool:

    Затем в поле Shape на Toolbar Photoimpact выберем форму рамки. Наиболее элегантно будет выглядеть прямоугольная рамка с закругленными краями:

    Рядом с полем Shape выберем цвет аналогично уже описанной процедуре выше. Теперь мы готовы к рисованию рамки. После создания первого варианта рамки на экране появится панель Path Panel, с помощью которой мы будем доводить рамку до желаемого вида:

    Сначала установим в закладке Outline Path Panel требуемую толщину линии. Мы рекомендуем для рамок вокруг текста выбирать толщину линии не более 2, в противном случае рамка будет выглядеть грубовато. Теперь надо изменить форму рамки на более приемлемую. Для этого выбираем закладку Shape в Path Panel и уменьшаем радиус закругления рамки:

    Как видно из рисунка выше, теперь рамка приняла вполне приемлемый вид. Нам осталось только выбрать панель Options в Path Panel для того, чтобы убрать Anti-aliasing у рамки (напоминаем, что рамка это элемент subpicture):

    Собственно рисование рамки завершено. Теперь следует преобразовать векторное изображение рамки в обычную точечную (bitmap) картинку. Для этого, выбрав курсором рамку, следует нажать правую кнопку мыши и в появившемся меню выбрать Convert Object Type/ From Text/Path to Image:

    После конвертации обязательно выберите с помощью Pick Tool рамку, а затем посмотрите на Toolbar Photoimpact и вы увидите, что у нашей рамки появился Soft Edge (сглаженный край), что совершенно недопустимо для subpicture, поэтому значение Soft Edge следует обязательно установить в 0:

    Было

    Надо

    На этом создание правильной для subpicture рамки закончено. Следует повторить процесс для каждого элемента меню. Завершаем разработку нашего Still Menu сохранением полученного файла как файла .ufo Ulead Photoimpact - это позволит нам легко исправлять в дальнейшем любые фрагменты нашего меню:

Наверх

Пока мы создали только проект меню. Для создания файлов, которые мы потом будем вводить в программу DVD-Authoring, следует проделать следующие операции:

- Изменение размера изображения с 768х576 на 720х576:

Далее, для сохранения фона следует в Layer Manager выключить слои с рамками (линиями):

Теперь мы можем сохранить фон меню как .bmp файл:

Для сохранения subpicture включаем слои с рамками (линиями) и выключаем с фоном и текстом - на экране должны остаться только рамки (линии):

Вот и все - мы получили фон для меню и subpicture для элементов выделения меню. Примеры, которые мы рассматривали, вы можете переписать здесь.

Несмотря на то, что мы подробно описали процесс создания Still (неподвижных) меню, мы не рекомендуем использовать их в чистом виде для DVD-Authoring. Наиболее правильным будет следующий процесс:

  1. Кладем созданный нами фон для меню на timeline видеоредактора

  2. Подкладываем под фон музыку, с возрастанием ее громкости в начале и затуханием в конце или без оного (по вкусу).

  3. Просчитываем проект собычными настройками для DV проекта.

  4. Обязательно через цифровую камеру или соответствующую видеомонтажную плату просматриваем результат на телевизоре.

  5. Корректируем картинку при обнаружении мерцания, "факеления" или каких-либо других артефактов изображения и повторяем пункты 1-4.

  6. Создаем итоговый .avi файл.

  7. Создаем MPEG-2 файл с минимально возможным для кодера MPEG-2 bitrate.

Полученное меню будет с точки зрения программы DVD-Authoring уже как Motion, но вы можете быть уверены, что при таком подходе вы не столкнетесь с неожиданностями после записи DVD диска.

Подведем небольшой промежуточный итог и еще раз повторим правила, обязательные для соблюдения при подготовке subpicture.

  1. Subpicture всегда рисуется линиями четной толщины.

  2. При настройке инструмента для рисования элементов subpicture следует запретить anti-aliasing, soft edge и любые другие возможности графического редактора, которые могут привести к неоднородности изображения subpicture.

  3. Для subpicture могут использоваться только четыре чистых цвета - красный, черный, синий и белый.

  4. Цвета могут вводиться только с помощью числовых значенийдля R, G и B. Коды цветов subpicture таковы:
    Красный: R=255, G=0, B=0
    Синий: R=0, G=0, B=255
    Черный: R=0, G=0, B=0
    Белый: R=255, G=255, B=255

Наверх


DVD Info - Still Episode Menu

DVD своими руками: Создание меню : Создание статичного меню эпизодов

Создание статичного меню эпизодов

Мы разобьем описание этого процесса на две части:

  1. Самая простая - адаптация готового меню из Ulead DVD Workshop для вставки в DVD проект.

  2. Использование только фрагментов меню из Ulead DVD Workshop.

Итак, первая часть - простая адаптация готового меню под свой фильм.

  • Оформление

    Загружаем в Ulead Photoimpact меню из директории Menu\Romance\Ru008.ufo (можно любой образец, разумеется - никакой разницы нет, это просто для примера):

    Как видно из рисунка меню, оно вполне подходит для фильма об отпуске где-нибудь на море. Сначала приготовим картинки из фильма для размещения в рамках. Предварительно для каждой картинки следует проделать операции, описанные в разделе Создание статичного меню (пп.1-5). Сначала узнаем размер самой рамки, выделив ее инструментом Pick Tool и выбрав по правой кнопке мыши Properties:

    Затем размер каждой картинки меняем в нашем случае на 139/104 пикселя (эти размеры для каждого шаблона меню следует подбирать экспериментально, поскольку размеры рамок варьируются в зависимости от из дизайна и количества рамок в меню, но по опыту можно сразу сказать, что по сравнению с размерами самой рамки, уменьшать размер вставляемой картинки надо минимум на 20-30 пикселей).

    Теперь выделяем картинку инструментом Pick Tool и по правой кнопке мыши копируем ее в буфер командой Copy. Затем щелкаем в любом месте нашего меню и по правой кнопке мыши вставляем нашу картинку в меню командой Paste:

    После совмещения картинки из фильма и рамки мы обнаружим, что картинка находится поверх рамки, что, разумеется, неправильно. Для того, чтобы картинка оказалась под рамкой, следует выделить картинку инструментом Pick Tool и по правой кнопке мыши выбрать Arrange/ Send Backward (тоже самое еще проще сделать нажатием Alt+Down) и тем самым переместить картинку на один слой вниз.

    Эту операцию следует проделать несколько раз, до тех пор, пока картинка окажется под рамкой:

    Те же действия следует проделать со всеми картинками для нашего меню (в данном случае их 6).Надписи под кадрами из эпизодов и общее название меню делается простым выбором инструмента Text (T) и изменением надписей Enter text here... на требуемые названия. Кроме этого, можно заменить текст 99/99 на те цифры, которые необходимы для вашего меню. На этом собственно оформительская часть работы закончена. Теперь нам нужно создать subpicture для нашего меню.

    Наверх

  • Создание subpicture

    Наиболее удобно использовать в качестве элементов выделения эпизодов рамки вокруг картинок из фильма. Но, как мы видим, эти рамки довольно причудливой формы. Тем не менее, сделать subpicture для такой рамки не представляет собой ничего сложного. Опишем последовательность действий для этого:

    1. Выделяем инструментом Pick Tool рамку и по правой кнопке мыши выбираем сначала Copy, затем Paste. В результате на экране появится еще одна рамка. Залить эту рамку одним цветом сразу не получится, поэтому вначале придется проделать с ней некоторые преобразования.

    2. Выделив новую рамку инструментом Pick Tool, применяем команду Format/Color Adjustment и "заливаем" рамку белым цветом (эту операцию можно выполнить и другими способами - этот выбран просто как один из них):

      Теперь рамка готова к "заливке" нужным цветом для subpicture.

    3. Заливаем рамку чистым красным цветом:

    На первый взгляд, все нормально - рамка залита сплошным красным цветом. Но давайте проверим, так ли это. Выделим рамку инструментом Pick Tool и по правой кнопке мыши выберем Image Optimizer. В появившемся меню выберем Mask Options, инструмент Eyedropper и применим его к нашей рамке:

    Результат плачевный - если рамку оставить в таком виде, то и в меню DVD фильма рамка будет смотреться как изрешеченная пулями, что меню, несомненно, не украсит. Выбрав в меню Image Optimizer кнопку Cancel, возвращаемся к рамке. Что очевидно является дефектом для subpicture по изображению рамки в правом окне Image Optimizer? Конечно же тени, которые раньше мы просто не заметили. Для ликвидации теней выделим рамку инструментом Pick Tool, затем, по правой кнопке мыши, выбираем Shadows - и в появившемся меню выключаем тени:

    Но тени не дали бы "пятнистой" картинки. Снова выделяем рамку инструментом Pick Tool и смотрим внимательно на верхнюю панель инструментов редактора - так и есть, в параметре Soft Edge значение 1. Убираем его в 0:

    Проверяем результат в Image Optimizer:

    Теперь все отлично - subpicture из нашей сложной рамки получилась идеально. Осталось только просто размножить созданную нами subpicture еще в 5 экземплярах командами Copy и Paste, совместить их с оригинальными рамками и все.

      • Наверх


DVD Info - Motion Episode Menu

DVD своими руками: Создание меню : Создание статичного меню эпизодов

Создание динамичного (motion) меню эпизодов

В качестве готовой рамки возьмем созданный нами ранее шаблон для статичного меню, так как подготовка шаблонов для динамичного меню абсолютно ничем не отличается от подготовки шаблона к статичному меню. Разница возникает потом - вместо статичных изображений в окнах шаблона будут показываться видеоклипы.

Предварительно отключим слои, на которых у нас были нарисованы subpicture и, тем самым внешне фактически вернемся к оригинальному меню из шаблонов от DVD Workshop.

Обратите внимание на белые прямоугольники, которые были в этом шаблоне и которые мы раньше не удалили. Теперь они нам пригодятся (они есть во всех шаблонах меню от DVD Workshop). Инструментом Pick Tool выделите верхний левый белый прямоугольник и затем инструментом Fill Tool залейте белый прямоугольник чистым синим цветом (B=255, R=0, G=0).

Повторите эту операцию для всех окошек меню. В результате получим такой шаблон:

Теперь изменим командой Format/Image size размер шаблона с 768х576 на 720х576, (напоминаем, что галку Keep aspect ratio надо обязательно снять). Сохраним полученное изображение как .bmp файл.

Запустим видеоредактор Ulead MediaStudio Pro 7.0. Откройте в нем новый проект. Проверьте настройки нового проекта и увеличьте количество оверлейных дорожек (Overlay tracks) до 7. На оверлейные дорожки с V1 по V6 положите те клипы, которые по вашему плану должны проигрываться в окошках нашего динамичного меню. Для удобства клип для первого окошка лучше положить на V1, для второго на V2 и т.д. Шаблон (полученный ранее .bmp файл) для меню положите на дорожку V7 и (обращаем ваше внимание на этот факт) на дорожку Va. Потом мы увидим, почему шаблон вводится в проект на две дорожки вместо одной. На экране возникнет такая картина:

Щелкнем мышью по дорожке V7 и далее по правой кнопке мыши выберем Overlay Options. В появившемся диалоге щелкнем мышью по любому из синих прямоугольников. Они станут прозрачными, но не полностью. Подбором параметра Similarity сделаем прямоугольники полностью прозрачными. Как правило, значение Similarity получится не более 15. В результате мы получим такую картинку:

Сейчас во всех окошках можно увидеть только фрагменты одного кадра одного клипа, а именно клипа на дорожке V6. Начнем настройку проекта с клипа на дорожке V1. Бросим на этот клип Moving Path 2D Basic, уменьшим размер кадра ровно в 16 раз (отметив параметр Keep aspect ratio, конечно), или, что тоже самое, каждую сторону кадра в 4 раза до 180х144 и наложим мышью, двигая клип за точку S, на первое окошко меню картинку клипа. Никакой особой точности здесь не требуется, поскольку ни один зритель на таком маленьком по размеру изображении не определит его истинный центр. Важно, чтобы рамка окошка просто была полностью закрыта. Результат показан на рисунке ниже:

Теперь, надеемся, вам стало понятно, зачем шаблон меню положен и на дорожку Va. Если бы мы так не сделали, то совмещение клипа и шаблона пришлось бы делать вслепую. Скопируем настройки для первой ключевой точки в последнюю командой копирования ключевой точки и нажмем ОК. Работа с первым клипом закончена. Очевидно, что все эти действия занимают не больше пары минут. Проделаем те же операции для клипов на дорожках V2-V6. Результат уже на клипе V6 будет таким:

Сейчас пришло время просмотреть результат. Мы настоятельно рекомендуем сделать это на телевизоре, поскольку только на нем вы сможете заметить возможный брак. Результат в окне предварительного просмотра редактора будет выглядеть так:

Если при просмотре на телевизоре какие-то клипы будут "мерцать", поскольку мы существенно уменьшили размеры кадров, примените к этим клипам операцию удаления одного поля, т.е. Deinterlace. Для этого по правой кнопке мыши выберите Media Source Options, поставьте галку у Deinterlace, затем нажмите кнопку ОК:

Вот и все. Создание динамического (motion) меню завершено. Как видите, эта операция не заняла много времени. Разобравшись в этом один раз с помощью настоящей статьи, в дальнейшем вы не будете тратить больше 5-10 минут на такое меню. Subpicture для динамичного меню абсолютно ничем не отличается от subpicture к меню статичному, поэтому никаких дополнительных знаний здесь не требуется.

Результат работы вы можете посмотреть здесь. Вместо клипов, которые были здесь использованы, вы можете применить свои, просто заменив их.


DVD Info - Motion Episode Menu - Final

DVD своими руками: Создание меню : Создание статичного меню эпизодов

Заключение

Мы надеемся, что приобретенный опыт поможет вам избежать "боязни" самостоятельного создания меню. Как видите, ничего страшного в этом нет и не имея совершенно никаких художественных способностей, пользуясь двумя распространенными программами, Ulead Photoimpact 8 и Media Studio Pro 7.0, вы легко можете создать профессионального вида меню.


DVD Info - Soft intro

DVD своими руками: Обзор программ

Коротко о многом

Теперь мы можем перейти к краткому анализу наиболее популярных программ для DVD Authoring. Как и всякий другой подобный анализ, он частично субъективен, но тем не менее:

Программы для тех, кто не хочет тратить время на создание DVD-Video диска

Ulead MediaStudio Pro 6.5 – в части создания DVD очень прост, практически не имеет никаких степеней свободы для автора, но поэтому этапа освоения не имеет и сделать на нем DVD диск может любой новичок.

Достоинства:

  • Не требуется навыков и знаний для создания DVD.

  • Быстрота работы – на подготовку меню уйдет 10-15 минут и можно записывать диск.

  • Поддержка VCD, SuperVCD, XSVCD.

Недостатки:

  • Фильм должен состоять только из одного файла (не считая короткого вступительного), причем поддерживается только формат MPEG Program Stream (video+звук в одном файле).

  • Никакие иные форматы видео и звука не поддерживаются.

  • Меню нельзя озвучить.

  • В меню могут быть только кадры из фильма в качестве кнопок и только к тому месту, откуда взяты эти кадры, может быть переход.

  • Без входа в меню просмотр фильма невозможен.

  • На некоторых DVD плеерах меню не работает.

SpruceUP– программа начального уровня. Степеней свободы также немного, но несколько больше, чем у Ulead MediaStudio Pro 6.5. Но с этой программой только механическим нажатием Next сделать DVD диск нельзя и придется выполнить несколько самостоятельных действий. К сожалению, фирма-разработчик программы Spruce Technologies в 2001 году была приобретена компанией Apple и дальнейшего развития этой и ряда других программ линии Spruce больше не будет.

Достоинства:

  • Не требуется серьезных знаний для создания DVD.

  • Поддержка звука в формате Dolby Digital (AC-3). Собственного кодера в Dolby Digital программа не имеет, но допускает использование файлов ac3.

  • Возможно применение кнопок управления собственного дизайна.

  • Для индикации главы (chapter) возможно использование любого кадра фильма.

Недостатки:

  • Фильм должен состоять только из одного файла, так как не задается последовательность проигрывания файлов. По окончании проигрывания каждого файла происходит возврат в меню.

  • Может сделать некорректный для бытового DVD плеера диск, который будет нормально воспроизводиться только на компьютерном DVD-ROM.

  • Без входа в меню просмотр фильма невозможен.

Ulead DVD Movie Factory– более «продвинутый» вариант DVD Plug-in к Ulead MediaStudio Pro. Допускает использование нескольких файлов, позволяет озвучивать меню. Имеет встроенный кодировщик MPEG. В остальном практически идентичен DVD Plug-in.

Программы для продвинутых любителей

Sonic DVDiT Professional Edition 2.5.2– эта программа, несмотря на свою простоту, имеет ряд существенных отличий от программ начального уровня.

Достоинства:

  • Не требуется серьезных знаний для создания DVD.

  • Интуитивно понятный интерфейс.

  • Поддержка звука в формате Dolby Digital Stereo. Имеет встроенный кодировщик звука в этот формат.

  • Возможно применение кнопок управления, фонов, текста и т.п. собственного дизайна.

  • Для индикации главы (chapter) возможно использование любого кадра фильма или любой иной картинки.

  • Фильм может состоять из множества файлов, причем последовательность проигрывания легко определяется пользователем при создании диска.

  • Допускается иерархическая структура из нескольких меню.

  • Просмотр всего фильма, включая вступительный клип (First Play), возможен без перехода в меню.

  • Каждое меню может иметь свое звуковое сопровождение.

  • Возможность указания координат chapters (глав) через таймкод.

Недостатки:

  • Не поддерживает шестиканальный звук Dolby Digital AC-3 (т.е. 5.1).

  • Не поддерживает motion menu.

Ulead DVD Workshop 1.3– внешне выглядит как программа, обладающая многими возможностями профессиональных продуктов, но на самом деле она никак не может быть отнесена к программам серьезного класса.

Достоинства:

  • Не требует серьезных знаний для создания DVD.

  • Интуитивно понятный интерфейс.

  • Поддержка звука в формате LPCM.

  • Каждое меню может иметь свое звуковое сопровождение.

  • Встроенный кодировщик в MPEG.

  • Возможно применение кнопок управления, фонов, текста и т.п. собственного дизайна.

  • Для индикации главы (chapter) возможно использование любого кадра фильма или любой иной картинки.

  • Фильм может состоять из множества файлов, причем последовательность проигрывания определяется пользователем при создании диска.

  • Поддерживаются motion menu.

  • Поддерживается сжатие звука в формат Dolby Digital Stereo при upgrade Workshop до версии AC-3.

Недостатки:

  • После проигрывания вступительного клипа всегда выполняется переход в меню.

  • На некоторых DVD плеерах меню не работает.

  • Вид меню может быть только довольно однообразным – прямоугольные окна для фрагментов видео/стоп-кадра фильма. Иной вид требует заметного объема ручной работы от автора.

Dazzle DVD Complete– программа практически соответствует Ulead DVD Workshop 1.3, но отличается несколько большими возможностями по дизайну меню. С другой стороны, DVD Complete более сложна для понимания, чем DVD Workshop.

Программы для профессионалов и очень продвинутых любителей

Sonic (ранее Daikin) ReelDVD 2.5.1/3.02– программа полупрофессионального уровня. Оперирует с subpicture, поэтому возможности по дизайну диска велики.

Достоинства:

  • Не требует серьезных знаний для создания DVD.

  • Интуитивно понятный интерфейс.

  • Встроенный кодировщик Dolby Digital Stereo и возможность использования Dolby Digital 5.1.

  • Поскольку меню создается либо в графическом, либо в видеоредакторе, то дизайн меню ограничен только фантазией автора.

  • Фильм может состоять из множества файлов, причем последовательность проигрывания определяется пользователем при создании диска.

  • Автор может запрограммировать действия пользователя по нажатию всех кнопок управления пульта ДУ DVD плеера.

Недостатки:

  • Требует понимания принципов работы DVD плеера.

  • Освоение программы только по описанию к ней очень затруднено

Sonic (ранее Daikin) Scenarist NT 2.5/2.7– программа профессионального уровня. Кратко можно сказать так – умеет все. Недостаток только один – программа несколько сложна в понимании и освоении.

Так на чем же работать?

Этот краткий обзор программ для DVD-Authoring, безусловно, не претендует на полноту, мы рассказали только о самых известных программах на рынке. Возникает резонный вопрос – какую программу выбрать для создания своих DVD-Video дисков? По нашему мнению, существуют 3 варианта такого выбора:

  • Никакого желания тратить на создание DVD-Video диска больше 15 минут нет – в этом случае наиболее правильным выбором будет применение Ulead DVD Movie Factory. Все просто и понятно, даже задумываться ни о чем не нужно.

  • Хочется сделать просто диск с фильмом, никаких меню не надо делать, но диск должен проигрываться целиком, без перехода к каким либо меню – в этом варианте прощен всего использовать Sonic DVDiT Professional Edition 2.5.2. Как не странно, эта программа не сложнее программ начального уровня, но позволяет просто связать несколько различных клипов и, сделав одно символическое (фантомное) меню, просто положить ваш фильм на DVD диск, легко обеспечив его непрерывный просмотр.

  • Я не ищу легких путей, хочу сделать свой DVD диск не менее интересным, чем мой фильм на этом диске – в этом случае только ReelDVD или Scenarist NT позволят вам создать любой дизайн вашего диска.

По поводу последнего пункта хотелось бы рассказать несколько подробнее – по нашему мнению, ReelDVD закрывает 95% потребностей как любителей, так и ряда профессионалов для создания своих проектов. Конечно, Sonic Scenarist NT может еще больше, но его интерфейс несколько менее нагляден и те его возможности, которыми он отличается от ReelDVD, могут никогда не потребоваться. Освоение же ReelDVD в случае необходимости намного облегчит переход к Sonic Scenarist NT, поскольку программы эти во многом похожи и можно легко перенести свой проект из ReelDVD в Sonic Scenarist NT, и такая возможность предусмотрена авторами обеих программ. Именно поэтому мы выбрали программу ReelDVD для более подробного рассказа. Освоение таких программ, как Ulead DVD Workshop или Dazzle DVD Complete нецелесообразно, на наш взгляд, поскольку временные затраты на этот процесс будут не меньше, чем в случае с ReelDVD, но возможности по созданию DVD останутся существенно ограниченными.


DVD Info - Soft intro - ReelDVD

DVD своими руками: Обзор программ: ReelDVD - Введение

ReelDVD - Руководство к применению

Итак, мы приступаем к изучению очень удобной и богатой по своим возможностям программы ReelDVD версии 2.5.1/3.03. Обращаем ваше внимание на то, что значком (!!!) будет отмечаться текст, особенно важный для понимания работы программы.

После запуска программы на экране появится ее главное окно:

где:

Проводник - в этом окне, идентичном окну обычного проводника Windows, мы должны (и будем) видеть файлы, участвующие в проекте.

Монтажный стол - сюда мы будем перетаскивать все файлы нашего проекта из окна Проводника.

Timeline или Track Editor - при выборе мышью любого элемента проекта на Монтажном столе здесь появится его представление приблизительно того же вида, что и в любом редакторе видео. Конечно, Timeline в ReelDVD не сравнима с аналогичной timeline по решаемым с ее помощью задачам в видео редакторе, но некоторые возможности по редактированию все-таки есть и мы ознакомимся с ними подробнее немного позже.

Редактор кнопок и он же плеер - самый насыщенный различными функциями элемент ReelDVD. Когда кнопка в его левом нижнем углу красного цвета, то это редактор кнопок, когда зеленого - то это плеер для просмотра проекта. Меняется цвет (и функции соответственно) по нажатию на кнопку мышью. Подробнее мы рассмотрим работу редактора кнопок позже.

Из всех команд меню программы, которые расположены в левом верхнем углу ее окна, стоит пользоваться только одной - Edit/Project Settings, поскольку почти все остальные команды выбираются мышью по месту их применения. Итак, выбираем команду Edit/Project Settings:

(!!!) - Все установки проекта необходимо сделать ДО ввода любого файла в проект. В противном случае, практически все изменения, которые вы внесете по этой команде, реально не окажут никакого действия, хотя внешне значения параметров в Edit/Project Settings и изменятся.

Закладка Project, пожалуй, сейчас единственная, в которой следует что-то изменить. Здесь:

  • Disc Name - указывается имя диска. Можно задать любое, а в нашем примере выбрано TAILAND.

  • TV System - здесь мы выбрали PAL, конечно. После выбора системы телевидения программа автоматически установит поля Video Format (формат видео), Aspect Ratio (соотношение сторон) и Size (размер в пикселях) для PAL. Изменять их следует только в том случае, если ваш фильм снят не в 4:3, а в 16:9.

  • Audio Encoding Type - указывает вид сжатия звука. На этом параметре программы следует остановиться немного подробнее. Дело в том, что сама программа умеет кодировать звук только в формат Dolby Digital Stereo, который мы и рекомендуем использовать в большинстве случаев. Если мы выберем в этом поле Dolby Stereo, то любой звук, введенный вами в проект, будет перекодирован программой в Dolby Stereo. В противном случае, при выборе в этом поле As is (как есть), звук останется в том же виде, в котором вы его ввели в проект. Ввести можно звук в любом Dolby Digital (в том числе и 5.1), в PCM и MPEG форматах, удовлетворяющих требованиям к DVD - т.е. как минимум 48 000 Hz, 16 bit.

  • Audio Encoding Rate - этот параметр доступен только при выборе Dolby Stereo в качестве вида кодирования звука. Мы рекомендуем устанавливать bitrate кодирования в 192 килобит/секунду.

  • Image Encoding Rate - параметр определяет bitrate для кодирования в MPEG-2 формат статичных или Still Menu. Поскольку DVD плеер понимает только видео в соответствующем формате MPEG, то любые статичные меню также реально превращаются в видеоклип. Поэтому здесь и указывается параметр bitrate для кодирования статичных меню. Разумным значением будет не более 6.0 Mbps, поскольку с ростом bitrate будет увеличиваться и объем файлов с статичными меню.

По завершении изменений рекомендуется нажать кнопку Save as Default, все параметры сохранятся и в будущем нужно будет менять только имя проекта.


DVD Info - Soft intro - ReelDVD - First Disc

DVD своими руками: Обзор программ: ReelDVD - Диск без меню

Первый опыт - диск без меню

После установки параметров проекта мы готовы к работе. Для начала создадим самый простой DVD-Video диск - без меню. Т.е. после установки диска в плеер фильм можно будет просто просмотреть. Наш фильм будет состоять из вступительного клипа (далее просто FirstPlay) и двух клипов. Все они должны быть проиграны последовательно.

(!!!) - уже начиная с этого простого примера, надо привыкнуть к простому правилу - все клипы вводятся в проект в том же порядке, в котором они должны будут потом проигрываться. Ничего криминального в нарушении этого правила нет, но это выполнение этого правила приводит к правильной индикации при проигрывании диска на дисплее DVD плеера. Можно, конечно, применить команду Track/Sort track, но о нарушении порядка часто забываешь, поэтому лучше придерживаться этого простого правила.

(!!!) - ReelDVD понимает только отдельные файлы видео и аудио, т.е. MPEG Elementary Stream. Вы можете импортировать любой MPEG файл, удовлетворяющий требованиям к DVD-Video и любой аудио файл, удовлетворяющий следующим требованиям:

Тип звука | Вид параметры | Значение
Dolby Digital (AC-3) | Формат | AC-3
 | Количество каналов | 2 (stereo), 5.1
 | Частота дискретизации | 48 KHz
 | Bitrate | 192 Kbit/s стерео 448 Kbit/s surround
PCM audio (не компрессированный звук) | Формат | AIFF, WAVE
 | Количество каналов | 2 (стерео)
 | Частота дискретизации | 48 KHz
 | Разрядность | 16-bit или 24-bit
 | Bitrate | 1.536 Mbit/s 16-bit 2.304 Mbit/s 24-bit
MPEG audio | Формат | MPEG audio
 | Количество каналов | 2 (стерео)
 | Частота дискретизации | 48 KHz
 | Bitrate | 224 Kbit/s

Если используемый вами кодировщик MPEG создает файл видео+аудио, то его до импорта в ReelDVD следует разделить на видео и аудио файлы программой TMPGenc или любой аналогичной.

В соответствии с правилом, описанным выше, сначала перетаскиваем файл с FirstPlay на монтажный стол, затем файл звука к нему перетаскиваем на икону с FirstPlay, затем файл первого клипа и звук к нему, затем второй клип и его звук. Если звук в отличном от Dolby Digital формате, то программа автоматически перекодирует звук в формат Dolby Digital. По завершении этих операций монтажный стол примет такой вид:

Рассмотрим подробнее новые элементы на монтажном столе:

Когда мы вводили первый клип, программа сама соединила кнопку [image] с FirstPlay (поскольку мы ввели его первым) и тем самым дала понять, что после включения плеера (кнопка выглядит именно как кнопка Power) будет проигрываться клип DVDFirstPlay.m2v. Внизу кнопки зажегся зеленый индикатор и, если впоследствии потребуется изменить назначение FirstPlay, надо будет просто подвести курсор к этому индикатору, нажать левую кнопку мыши и соединить кнопку с другим клипом.

Каждый клип на монтажном столе оказался в рамке. Рамка у клипа появилась отнюдь не для украшения, а как элемент управления проигрыванием клипа. Три стороны рамки служат для назначения команд пульта DVD плеера и последовательности проигрывания применительно к каждому клипу. Рисунок ниже показывает, какие именно команды могут быть назначены:

Использовать эти команды чрезвычайно просто. В нашем первом примере от диска требуется просто последовательное проигрывание клипов. Для этого подводим курсор мыши к стороне Next клипа FirstPlay. У курсора появится слово NXT и стрелка вправо. Нажимаем левую кнопку мыши и соединяем поле Next клипа FirstPlay с полем Previous клипа ThaiPart1. Проделываем ту же операцию для клипа ThaiPart1. Таким образом мы установили последовательность проигрывания клипов. Если мы хотим, чтобы фильм проигрывался до тех пор, пока зритель не нажмет кнопку Stop, соединим поле Next последнего клипа ThaiPart2 с полем Previous первого клипа фильма ThaiPart1. Поле Return каждого клипа в данном случае удобно использовать для перехода в начало фильма, поэтому соединим поле Return клипов ThaiPart1 и ThaiPart2 с полем Previous клипа ThaiPart1. Таким образом, нажав кнопку Return на пульте ДУ плеера, зритель всегда перейдет к началу фильма. По завершении всех соединений монтажный стол примет такой вид:

Для проверки правильности выполненных действий включите плеер программы (нажав на кнопку [image] и убедитесь, что все назначенные вами команды правильно отрабатываются.


DVD Info - Soft intro - ReelDVD - Still menu

DVD своими руками: Обзор программ: ReelDVD - Создание обычных (still) меню

Создание обычных (still) меню

Возможности по созданию меню у ReelDVD очень велики и именно это отличает программы такого класса от остальных. Для того, чтобы понять, как делать меню в ReelDVD, причем строго говоря, вне зависимости, Still это или Motion меню, совершим небольшой экскурс в DVD технологию.

Установите любой коммерческий DVD-Video диск в DVD плеер и посмотрите внимательно, как выглядит меню на экране телевизора. Вы обнаружите, что выбор в меню - это всегда выделение слова или изображения на экране. Это выделение может выполняться десятками способов - рамкой вокруг текста или картинкой, изменением цвета текста и/или цвета и фона вокруг, и т.п.

Возникает резонный вопрос - как плеер узнает, каким образом и что именно надо выделить? Ответ на этот вопрос на самом деле довольно простой. При генерации DVD диска к видеопотоку файла меню (как уже мы обсуждали ранее, любые меню есть видеоклипы в конечном итоге) добавляется еще один - subpicture stream и именно в нем программа DVD-Authoring сообщает DVD плееру инструкции по обработке меню. Это несколько утрированное объяснение, но оно близко к реальной действительности. В ReelDVD как раз и можно создать subpicture stream, причем по своему усмотрению, без массы жестких ограничений, накладываемых в тех программах, где созданием subpicture автор управлять не может.

Несмотря на то, что название subpicture stream говорит о некоем потоке, на самом деле subpicture есть простое графическое изображение, а слово stream (поток) просто подчеркивает то, что subpicture применяется ко всему видеоклипу меню. Но все объяснения сущности subpicture бессмысленны без конкретных примеров, поэтому мы сейчас поясним принципы использования subpicture на примере конкретного меню (вы также можете ознакомиться с подробным руководством по созданию меню в статье Создание меню для программ DVD-Authoring).

Мы попробуем сделать стартовое меню диска таким:

А выделение разделов меню сделаем белыми овалами, нарисованными тонкими линиями, т.е. выбранный пункт меню будет обведен белой линией. Для создания такого меню надо выполнить следующие действия:

  1. В любом графическом редакторе (лучше всего использовать Adobe Photoshop версии 5 и выше или Ulead Photoimpact 7) следует создать изображение фона меню размером 768х576. При нарисовании фона для меню можно пользоваться любыми инструментами, цветами и т.п. Никаких ограничений здесь не существует. Слой, на котором рисуется фон, лучше назвать background.

    (!!!) - обращаем ваше внимание на то, что если изображение для ввода в DVD проект (это же относится, кстати, и к подготовке графических изображений для видеоредакторов) готовится в графическом редакторе с "нуля", то его размер должен быть 768х576, а не 720х576. Это связано с тем, что графические редакторы используют квадратные пиксели, а в DV видео используются пиксели прямоугольные. Поэтому, после завершения работы над меню, все необходимые для ReelDVD файлы следует сохранить в размере 720х576, предварительно сняв галку с параметра Keep aspect ratio (название зависит от конкретного редактора, может быть и constrain proportion, например), т.е. без сохранения пропорций сторон. В противном случае изображение будет немного, но искажено. Подробнее об этом можно прочитать здесь. Оригинал при этом не надо изменять, поскольку вам может потребоваться его корректировка в процессе работы над диском.

  2. В отдельных слоях, которым следует дать нормальные имена, отражающие смысл кнопок, рисуем овалы вокруг надписей - именно этот рисунок и есть в данном случае subpicture.

    (!!!) - subpicture имеет определенные ограничения на то, как она создается. Ограничения следующие:

    • любой рисунок создается с использованием только трех чистых цветов - красного, синего и черного. Белый цвет понимается ReelDVD как прозрачный фон. Слово "чистый" означает, что в цифрах синий цвет, например, будет выглядеть так: Red=0, Green=0 и Blue=255. Наилучший цвет для элементов выделения - черный. Потом этот цвет можно будет легко изменить в ReelDVD, о чем мы поговорим позже. В нашем примере мы использовали черный цвет для рисования овалов.

    • необходимо отключить все antialiasing (сглаживание) функции в графическом редакторе.

    Картинка с овалами будет выглядеть так:

    Далее все просто - выключаем слои с овалами и сохраняем как .bmp файл фоновое изображение, затем выключаем слои фона и сохраняем только овалы (все) в другом .bmp файле. На этом подготовка меню закончилась. Вы можете скачать итоговый файл с этим примером (600 КБайт) в формате Adobe Photoshop.


DVD Info - Soft intro - ReelDVD - Motion menu

DVD своими руками: Обзор программ: ReelDVD - Создание Motion menu

Создание Motion menu

Motion меню отличается от still тем, что на экране зритель видит один или несколько видеоклипов на каком либо фоне или просто видеоклип, на фоне которого размещены кнопки навигации. Для ReelDVD motion menu по технологии создания ничем не отличается от still меню. Просто subpicture накладывается не на неподвижное графическое изображение, а на видеоклип. Этапы создания motion меню таковы:

  • В любом видеоредакторе создается желаемый видеоклип. Пример фактически самого популярного вида подобного клипа, используемого для выбора эпизодов фильма:

    • Здесь в четырех окошках прокручивается одновременно по 40 секунд каждого фрагмента, и общее время проигрывания клипа тоже, естественно, 40 секунд.

  • Создается .bmp файл из любого кадра клипа. Этот кадр нам нужен для шаблона, на котором мы будем рисовать кнопки навигации в меню.

  • Готовый клип кодируется в MPEG-2

  • Сделанный ранее кадр из клипа загружается в графический редактор и на нем в отдельных слоях создаются кнопки из текста, как показано на рисунке:

    • Цвет букв белый только ради того, чтобы его было видно на этом рисунке в статье. На самом деле текст в subpicture набран тоже черным цветом. Поскольку в случае Motion меню фон уже есть (это видеоклип), то следует сохранить в .bmp файл только кнопки-текст. Никакого изменения размеров не нужно делать, поскольку кадр был взят в разрешении 720х576.

    Вот и все, работа над Motion меню закончена и файл этого меню в формате Adobe Photoshop вы можете переписать здесь (размер 1.7 мегабайта).

Завершение работы над диском. Нам осталось познакомиться с самой увлекательной частью работы над диском - связывание проекта в единой целое и завершение дизайна наших меню.


DVD Info - Soft intro - ReelDVD - Chapter mark

DVD своими руками: Обзор программ: ReelDVD - Расстановка chapters (глав)

Расстановка chapters (глав)

Для примера используем наш первый проект, который был создан нами пока без меню:

Прежде чем ввести меню в проект, необходимо разметить хотя бы один клип на главы (chapters). Сделать это можно двумя способами:

  1. Определить нужные главы еще на этапе создания собственно фильма, записав таймкоды для них. Это наиболее правильный и точный способ.

  2. Задать chapters непосредственно в ReelDVD. Этот способ менее удобный, поскольку в любой программе DVD-Authoring расстановка chapters делается довольно неуклюже, хотя ReelDVD далеко не самая худшая программа в этом плане.

Для расстановки глав сначала надо выбрать клип на монтажном столе, в котором будут расставляться главы.

(!!!) - Для правильной индикации chapters (глав) на дисплее DVD плеера следует расставлять главы сначала в первом клипе фильма, затем во втором и т.д. Внутри клипа расстановку следует делать также строго последовательно. Если вы ошиблись и пропустили главу, после которой уже были сделаны другие главы, следует удалить последующие главы, отметить пропущенную и снова отметить удаленные ранее.

(!!!) - Motion меню, несмотря на то, что это тоже видеоклипы, в соответствии с требованиями DVD спецификации, НЕ могут быть разбиты на главы.

(!!!) - При разбиении на главы Редактор кнопок и плеер будет всегда работать в режиме показа кадров, выбранных навигатором, независимо от того, в каком режиме он находился до этого.

После его выбора в окне timeline (он же Track Editor) мы увидим:

где:

- навигатор по клипу. При перемещении его по timeline будет соответственно меняться и изображение на плеере программы. Для появления навигатора в любом месте клипа нет необходимости тащить его от начала - достаточно удерживая клавишу Ctrl, щелкнуть мышью в нужном месте и навигатор появится.

- указатель chapter в клипе. Первоначально всегда установлен на первом кадре клипа, поскольку первый кадр всегда начинает главу.

- кнопка указания языка для аудиопотока. Если аудиодорожка только одна, то здесь может быть символ любого языка, но в любом случае можно нажать на эту кнопку и в появившемся окне выбрать язык Russian. Мы рекомендуем всегда устанавливать правильный язык, иначе при нажатии кнопки Audio или Subtitle ваш зритель с удивлением обнаружит какой-нибудь японский язык, которого на самом деле нет. Еще более правильным является установка русского языка в Edit/Project Settings/Languages и последующее нажатие кнопки Save as Default.

- кнопка отметки главы. После определения местоположения главы нужно просто нажать на эту кнопку.

- кнопка создания нового аудиопотока. Всего клип может иметь 3 звуковых дорожки в ReelDVD. Если поток всего один, то для его создания удобнее всего просто перетащить аудиофайл проводником на икону клипа.

- кнопка создания нового потока subpicture. Всего клип может иметь 3 потока subpicture. 3 потока используются только при необходимости размещения субтитров на DVD диске. Для создания меню нет необходимости в нескольких потоках subpicture. Если поток всего один, то для его создания удобнее всего просто перетащить файл subpicture проводником на икону клипа.

- кнопка для ввода субтитров. После ее нажатия появляется окно, в котором можно набрать нужный текст субтитров.

- кнопки с плюсом и минусом служат для изменения масштаба изображения на timeline.

Если вы заранее записали таймкоды точек разбиения фильма на главы, то задать chapters можно так:

  • Переместите навигатор слегка вправо и нажмите кнопку [image]. Вид Track Editor изменится на:

  • Установить мышь на втором слева [image] указателе и в появившемся внизу окне Chapter Time ввести время начала второй главы (первая, как мы помним, всегда начинается с первого кадра клипа):

    и нажать Enter.

  • Взять мышью крайне правый указатель [image], сдвинуть его влево и ввести время начала следующей главы.

  • Повторить для всех глав. При разбиении навигатор [image] должен всегда быть правее любого указателя главы [image].

Если таймкоды начала глав неизвестны, точнее не хочется их искать и записывать, то можно отметить chapters в самом ReelDVD, используя навигатор [image] и плеер программы:

  • Переместите навигатор [image] в нужное место, контролируя правильность по дисплею плеера программы.

  • Нажмите кнопку [image].

  • Повторите процесс для всех глав.

После разбиения клипов на главы мы готовы к вводу меню в проект.


DVD Info - Soft intro - ReelDVD - Inserting Menu

DVD своими руками: Обзор программ: ReelDVD - Работа с меню в проекте

Работа с меню в проекте

Итак, теперь мы полностью готовы к вводу меню в проект. Сначала мы перетаскиваем из окна проводника на монтажный стол фон главного меню, созданного нами ранее. Прежде чем картинка фона "упадет" на монтажный стол, ReelDVD потребует от вас ответа на вопрос, в каком виде она будет использоваться:

Меню можно ввести как Still Menu или Slide Show. Реально разница между этими двумя режимами заключается только в том, что если выбрать Still Menu, то такое меню нельзя будет озвучить. Если выбрать Slide Show, то такое меню можно озвучить, причем время озвучивания можно задать каким угодно. Мы выбираем Slide Show.

Следующий шаг - повторяем ту же операцию для рисунка с овалами (subpicture), перетаскивая его на икону фона меню. В этом случае программа не задаст никаких вопросов, поскольку поймет, что вводится subpicture. На эту же икону перетаскиваем и звук, которым должно сопровождаться появление меню на экране телевизора. Следующий шаг - выбираем мышью икону с нашим первым меню и в Track Editor видим такую картину:

Для того, чтобы установить желаемую продолжительность звучания музыки в меню, следует просто сначала удлинить видеодорожку, схватив мышью за ее правый край, затем также удлинить аудио дорожку. Дорожки с Subpicture и Buttons (о которой мы поговорим немного позже) автоматически станут такого же размера, как и видеодорожка.


DVD Info - Soft intro - ReelDVD - Button Descriptions

DVD своими руками: Обзор программ: ReelDVD - Назначение кнопок

Назначение кнопок

Но наиболее интересен для нас сейчас редактор кнопок. Для более комфортной работы с ним, его размер рекомендуется увеличить. Для этого в любом месте серого поля окна редактора кнопок надо нажать правую кнопку мыши и снять галку с параметра Allow Docking, после чего растянуть максимально возможно его изображение. Рассмотрим кнопки управления редактированием меню, прежде чем приступим к работе над ним:

- кнопка изменения размера области кнопки меню.

- кнопка выделения кнопок меню фильма.

- после нажатия этой кнопки на экране появится изображение только собственно subpicture, без фона, с теми цветами, которые были применены вами при создании subpicture.

- после нажатия этой кнопки все, что мы нарисовали в subpicture, появится в том цвете, в котором это изображение будет показывать зрителю DVD плеер.

- после нажатия этой кнопки вы увидите цвета выбранной зрителем кнопки меню.

- после нажатия этой кнопки вы увидите цвет кнопки меню в момент ее выбора (когда зритель нажмет Select)

- с помощью этих кнопок управления цветом можно легко изменять цвета из subpicture на желаемые вами, а также добиваться "исчезновения" ненужных кнопок.

Теперь нажмем кнопку [image] и на экране появится картинка только subpicture. Выделим овалы на рисунке, нажав кнопку [image].

(!!!) - Порядок выделения кнопок меню очень важен. Именно та кнопка, которую вы обведете первой, будет выделена на экране после того, как зритель нажмет на своем пульте кнопку Menu. Выделять кнопки поэтому надо в наиболее разумном порядке, т.е. в том, в котором зритель будет ими пользоваться. Порядок выделения также определяет номер кнопки - нажав цифру с соответствующим номером на пульте управления DVD плеера, зритель выберет тем самым кнопку с этим номером.

По завершении выделения мы увидим:

Нажимаем кнопку [image] и возвращаемся практически к первоначальной картинке, но за одним исключением - вокруг кнопок будут контуры выделения и у каждой кнопки появится номер со словом Nop (нет операций), поскольку мы еще не назначили кнопкам функции. Обратите внимание на то, что номера кнопок соответствуют порядку их выделения. Теперь уже можно задать кнопкам прозрачность и цвета. Сейчас мы имеем режим Display, т.е. то что увидит зритель, войдя в меню. В этом режиме нам не нужно, чтобы зритель видел все овалы, поэтому в первую очередь сделаем прозрачным черный цвет, в котором мы рисовали subpicture. Исходное состояние кнопок управления цветом сейчас такое [image]. Эти кнопки имеют двоякое назначение. Во-первых, нажимая на "+" или "-" мы можем изменять яркость для выбранного цвета. При установке "0" цвет пропадает, при "100" он наиболее заметен. Во-вторых, щелкнув мышью по промежутку между "-" и "+" мы можем выбрать любой из предложенных программой цветов для замены того цвета, по которому мы щелкнули мышью:

(!!!) - то, что цветов всего 16, не относится к недостаткам ReelDVD, поскольку сами цвета и их количество ограничены DVD спецификацией и никакая другая программа не предложит большего выбора.

(!!!) - обращаем ваше внимание на то, что кнопок управления цветом всего четыре и каждая кнопка управляет только ОРИГИНАЛЬНЫМ цветом из subpicture. Если при создании меню вы использовали несколько цветов, то каждым цветом вы будете управлять по его кнопке.

Уберите видимость черного цвета, уменьшив до 0 его интенсивность - и овалы исчезнут с экрана. Далее нажимаем кнопку [image] и выбираем цвет для выделенных кнопок меню, нажав на окошко черного цвета между "-" и "+". Для данной картинки лучше всего будет выбрать белый цвет. Несмотря на то, что все овалы станут белыми, не беспокойтесь - на экране телевизора зритель увидит овал только у выбранной им кнопки меню. Следующий шаг - нажимаем кнопку [image] и устанавливаем цвет, который появится у овала выбранной кнопки в момент нажатия зрителем кнопки Select на своем пульте. Этот цвет возникает на доли секунды, поэтому он не очень заметен - выберем его красным. На этом дизайн главного меню закончен, нам осталось только задать маршрут передвижения курсора по меню. Для этого служат кнопки

Поскольку совершенно очевидно, что в этом меню все перемещения будут только вверх-вниз, сначала выбираем режим прокладки связей вверх, как показано на рисунке выше и соединяем кнопку "О диске" с кнопкой "Эпизоды", затем кнопку "Эпизоды" с кнопкой "Просмотр фильма". Затем выбираем режим прокладки связей вниз и проделываем те же операции, но сверху вниз. На этом вся работа по дизайну главного меню завершена.

Но у нас есть еще меню эпизодов, которое тоже следует ввести в проект. Для этого перетаскиваем на монтажный стол видеоклип к меню, перетаскиваем на него файл с музыкальным сопровождением и завершаем ввод меню перетаскиванием на икону клипа меню subpicture с кнопками-текстом. Точно также в режиме [image] обводим кнопки. В этом меню нам надо, чтобы текст был виден всегда, поэтому выбираем для него в режиме [image] белый цвет, в режиме [image] желтый и в режиме [image] красный. В завершении работы прокладываем маршруты передвижения курсора аналогично тому, как мы делали это в главном меню, но используя, конечно, и направления "слева направо" и "справа налево". На этом дизайн меню эпизодов закончен.

Наконец, мы можем приступить к завершению проекта и нам осталось присвоить кнопкам наших меню нужные функции. Делается это не просто, а очень просто. Посмотрите внимательно на иконы меню на монтажном столе и определите, чем они отличается от икон видеоклипов. Правильно - на нижней грани икон с меню появился символ [image]. Этот символ появляется только после того, как в меню была выделена хотя бы одна кнопка. Подводим к этому символу на главном меню (мы вводили его первым) мышь, нажимаем на этом символе левую кнопку мыши (у курсора появится слово CMD). Соединяем икону главного меню со вторым клипом нашего фильма (первый у нас FirstPlay, а со второго начинается сам фильм) и отпускаем кнопку мыши. На экране немедленно возникнет список глав этого клипа со стоп-кадрами в местах разбиения на главы.

Поскольку первый пункт нашего меню "Просмотр фильма", выбираем мышью первую главу, так как это всегда начало фильма. Программа тут же предложит вам определить, по выбору какой кнопки произойдет переход к началу фильма:

Выбираем, естественно, кнопку "Просмотр фильма". Затем опять соединяем символ [image] иконы главного меню, но уже с меню эпизодов. Программа предложит вам выбрать кнопку главного меню, по нажатию которой будет выполняться переход к меню эпизодов и выбрать следует, конечно, кнопку "Эпизоды". Таким же образом можно назначить кнопку "О диске", если у вас есть соответствующий клип. На этом все с главным меню - оно полностью готово.

Точно таким же образом назначаем команды кнопкам меню эпизодов - соединяем четыре раза (поскольку в этом меню можно выбрать четыре эпизода) кнопку [image] меню эпизодов со вторым клипом, затем соединяем с главным меню для назначения кнопки "Главное меню" в меню эпизодов. Если в вашем проекте есть еще одно меню эпизодов, то соединяем с ним для назначения кнопки "Продолжить выбор эпизодов". В завершении работы над проектом соедините большие кнопки программы Title и Menu с нашим главным меню, для того, чтобы нажав кнопки Title или Menu, зритель перешел в главное меню диска. Но ничего не мешает вам в будущем делать отдельные Title и Menu и тогда вам потребуется всего лишь соединить эти кнопки программы с соответствующими меню.

После всех описанных действий монтажный стол примет такой "запутанный" вид (на рисунке показан реальный проект с большим количеством меню):

Цифры на линиях просто отражают количество связей данного типа (цвет говорит о типе связи) между элементами проекта.

На всякий случай по завершении работы над проектом следует проиграть его на плеере программы. Пульт управления плеером совпадает с пультом управления обычного DVD проигрывателя, поэтому вы сможете легко проверить правильность проекта.

(!!!) - Рассинхронизация звука и видео при проигрывании проекта на плеере ReelDVD ни в коей мере не означает, что рассинхронизация есть на самом деле и на нее можно не обращать внимания - в готовом диске никакой рассинхронизации не будет.


DVD Info - Soft intro - ReelDVD - Record to DVD

DVD своими руками: Обзор программ: ReelDVD - Запись результата

Запись результата

Версия 2.5.1. ReelDVD поддерживает запись только на Pioneer A03. Версия 3.0, вышедшая осенью 2002, поддерживает все современные DVD рекордеры, но не стоит ждать и/или искать версии именно для своего рекордера. Правильнее всего просто создать образ DVD диска на жестком диске. Для этого в настройках проекта в разделе Layout Settings следует установить:

В каталоге DVDImages (имена каталога и диска могут быть любыми, конечно) программа создаст необходимую структуру DVD диска и далее можно легко записать DVD-Video диск обычной программой, поддерживающей запись DVD-Video дисков, такой как Nero Burning ROM (версии 5.5.9.0 и выше) или VOB Instant CD/DVD (наиболее предпочтительная программа, версии 6.4 и выше) и т.п. Запустить программу на генерацию диска можно выбором File/Make disc или нажатием кнопки [image]. После записи образа DVD Video диска на жесткий диск нашего компьютера мы рекомендуем еще раз проверить, насколько правильно вы создали диск, программой PowerDVD 4.0 или аналогичной, поддерживающей проигрывание DVD с жесткого диска компьютера.

Вот и все. Нам осталось только рассказать о некоторых "маленьких хитростях"

При написании этого материала использовалась информация с сайта www.crazypants.com


DVD Info - Soft intro - ReelDVD - Misc

DVD своими руками: Обзор программ: ReelDVD - Маленькие хитрости и особенности

Маленькие хитрости и особенности

Здесь хотелось бы привести небольшой FAQ по программе.

  • У меня почему-то мерцают различные элементы неподвижных меню. Кроме этого, часто элементы выделения (квадраты, например) "теряют" одну сторону изображения. Можно ли избежать подобных неприятностей и как?

  • Если мой фильм состоит из нескольких MPEG файлов, то у DVD плеера не срабатывает перемотка через границы файлов, хотя весь фильм в целом проигрывается нормально. Как устранить этот недостаток?

  • На коммерческих DVD дисках я часто вижу, что кнопки появляются на Motion Menu не сразу, а через значительный промежуток времени. Мало этого, меню как бы проявляется на экране. Могу ли я сделать тоже самое в ReelDVD?

  • Вы рекомендуете делать отдельно still меню и subpicture к нему. Какой в этом смысл, если можно все оставить в одном файле Photoshop?

  • Можно ли заменить собственно меню (motion или still), если мне нужно только немного подправить дизайн, не трогая кнопки и, соответственно, не переназначая их?

  • Я очень часто делаю однотипные DVD-Video диски (свадьбы). Как мне сделать так, чтобы я мог менять только видеофайлы, не занимаясь переназначением кнопок, связями и т.п.?

  • Занимаясь любительским DVD-Authoring'ом обнаружил странную особенность - при проигрывании любительских фильмов на дисплее большинства brand name DVD плееров вместо индикации глав и времени просто отображается слово Play. С другой стороны плееры BBK и аналогичные отображают все правильно. Возможно ли сделать индикацию глав и времени доступной для всех плееров?

  • Мне "медведь на руку наступил", совсем не умею рисовать и мне очень трудно самому создавать меню, но хотелось бы использовать преимущества ReelDVD и Scenarist. Как это можно сделать?

  • Существуют ли готовые шаблоны для DVD меню, которые можно было бы использовать для создания своих дисков, т.е. шаблоны с возможностью их редактирования?

У меня почему-то мерцают различные элементы неподвижных меню. Кроме этого, часто элементы выделения (квадраты, например) "теряют" одну сторону изображения. Можно ли избежать подобных неприятностей и как?

Избежать этих раздражающе неприятных моментов можно, если придерживаться нескольких простых правил:

  • Линии в subpicture всегда рисовать толщиной не менее 2 пикселей.

  • Количество пикселей в нарисованном вами графическом элементе subpicture должно быть четным.

  • Большие элементы выделения в меню наиболее правильно делать как подсветку, т.е. красивая и интересная рамка, например, создается по всем правилам подбора цветов, с обязательным сглаживанием (soft) краев и anti-aliasing. Для выделения этой рамки в subpicture следует нарисовать рамку чуть меньшего или такого же размера без размытия краев и anti-aliasing, но с условием установки яркости в меню НЕ БОЛЕЕ 50-60%. Тоже относится и к тексту - нельзя присваивать 100% яркость тексту в качестве элемента выделения - он получится практически всегда "размытым" на экране телевизора.

  • Если изображение рисуется в графическом редакторе с "нуля", то она должно быть размером 768х576.

  • Если вы планируете нарисовать текст, рамки и т.п. в графическом редакторе и хотите в качестве фона использовать кадр из DV клипа, этот кадр должен быть приведен также к размеру 768х576 и только после этого вставлен как фон для меню.

  • По завершении создания меню его картинка и subpicture должны быть сохранены с разрешением 720x576 с обязательной отменой параметра Keep Aspect Ratio (или аналогичного ему).

  • Если вы сомневаетесь в правильности созданного вами неподвижного меню, настоятельно рекомендуем создать из файла меню DV клип и просмотреть его на экране телевизора через видеокамеру. Если мерцания и других артефактов не будет, то их не будет и после авторинга диска.

  • Крайне редко, но в артефактах бывают виноваты встроенные MPEG кодеры программ DVD авторинга. Это обнаруживается в том случае, если меню как DV клип воспроизводилось нормально, а после авторинга, уже на DVD диске, появились артефакты. Если такой эффект появился, то "переведите" ваше неподвижное меню в motion, поскольку motion menu никак не меняется программой DVD авторинга.

К сожалению, эти правила полностью применимы только к некоторым программам DVD авторинга, таким как ReelDVD или Scenarist. Мерцающие меню, "усеченные" рамки и т.п. при авторинге в этих программах могут появиться только благодаря небрежному отношению автора диска к своей работе. В массовых, недорогих программах, которые не дают автору прямой доступ к subpicture, таких как Ulead DVD Workshop, Dazzle DVD Complete, Pinnacle Studio 8 и т.п. артефакты возможны и без всякой вины автора, из-за несовершенства алгоритмов генерации subpicture и встроенных кодеров MPEG.

Правила по размерам меню в 768х576 мы уже приводили, но считаем не лишним их снова повторить.

Наверх

Если мой фильм состоит из нескольких MPEG файлов, то у DVD плеера не срабатывает перемотка через границы файлов, хотя весь фильм в целом проигрывается нормально. Как устранить этот недостаток?

Действительно, такой недостаток есть. Обойти его в ReelDVD можно только "склеиванием" в TMPGEnc, например, нескольких MPEG файлов в один. Звук можно "склеить" в видеоредакторе. Второй вариант - использовать Scenarist.

Наверх

На коммерческих DVD дисках я часто вижу, что кнопки появляются на Motion Menu не сразу, а через значительный промежуток времени. Мало этого, меню как бы проявляется на экране. Могу ли я сделать тоже самое в ReelDVD?

Да, сделать это можно, причем двумя способами:

  1. "Разрезать" меню на два клипа по месту "проявления" меню. Само "проявление" надо будет сделать в видеоредакторе. Мы не рекомендуем этот способ, поскольку при переходе от файла видео к меню неизбежно возникнет пауза, хоть и короткая, но заметная.

  2. Второй способ более элегантный. Сначала создается файл в видеоредакторе с Motion Menu, "проявление" делается там же. Subpicture создается обычным способом. Далее:

    • Обычным порядком в проект вводится видеофайл меню, затем subpicture.

    • Выбирается это меню на монтажном столе.

    • Создаются и назначаются все кнопки меню как обычно.

    • Выбирается видеоклип меню на timeline Track Editor.

    • В окне [image] изменить время начала на тот самый период, после которого должно появиться меню. Например, пусть это будет 5 секунд: . Все дорожки сдвинутся на 5 секунд вправо.

    • Сдвиньте видеоклип и звук к нему назад, в 0-ую отметку. На этом процесс закончен и вид timeline будет такой:

Наверх

Вы рекомендуете делать отдельно still меню и subpicture к нему. Какой в этом смысл, если можно все оставить в одном файле Photoshop?

Действительно, все можно оставить в одном файле Photoshop, но такой способ имеет два минуса:

  1. Не получается сделать невидимыми слои subpicture в режиме Display.

  2. Изменение дизайна меню потребует полного переназначения кнопок.

Наверх

Можно ли заменить собственно меню (motion или still), если мне нужно только немного подправить дизайн, не трогая кнопки и, соответственно, не переназначая их?

Да, можно. Это действительно очень удобно. Для замены видеоклипа motion menu надо выбрать на монтажном столе клип меню, затем выбрать только видео из клипа на timeline. После такого выбора внизу появится окошко:

Нажав на кнопку с точками, следует указать новый файл с меню. То же самое можно проделать и с аудиодорожкой и с фоном от still меню. Единственная особенность - программа не будет конвертировать аудио в формате PCM в Dolby - файл при замене должен быть в том же формате, что и исходный. Возможность замены файлов позволяет дать совет - если на создаваемом вами DVD-Video диске осталось свободное место - удлините motion меню вместе с музыкальным сопровождением. Это позволит поднять зрелищность диска, поскольку циклы воспроизведения меню станут длиннее и музыка не будет так часто обрываться.

Наверх

Я очень часто делаю однотипные DVD-Video диски (свадьбы). Как мне сделать так, чтобы я мог менять только видеофайлы, не занимаясь переназначением кнопок, связями и т.п.?

Это очень просто. Можно делать так, как в ответе на предыдущий вопрос, но правильнее всего воспользоваться тем, что ReelDVD позволяет создавать шаблоны проектов. Для сохранения проекта как шаблона, надо выбрать File/Save as и в вариантах сохранения выбрать Storyboard Template. Теперь при выборе File/New ReelDVD будет предлагать вам выбрать нужный шаблон.

Наверх

Занимаясь любительским DVD-Authoring'ом обнаружил странную особенность - при проигрывании любительских фильмов на дисплее большинства brand name DVD плееров вместо индикации глав и времени просто отображается слово Play. С другой стороны плееры BBK и аналогичные отображают все правильно. Возможно ли сделать индикацию глав и времени доступной для всех плееров?

Действительно, такая проблема имеет место быть и связана она с некоторыми особенностями стандарта на DVD видео диски. Подробное рассмотрение этих особенностей нецелесообразно в силу большого объема информации по этой теме. Решить эту проблему можно довольно простым способом:

  • Переписать программу IfoEdit.

  • Создать необходимые для записи DVD диска файлы на жестком диске компьютера.

  • Запустить IfoEdit

  • Нажав Open, выбрать файл VIDEO_TS.IFO.

  • В верхней половине окна программы выбрать строку VMG_PTT_SRPT - Video Manager Title Play Map Table, как показано на рисунке:

  • В нижнем окне программы выбрать двойным щелчком мыши строку с адресом [00000008] и изменить имеющееся значение на 0.

  • Нажать кнопку Save.

  • Записать DVD болванку и убедиться в правильности отображения главы/времени.

Совет прислан Борисом Прохоровым.

Наверх

Мне "медведь на руку наступил", совсем не умею рисовать и мне очень трудно самому создавать меню, но хотелось бы использовать преимущества ReelDVD и Scenarist. Как это можно сделать?

Это вполне возможно. Необходимо установить себе программу Ulead DVD Workshop, сделать в ней меню (рисовать в нем не требуется вообще), причем легко создаются многооконные motion menu и запустить создавать образ DVD-Video диска. Во время компиляции проекта DVD Workshop во временной папке ~menutemp создает файлы такого вида:

0fceda38-0fc2-4db1-8203-32d224ff5e94HLIMG.bmp
0fceda38-0fc2-4db1-8203-32d224ff5e94IMG.mpg

Это и есть меню (mpg) с subpicture (bmp). Следует учесть, что после закрытия Workshop стирает все временные файлы.

Совет прислан Вячеславом Калининым.

Наверх

Существуют ли готовые шаблоны для DVD меню, которые можно было бы использовать для создания своих дисков, т.е. шаблоны с возможностью их редактирования?

Да, существуют. Необходимо установить себе программу Ulead DVD Workshop и после ее установки переписать в любое удобное место каталог \Program Files\Ulead Systems\ Ulead DVD Workshop\ Contents со всем его содержимым, затем на новом месте удалить каталоги TextEffects, Audio и Video. Теперь в директории Image у вас есть масса фонов для меню, а в остальных каталогах меню, кнопки, объекты и т.п. Несмотря на совершенно неизвестные расширения имен файлов в этих каталогах, все эти файлы являются ни чем иным, как файлами .UFO программы Ulead Photoimpact. Поэтому, присвоив им для удобства расширение .ufo, вы можете легко использовать их как заготовки для своих меню. Если уже больший опыт работы есть в Adobe Photoshop, то в Photoimpact можно легко преобразовать их в формат Photoshop.

Наверх
Copyright © 1997-2003 Компания Сплайн, все права защищены.
Help file designed & created by Tools


DVD Info - Soft intro - Scenarist NT

DVD своими руками: Обзор программ: Scenarist NT - Введение

Введение

Scenarist является существенно более мощной программой по сравнению с ReelDVD. На Scenarist-е делается до 90% коммерческих DVD дисков. Среди любителей эта программа намного менее популярна из-за распространенного мнения о сложности Scenarist для понимания и освоения. На самом деле это не совсем верное мнение (точнее, совсем неверное) и мы, публикуя этот материал, рассчитываем на его изменение в широких народных массах авторов DVD-Video дисков.

Внимательно исследовав программу ReelDVD, мы обнаружили у нее несколько незначительных недостатков, таких как :

  • Вместо индикации глав и времени на экране дисплея большинства brand name плееров отображается слово Play (для исправления этого недостатка нужно отредактировать файл VIDEO_TS.IFO с помощью программы IfoEdit);

  • После того как мы добились отображения информации на дисплее, обнаружилось, что основной фильм начинается не с первой главы: первая глава – это FirstPlay, вторая – основной фильм и каждое меню есть тоже глава (сцена);

  • DVD-Video диски, созданные в ReelDVD, “не очень правильно” проигрываются программными плеерами, например, PowerDVD: отсутствует возможность пользоваться “регулятором положения” (т.е. позиционироваться в любое место фильма), если нажать кнопку Next во время проигрывания FirstPlay, то воспроизведение диска может прекратиться.

Все эти недостатки незначительны, поскольку мы достигли главного: наш диск гарантированно проигрывается на бытовом плеере вне зависимости от качества носителя, на котором он записан, наш диск имеет профессиональное выглядящее меню, мы контролируем все необходимые кнопки пульта дистанционного управления плеера. Но, тем не менее, остается ощущение, что наш диск “не полностью правильный”.

“Правильный” на сто процентов диск нам поможет создать программа Sonic (ранее Daikin) Scenarist NT 2.7. Мы предполагаем, что Вы внимательно прочитали статью «DVD своими руками» и умеете пользоваться программой ReelDVD. Эти программы похожи, поэтому в этой статье мы не будем тратить время на разъяснение некоторых понятий, уже подробно описанных в статье по ReelDVD. Это в полной мере относится к созданию меню, поскольку меню для ReelDVD и Scenarist создается абсолютно одинаково (вы также можете ознакомиться с подробным руководством по созданию меню в статье Создание меню для программ DVD-Authoring). Мы также предполагаем, что вы имеете все необходимые файлы для включения их в проект (сценарий) программы Scenarist (меню для этого учебного проекта вы сможете переписать ниже). Обращаем ваше внимание на то, что значком (!!!) будет отмечаться текст, особенно важный для понимания работы программы.

(!!!) - еще раз обращаем ваше внимание на то, что без знания, как минимум, правил создания subpicture и меню с subpicture, подробно описанных в статье про ReelDVD, чтение настоящей статьи абсолютно бесполезно. Кроме этого, настоятельно рекомендуем внимательно ознакомиться с DVD Глоссарием.

(!!!) - все материалы по Scenarist не являются переводом документации к программе, а изложением результатов практической работы с программой.

Итак, давайте создадим DVD-Video диск, содержащий следующее:

  • FirstPlay (клип который проигрывается сразу после установки диска в плеер);

  • Главное Меню (это первое меню, в нём будет выбор между просмотром фильма и переходом к меню эпизодов)

  • Меню эпизодов фильма

  • Собственно фильм


DVD Info - Soft intro - Scenarist NT - Project settings

DVD своими руками: Обзор программ: Scenarist NT - Настройка проекта

Настройка проекта

Работа программы после ее запуска начинается с выбора проекта:

  • в окне Project Manager, нажимаем кнопку New.

  • попадаем в Scenarist NT Project Wizard, и нажимаем кнопку Next.

  • нажимаем кнопку … и указываем имя файла проекта и его местонахождение, затем нажимаем кнопку Next. Имя может быть любым, конечно.

  • В следующем окне оставляем в качестве типа диска DVD-Video и нажимаем Next.

  • В следующем окне оставляем в качестве вида диска Single Layer Disc (однослойный) и нажимаем Next.

  • Далее устанавливаем параметры кодирования фильма: PAL (720 x 576), 4:3, и нажимаем кнопку Next.

  • Следующие четыре окна служат для назначения цветов кнопок управления в меню. Оставляем все значения по умолчанию, т.е. четыре раза нажимает кнопку Next.

  • На вопрос: How many video title set would you like? (Сколько будет фильмов в проекте), ответим: один, т.е. оставим всё как есть и нажмём кнопку Next.

  • В следующем окне определим место, куда будет записываться результат (мы хотим создать образ DVD-диска). Для этого справа от поля Target (Место назначения) нажмём кнопку … и выберем папку (можно использовать ту же папку, которую вы указали для данного проекта). Нажимаем кнопку Next.

  • Не используем никаких шаблонов, выбирая I don't want to use template wizard, т.е. нажимаем кнопку Next.

На этом задание параметров проекта завершается. На экране видим результат нашего выбора:

Scenario Name : MyFirstProject
Disc type : DVD Video
Layer type : Single layer
Resolution : PAL
Aspect ratio : 4x3
Number of VTS : 1
Target directory : D:\Temp\Scenarist\Test01\
DVD Root directory : D:\Temp\Scenarist\Test01\0\
Multiplexer directory : D:\Temp\Scenarist\Test01\mux_data\

Теперь осталось нажать кнопку Finish.


DVD Info - Soft intro - Scenarist NT - Interface

DVD своими руками: Обзор программ: Scenarist NT - Знакомство с интерфейсом программы

Знакомство с интерфейсом программы

Мы успешно завершили настройку проекта и вошли в программу Scenarist. Что мы видим? По умолчанию программа занимает весь рабочий стол и состоит из двух окон:

Левое окно это окно сценария, назовём его Основное Окно. Правое окно содержит плеер для отображения клипа, изображений, текстов и готового результата, назовём его Окном Эмуляции. Если вы не увидели этого окна, то по команде View/Simulation Window можно увидеть Окно Эмуляции на экране.

Правое окно можно закрыть, а потом, при необходимости, открыть из Основного. Закрытие левого окна приведёт к закрытию проекта. Функция Save в Scenarist отсутствует как класс – проект “всегда сохранен”, поскольку все действия пользователя записываются в файл проекта немедленно. Отмены операции, Undo, не существует в принципе, что сделано, то сделано. Теперь подробнее, об Основном Окне (сверху вниз, слева направо):

  • Меню программы: обычный набор меню (File, Edit, New и т.п.)

  • Панель инструментов программы: здесь есть практически все необходимые кнопки. Набор кнопок в панели изменяется в зависимости от выбранной закладки в рабочем окне (см. ниже).

  • Основное Рабочее Окно: здесь проводится основная работа по созданию вашего DVD-диска.

  • Информационное Окно (information window): здесь отображается информация об ошибках и о выполнении текущих заданий, например о процессе конвертации wav-файла в AC3.

  • Окно Свойства (property browser): это окно для внесения изменений в различные параметры сценария, клипов, меню и т.п.

  • Проводник (accept manager): псевдо-проводник, т.е. не совсем настоящий – показывает только те файлы, которые вы в него ввели.

В Окне Эмуляции есть:

  • Меню

  • Панель инструментов (Toolbar)

  • Окно Плеера

  • Окно Редактирования: это окно является “продолжением” Окна Свойств (из Основного окна), здесь появляются различные параметры фильма (в основном меню), которые можно просматривать и(или) изменять.


DVD Info - Soft intro - Scenarist NT - Import to project

DVD своими руками: Обзор программ: Scenarist NT - Ввод данных в проект

Ввод данных в проект

Сначала введём необходимые данные в наш проект. Данными для проекта являются видео, аудио файлы и файлы изображений. В нашем случае это два видео файла и два аудио файла (мы имеем FirstPlay и сам фильм), а также четыре изображения для создания меню. Нами подготовлены видео файлы:

  • Вступительный клип: FirstPlay.m2v и FirstPlay.wav

  • Фильм: Movie.m2v и Movie.wav

О том как создать такие файлы, подробно рассказано в статье: ”Reel DVD - Первый опыт”. Если у вас есть возможность, то для выполнения этого примера возьмите небольшие файлы. Файлы нашего примера для создания меню(399 Kb):

  • Первое меню: Menu01.bmp (меню), Menu01_sub.bmp (subpicture)

  • Второе меню: Menu02.bmp (меню), Menu02_sub.bmp (subpicture)

Мы хотим сделать два обычных (still) меню (не анимационные и без звука). Как создавать обычные меню, рассказано в статье: ”Создание обычных (still) меню).”

Вводим данные в проект:

  • В Рабочем Окне нажмите на закладку Data Editor (по умолчанию закладка была нажата).

  • С помощью кнопки New Folder [image] создайте две папки, с названиями Video & Audio и Images.

  • С помощью кнопки New Data [image], поочерёдно, открыв предварительно папку Video & Audio, поместите в нее четыре файла (FirstPlay.m2v, FirstPlay.wav, Movie.m2v, Movie.wav). Файлы видео начнут обрабатываться. Для аудио файлов будет предложена конвертация, поэтому в появившемся окне

    выберите AC3. Если в будущем вы будете конвертировать весь звук в DolbyDigital (что мы настоятельно рекомендуем, то следует после выбора AC-3 отметить Apply to All (Применять всегда). Чем больше файлы, вводимые в проект, тем больше времени тратит программа на их обработку. Процесс конвертации файла отображается в Информационном Окне ниже.

  • Затем, в папку Images, с помощью той же кнопки New Data [image], поочерёдно, добавьте изображения необходимые для создания меню (Menu01.bmp, Menu01_sub.bmp, Menu01.bmp, Menu01_sub.bmp). При вводе графических фалов программа задаст вопрос

    Для файлов Menu01.bmp и Menu02.bmp укажите Still Image, а для файлов Menu01_sub.bmp и Menu02_sub.bmp укажите Sub-Picture with Forced Start.

    (!!!) - под Subpicture with Forced Start программа понимает subpicture для меню, т.е. subpicture, изображение которой зритель не сможет отключить. Под Subpicture without Forced Start программа понимает subpicture, изображение которой пользователь может отключить. Subpicture с таким атрибутом используется для ввода субтитров.

Всё, ввод данных в проект завершён. Дерево Data Editor выглядит следующим образом:


DVD Info - Soft intro - Scenarist NT - Track Creating

DVD своими руками: Обзор программ: Scenarist NT - Формирование дорожек проекта

Формирование дорожек проекта

Приступим к формированию Дорожек проекта. Т.е. соберём из введённых нами данных объекты (клипы и меню) из которых чуть позже соберём наш DVD-диск.

  • Создание дорожек для видео клипов

  • Расстановка глав (или сцен) (chapter)

  • Создание дорожек для меню

  • Создание меню на базе дорожки меню


DVD Info - Soft intro - Scenarist NT - Track Creating - VideoTrack Creating

DVD своими руками: Обзор программ: Scenarist NT - Формирование дорожек проекта

Создание дорожек для видео клипов

Делаем дорожку для First Play:

  • В Рабочем Окне выберите закладку Track Editor:

    • (обращаем ваше внимание на панель инструментов - она изменилась, на ней появились новые кнопки)

  • С помощью кнопок Information Window и Property Browse [image], выключите Информационное Окно и Окно Свойств. В области экрана, под Рабочим Окном останется только Проводник (так будет удобней):

  • перенесите (мышкой:) FirstPlay (видео) из Проводника в окно Track Editor:

    Щелкните мышью на иконе клипа - окно Track Editor примет вид:

  • Перенесите аудио от FirstPlay из Проводника в прямоугольник с надписью Video (см. рисунок выше). Вид окна Track Editor изменится на следующий:

  • В ниспадающем меню Audio 1 выберите нужный язык - в нашем случае, конечно, это будет Russian.

  • В дереве дорожек Track Editor выберите корень (надпись Tracks), и теперь мы готовы к формированию следующей дорожки.

  • Повторите описанные выше операции для клипа Movie и звука к нему.

Если в процессе создания дорожки вы сделали какие-то ошибки – удалите эту дорожку и создайте её снова. Для удаления следует выделить дорожку и нажать либо клавишу Delete, либо Clear из меню по правой кнопки мыши.


DVD Info - Soft intro - Scenarist NT - Track Creating - Chapters Settings

DVD своими руками: Обзор программ: Scenarist NT - Формирование дорожек проекта

Расстановка глав (или сцен) (chapter)

Как известно, определять главы нужно ещё в процессе создания фильма, записывая таймкоды для них. Этот способ позволят легко расставить главы в программе подготовке DVD-диска. Scenarist не является исключением из правил. Тем более, что в плеере Scenarist-а (так же как и в ReelDVD) видео может расходиться со звуком, поэтому расставить главы, ориентируясь по звуку, практически невозможно.

Расставим для примера три главы (chapter) в фильме. Для расстановки глав:

  • С помощью кнопок на панели инструментов открываем окно Свойств и Окно Эмуляции. Окно Эмуляции – это вторая половинка Scenarist-а о которой мы упоминали в начале статьи, но в процессе работы оно могло стать невидимым. Удобнее всего в процессе работы над проектом выбрать команду View/Alway on Top в Окне Эмуляции оно всегда будет видно.

  • В рабочем окне выбираем закладку Track Editor и далее выбираем дорожку Movie-t. Делаем окошко с деревом дорожек как можно уже для увеличения рабочей области Track Editor.

  • Нажмите на слайдер справа от прямоугольника с надписью Scenes:

    Первая глава поставлена! Первая глава всегда ставится в начале клипа, всегда существует, не может быть ни удалена, ни передвинута.

  • Передвиньте слайдер по клипу, наблюдая за изображением на плеере в Окне Эмуляции, и остановитесь в месте приблизительно соответствующем второй главе вашего фильма. Для удобства перемещения по timeline можно изменять масштаб timeline кнопками "+" или "-" на toolbar.

  • Нажмите кнопку New Scene [image] на toolbar и новая глава (сцена или Chapter) установлена.

  • Нажмите в области справа-и-сверху от слайдера – новая сцена будет выделена, а внизу в окне Свойств сцены будут показаны её параметры:

  • В поле Name рекомендуется ввести название сцены, например Эпизод-2, а в поле Scene Time можно ввести точное время начало сцены, если оно было записано вами ранее.

(!!!) - давая имена сценам, а также другим объектам сценария, можно использовать только буквы, цифры, знаки подчеркивания и дефис. В противном случае вы получите сообщение об ошибке, причем, к сожалению, уже на этапе генерации диска.

  • Для проверки правильности установки сцены, щелкните два раза два раза мышью по иконе нужной сцены и в плеере Окна Эмуляции появится изображение начала сцены, откорректированное вводом точного значения времени начала сцены (если таковое было).

Создание сцены завершено. Расставьте таким же образом остальные сцены вашего фильма. Для примера мы сделали три сцены с названиями: Эпизод-1, Эпизод-2 и Эпизод-3.

Обратите внимание, что мы плавно изменили терминологию: теперь мы говорим Сцена вместо Глава. Просто все, что касается Chapter (глава) в программе Scenarist называется Scene (сцена). Теперь, пользуясь Scenarist-ом, будет проще называть компоненты проекта так, как они называются в этой программе.


DVD Info - Soft intro - Scenarist NT - Track Creating - Menu Tracks Create

DVD своими руками: Обзор программ: Scenarist NT - Формирование дорожек проекта

Создание дорожек для меню

Теперь мы создадим дорожки для меню. Как уже рассказывалось выше, мы решили сделать два обычных (still) меню - главное меню диска и меню для выбора эпизодов.

Главное меню нашего примера содержит два пункта:

  • Посмотреть фильм

  • Выбор эпизодов

Меню для выбора эпизодов содержит четыре пункта:

  • Эпизод-1

  • Эпизод-2

  • Эпизод-3

  • Вернуться в главное меню

Итак, делаем меню:

  • С помощью кнопок на toolbar выключаем Окно Свойств и включаем Проводник.

  • В рабочем окне выбираем закладку Track Editor (она у нас уже выбрана), расширяем окошко с деревом дорожек до её первоначальной ширины, нажимаем на корень дерева (надпись Track).

  • Из проводника перетаскиваем Menu01 в Track Edit и выбираем Still Menu.

  • В окне Track Editor кликните два раза на появившемся клипе Menu01-t.

  • Переносим Menu01_sub в прямоугольник с надписью Still.

  • Заменяем Not Specified (в прямоугольнике с надписью Subpicture 1) на Russian.

    В результате всех этих действий окно Track Editor должно выглядеть так:


DVD Info - Soft intro - Scenarist NT - Track Creating - Menu From Menu Track

DVD своими руками: Обзор программ: Scenarist NT - Формирование дорожек проекта

Создание меню на базе дорожки меню

Переходим в Окно Эмуляции и проделываем следующие операции:

  • С помощью кнопки New Button [image] рисуем кнопки на изображении меню:

  • В Окне Редактирования (под окном плеера) нажимаем на закладку Subpicture and Highlight.

  • Переключаемся в подменю Colors:

Устанавливаем значения для чёрного цвета (при создании подменю Menu01_sub.bmp мы использовали только чёрный цвет):

  1. Display Color - 0%

  2. Selection Color - Жёлтый

  3. Action Color - Тёмно красный

  • Далее с помощью кнопок в панели инструментов Окна Эмуляции расставьте направления перемещения курсора меню при нажатии на кнопки управления на пульте дистанционного управления DVD плеера. Другой вариант: в меню Окна Эмуляции, в Tools выберите Auto Route – это автоматически расставит направления перемещения. Следует только учитывать, что автомат не обладает приемлемым интеллектом и нормально расставляет направления только при простом (квадратно-гнездовом) размещении кнопок.

  • Проверьте работу меню. Для этого нажмите кнопку Software Simulation [image] в toolbar Окна Эмуляции, затем кнопку Play. Синие стрелки (влево, вправо, вверх и вниз) под экраном плеера эмулируют стрелки пульта управления DVD плеера.

  • Выключите плеер и вернитесь в режим редактирования, нажав кнопку Design Mode [image].

На этом создание меню завершено. Аналогичным образом создайте второе меню, используя файлы Menu02.bmp, Menu02_sub.bmp/


DVD Info - Soft intro - Scenarist NT - Scenario Editor

DVD своими руками: Обзор программ: Scenarist NT - Редактор сценария

Редактор сценария

Мы ввели данные, подготовили дорожки, теперь всё готово для создания сценария будущего DVD-диска.

  • Добавление дорожек в сценарий

  • Расстановка связей


DVD Info - Soft intro - Scenarist NT - Scenario Editor - Add Tracks to Scenario

DVD своими руками: Обзор программ: Scenarist NT - Редактор сценария

Добавление дорожек в сценарий

  • Нажмите на закладку Scenario Editor в Рабочем Окне.

  • Расширьте основную область окна за счёт уменьшения окна с деревом сценария:

    • Как видите – сценарий почти готов, осталось только поместить наши дорожки в нужные места и расставить связи:

    • C помощью кнопок в toolbar откройте проводник и нажмите в нём на закладку Track.

    • Перетащите FirstPlay-t из проводника на иконку Title_1.

    • Нажмите на иконку VideoManager. В меню в пункте New нажмите Language (либо правая кнопка меню, пункт Add Language…) и в появившемся окне выберите Russian.

    • Перетащите Menu01-t из проводника на только что созданную иконку Russian.

    • Нажмите на иконку VTS_1. В меню в пункте New нажмите Language (либо правая кнопка меню, пункт Add Language…) и в появившемся окне выберите Russian (чуть сдвиньте кнопку горизонтальной прокрутки, что б было видно только что созданную иконку Russian), перетащите Menu02-t из проводника на только что созданную иконку Russian (в новую иконку, ту, которая растёт из VTS_1).

    • Нажмите на иконку VTS_1. В меню в пункте New нажмите Title (либо правая кнопка меню, пункт Add Title…), оставьте предложенное название Title_2, (чуть сдвиньте кнопку горизонтальной прокрутки, что б было видно только что созданную иконку Title_2) перетащите Movie-t из проводника на только что созданную иконку Title_2.


DVD Info - Soft intro - Scenarist NT - Scenario Editor - Connects Set

DVD своими руками: Обзор программ: Scenarist NT - Редактор сценария

Расстановка связей

После ввода всех наших дорожек в окно создания сценария, оно должно выглядеть приблизительно так:

Если все дорожки проекта не видны, то достаточно выбрать "-" на toolbar для изменения масштаба изображения.

(!!!) - В нашем примере, как вы видите, есть только два меню - Title (Menu01), оно всегда присоединяется к VideoManager/Language и Root (Menu02), которое в свою очередь всегда присоединяется к VTS/Language. В качестве Language в нашем примере Russia, конечно. Если ваше Root меню состоит из нескольких меню, то все они (кроме первого, конечно), должны перетаскиваться на ячейку Program первого меню из папки Tracks. Эта ячейка 2-ая сверху. Если вы хотите, чтобы все меню вызывались из Title меню, то все меню, кроме первого, должны перетаскиваться на ячейку Program в Title меню. Вот так, например, выглядят несколько меню из дерева Root:

Осталось расставить связи между компонентами проекта. Посмотрите на рисунок (выше). Мы имеем основные (верхний уровень) иконки:

  • First PGC - указывает на тот клип, который воспроизводится после загрузки DVD-диска в плеер.

  • Video Manager - контейнер для меню верхнего уровня, т.е. Title.

  • VTS_1 - контейнер для фильма и тех клипов, которые могут быть с ним связаны.

Одна связь в нашем сценарии уже существует: от First PGC к Title_1. Эта связь означает, что после загрузки (включения) DVD-диска будет проигрываться наша дорожка FirstPlay-t.

Расставим остальные связи:

  • Сначала от главного меню к фильму. Для этого от прямоугольника с текстом Btns на иконке Menu01_sub_1_menu (эта иконка находится внизу дерева, растущего из иконки Video Manager):

  • нажатой мышкой проведите линию на иконку Title_2 (она находится справа и вверху, если это не удобно сделать, то максимально расширьте основное окно). Если вы попали на иконку Title_2, то на экране появится окно “Choose Command Button”. Выберите первую кнопку.

  • Протяните связь от прямоугольника с текстом Btns на иконке Menu01_sub_1_menu (оттуда же, откуда протягивали перед этим) к иконке Menu02-t-pgc (т.е. к дорожке второго меню):

  • В появившемся окне “Choose Command Button” выберите вторую кнопку.

  • В редакторе сценариев связи между меню не показываются, будьте внимательнее! Для проверки созданных связей откройте Окно Эмуляции (вторая половинка Scenarist-а), предварительно выбрав ячейку меню с флагом Btns. Нажмите на закладку Button Commands в окне Редактирования. В ней появится список ваших связей.

  • Расставим связи от второго меню (иконка Menu02_sub_1_menu) к сценам нашего фильма. Для этого последовательно проводим связи от прямоугольника с текстом Btns на иконке Menu02_sub_1_menu к иконкам Эпизод-1, Эпизод-2, Эпизод-3 и к иконке Menu01-t-pgc (для того, что бы соединить «вернуться в главное меню” не забудьте о том, что связи на меню не отображаются, а о том как проверить, читайте в предыдущем пункте.

  • Последняя связь от First Play к главному меню (так в нашем примере, но можно и к основному фильму, если угодно).

  • Протяните связь от прямоугольника с текстом Post на иконке FirstPlay-t-pgc к иконке Menu01-t-pgc (т.е. к дорожке первого меню). Эти связи также не отображаются в Scenario Editor и для того, что бы проверить их, откройте Окно Эмуляции, в окне Редактирования нажмите на закладку PGC Commands, в спадающем меню выберите Post. Эта команда выглядит так: CallSS RSM=1, TitleMenu (это означает то, что связь проставлена верно).

(!!!) - Команды Post и Pre НЕ эквивалентны командам Next и Previous пульта управления плеером и аналогичным командам ReelDVD.

Проверьте работу вашего диска. Для этого надо:

  • Выбрать иконку First PGC

  • В toolbar Окна Эмуляции нажмите кнопку Software Simulation, затем кнопку Play. Синие стрелки внизу (влево, вправо, вверх и вниз) эмулируют стрелки пульта управления DVD плеера.


DVD Info - Soft intro - Scenarist NT - Create DVD Folders

DVD своими руками: Обзор программ: Scenarist NT - Создание образа DVD-диска

Создание образа DVD-диска

  • Нажмите на закладку Layout Edition в Рабочем Окне.

  • В появившемся окне, в области Step 3 – Choose Operations and Press Start выделите первый раздел Create DVD Video.

  • Проверьте (выше в Step 2) поле DVD Root Directory. В этой папке будет создан образ вашего DVD-диска.

  • Откройте информационное окно (кнопка Information Windows в toolbar) для контроля процесса создания диска.

  • Нажмите кнопку Start.

Полученный образ DVD-диска можно просмотреть с помощью программного DVD-плеера, например PowerDVD.

Заключение

Несмотря на то, что Scenarist видит DVD-R рекордеры, мы не можем рекомендовать запись на диск с помощью Scenarist, по одной простой причине – мы не проверяли эту возможность во время написания этого материала. Воспользуйтесь старым и проверенным способом: запишите диск (используя полученный образ) с помощью программы VOB Instant CD+DVD, Nero Burning ROM (только в крайнем случае, запретив у Nero Joliet) или любой другой программы, которой вы пользуетесь для записи DVD-дисков. Подробнее о записи Scenarist'ом DVD-Video дисков можно прочитать здесь.

Обратите внимание, что состав файлов в папке VIDEO_TS изменился по сравнению с одноимённой папкой, созданной с помощью программы ReelDVD: появился файл VIDEO_TS.VOB, а файл VTS_01_0.VOB имеет размер менее стандартного в 1 гигабайт. В этих файлах записаны меню, в остальных видео и аудио файлы фильма. Несмотря на то, что ReelDVD и Scenarist имеют один движок, результат (даже по составу файлов) получается различный.

ReelDVD – это частный случай от Scenarist, и, если файлы ReelDVD можно было бы поместить в Scenario Editor, то мы бы увидели, что все файлы видео и меню лежат в Title_1. Именно поэтому все связи в ReelDVD выполняются с помощью команд Next PGC и Previous PGC, и именно поэтому не работает отображение информации на дисплее и нет позиционирования в программных плеерах.


DVD Info - Soft intro - Scenarist NT - Inside Scenarist NT

DVD своими руками: Обзор программ: Scenarist NT - Углубленное изучение

Углубленное изучение Scenarist NT

Начиная с этой главы, мы будем постепенно, по мере появления новых данных, сообщать дополнительную информацию по программе Scenarist NT. До завершения проекта не стоить ждать системного подхода к этому материалу, поскольку информации слишком много и систематизировать ее полностью можно будет только по окончании работы над всеми разделами. В работе над этим материалом нам оказывают помощь г-да Борис Прохоров, Кирилл Щерба, а также другие участники конференции по Scenarist NT, за что им мы приносим им искреннюю благодарность.


DVD Info - Soft intro - Scenarist NT - Inside Scenarist NT - Working with Menu - Menu Design

DVD своими руками: Обзор программ: Scenarist NT - Углубленное изучение

Оформление меню

Основные правила создания меню достаточно подробно освещались в статье о ReelDVD. Но есть ряд дополнительных возможностей по оформлению меню, которые существуют только в Scenarist и отсутствуют в ReelDVD. Именно об этих особенностях и будет идти речь в этом разделе руководства.


DVD Info - Soft intro - Scenarist NT - Inside Scenarist NT - Working with Menu - Menu Design - Image Chapter

DVD своими руками: Обзор программ: Scenarist NT - Углубленное изучение

Раздел Image

Для редактирования меню выберите любую subpicture с меню в Track Editor программы и откройте Simulation Window. Выберите закладку Subpicture and Highlight, и кнопками справа от ниспадающего меню установите раздел Image, как показано на рисунке:

В разделах меню Image можно сделать следующее:

  • изменить название subpicture в поле Name

  • ограничить длительность пребывания subpicture на экране в поле Data End Time

(!!!) - реально устанавливается именно продолжительность пребывания subpicture на экране, т.е. Data Start Time всегда равно 0, независимо от местоположения subpicture относительно видео. Например, если вы установите в Data End Time 00:01:00;00, то subpicture будет находится на экране ровно 1 минуту и при этом вы сдвинете ее на timeline на 20 секунд вправо, то subpicture будет на экране с 20 секунд до 1 минуты 20 секунд.

(!!!) - после любого сдвига subpicture с меню не забывайте, установив курсор на дорожке с Highlight, выбрать по правой кнопке мыши команду Align. В противном случае вы получите сообщение об ошибке при любой попытке генерации образа диска, несмотря на то, что при проигрывании в режиме эмуляции все будет нормально.

  • разрешить/запретить Forced Start в поле Forced Start

  • заменить одну subpicture на другую в поле File


DVD Info - Soft intro - Scenarist NT - Inside Scenarist NT - Working with Menu - Menu Design - Colors Chapter

DVD своими руками: Обзор программ: Scenarist NT - Углубленное изучение

Раздел Colors

Далее кнопками справа от ниспадающего меню выберите раздел Colors:

Смысл кнопок понятен всем, кто ознакомился с настройками цветов в subpicture в программе ReelDVD - слева четыре основных цвета subpicture, справа определяемые вами цвета в меню, видимые зрителю. Но на этом сходство заканчивается. Щелкнув мышью по любому (в нашем примере - по красному) из основных цветов слева, мы увидим панель управления преобразованием цветов:

Смысл этой панели в том, что для subpicture вы можете создать изображение (или использовать готовое) с неограниченным количеством цветов, но обязательно задав в панели Color Conversion правила преобразования множества цветов в три основных. Для этого нужно либо указать точный цвет красного тона, например, для преобразования в красный чистый тон, либо, нажав кнопку Redder Than (краснее чем), сообщить программе, что все, что краснее указанного цвета, должно быть также преобразовано в чистый красный тон. Манипуляции с красным цветом приведены только для примера. С каждым из трех основных цветов можно проделать тоже самое. Нажав на стрелку правее цветного прямоугольника, можно выбрать требуемый цвет из палитры Windows, выбрав кнопку Other...

В этом меню еще одна очень приятная возможность, которой не было в ReelDVD - создание нескольких палитр цветов subpicture. Меняя номер Color Index в ниспадающем меню в правом нижнем углу окна Colors и настраивая для каждого Color Index свою палитру, вы получаете возможность использовать по крайней мере три разных цвета выделения (Selection) для работы с кнопками в одном (!) меню. О том, как это сделать, написано в разделе Buttons.

Далее кнопками справа от ниспадающего меню выберите раздел Highlight:

В этом разделе нам интересен параметр Forced Selected Button (Принудительно выбранная кнопка) - в нем устанавливается номер кнопки, которая будет выбрана в данном меню после входа в это меню. Номер кнопки может быть найден вами в левом верхнем углу обведенного в Scenarist контура кнопки. Если вы хотите, чтобы при циклическом проигрывании меню в качестве выбранной кнопки была последняя выбранная в этом меню кнопка, то вместо номера кнопки следует выбрать Nonexistent. Такой способ имеет только один недостаток - при первом входе в меню может быть НЕ выбрана какая-либо кнопка вообще. Этот недостаток устраним, но только для меню с каким либо атрибутом (Root, Audio и т.д.) - выбрав PGC ячейку меню, в Simulation Window следует выбрать в PGC Commands для Pre команду Set Highlighted Button, задав номер кнопки, которая должна быть выделена при первом входе в меню.


DVD Info - Soft intro - Scenarist NT - Inside Scenarist NT - Working with Menu - Menu Design - Buttons Assigned

DVD своими руками: Обзор программ: Scenarist NT - Углубленное изучение

Раздел Buttons

Далее кнопками справа от ниспадающего меню выберите раздел Buttons:

В этом меню можно посмотреть и изменить координаты любой кнопки меню, что может потребоваться при очень близком расположении кнопок друг к другу, вследствие чего трудно очертить кнопки мышью без перекрытия. Кроме этого, любой кнопке можно присвоить атрибут Auto Action. Если кнопке присвоить такой атрибут, то при переходе на эту кнопку немедленно будет выполнена связанная с этой кнопкой команда.

Если вы подготовили различные цветовые палитры в разделе Colors, то вы можете указать для каждой кнопки свой Color Index и, тем самым, изменить цвета выделения (Selection) кнопок в по своему желанию.


DVD Info - Soft intro - Scenarist NT - Inside Scenarist NT - Working with Menu - Menu Design - Advanced Effects Chapter

DVD своими руками: Обзор программ: Scenarist NT - Углубленное изучение

Раздел Advanced Effects

Далее кнопками справа от ниспадающего меню выберите раздел Advanced Effects:

В этом разделе можно создать эффекты для subpicture. Строго говоря, эти эффекты предназначены только для субтитров (subtitle), но их можно использовать и для меню (но совместимость такого решения мы не проверяли, хотя вряд ли она станет хуже). Всего можно использовать 4 эффекта:

  • Fade (F) - постепенное изменение цветов subpicture. В связи с особенностями представления цветов DVD плеером, это именно постепенное, ступенчатое изменение цветов, а не плавное, к сожалению.

  • Wipe (W) - плавное "наползание" subpicture на экране.

  • Scroll (S) - прокрутка subpicture на экране.

  • Stop (красный кружок) - прекращение видимости subpicture на экране.

Fade- постепенное проявление subpicture на экране.

Для применения эффекта следует мышью на timeline Simulation Window выделить область необходимой длительности, растягивая ее или сокращая за края при необходимости. Если щелкнуть мышью на свободной от эффекта области timeline, то можно установить цвета, которые возникнут на экране по завершении эффекта, как показано на рисунке выше. Если же щелкнуть на зеленом прямоугольнике эффекта, то можно (и нужно) выставить цвета в начале эффекта и по его завершении в разделах Stop Contrast (начало) и Stop Contrast (конец):

Wipe- плавное "наползание" subpicture.

Для применения эффекта следует мышью на timeline Simulation Window выделить область необходимой длительности, растягивая ее или сокращая за края при необходимости. Если щелкнуть мышью на свободной от эффекта области timeline, то можно установить цвета, которые возникнут на экране по завершении эффекта, как показано на в первом рисунке в описании эффекта Fade выше. Если же щелкнуть на зеленом прямоугольнике эффекта, то можно (и нужно) выставить цвета в начале эффекта и по его завершении в разделах Initial Color (цвет в начале эффекта), Initial Contrast (контрастность в начале эффекта), Change Contrast (контрастность к концу эффекта) и Change Color (цвет к концу эффекта):

В этой панели настроек также можно выбрать направление "наползания" слева или справа в параметре Type - Left или Right.

Пример эффекта Wipe ("наползание" слева):

Scroll - "прокрутка" subpicture на экране.

Для применения эффекта следует мышью на timeline Simulation Window выделить область необходимой длительности, растягивая ее или сокращая за края при необходимости. Если щелкнуть мышью на свободной от эффекта области timeline, то можно установить цвета, которые возникнут на экране по завершении эффекта, как показано на в первом рисунке в описании эффекта Fade выше. В этом эффекте можно установить только направление движения subpicture в параметре Type:

  • Down In - движение сверху вниз до остановки в нормальном положении

  • Down Out - движение из нормального положения до ухода с экрана вниз

  • Up In - тоже что и Down In, но снизу вверх

  • Up Out - тоже что и Down Out, но вверх

Stop - простая остановка subpicture. Никаких настроек не имеет. Точно также выделяется область на timeline, но длительность эффекта не имеет значения.

(!!!) - Если вы хотите применить описанные выше эффекты (кроме Stop, который ограничений не имеет) к subpicture с меню, то следует проделать такие операции:

  • Полностью создать меню, т.е. определить кнопки, проложить связи и т.п.

  • Сдвинуть в Track Editor highlight этого меню вправо на произвольное время.

  • Применить к меню желаемый эффект

  • Выбрав в Track Editor highlight меню, по правой кнопке мыши выбрать Align.


DVD Info - Soft intro - Scenarist NT - Inside Scenarist NT - Working with Menu - Working with two levels Menus

DVD своими руками: Обзор программ: Scenarist NT - Углубленное изучение

Работа с меню из нескольких уровней

Как правило, в большинстве случаев при создании DVD диска требуется иметь одно главное меню, из которого выполняются переходы в меню эпизодов, установки параметров звука, языка и т.д. Организовать все эти меню можно несколькими способами:

  1. Классический - главное меню помещается в VideoManager и из него можно переходить в любое место проекта, точнее - к любому title проекта. Остальные меню размещаются в соответствующих VTS. В этом случае главное меню вызывается по нажатию кнопки Title на пульте ДУ DVD плеера, а остальные меню нажатием кнопки Menu пульта. Этот способ обязателен к применению, если вы планируете создать диск из нескольких различных фильмов, каждый из которых будет в своем VTS со своими меню, так как только из Title меню можно осуществлять переход между VTS. Существуют, конечно, пути обхода этого ограничения, но они крайне неудобны да и не требуются. Недостаток такого варианта только один - пользователь должен понимать, что нажимая разные кнопки пульта DVD-плеера Title и Menu, он будет попадать в разные меню. Как это не смешно, такое понимание есть не всегда, поэтому в подавляющем большинстве коммерческих DVD-Video дисков вне зависимости от того, какая кнопка нажимается, на экране возникает одно и то же меню.

  2. Все меню размещаются вместе с фильмом в одном VTS. Наиболее часто используемый способ. Удобен тем, что все меню вместе и рядом. В этом случае одно меню является основным и получает атрибут Root Menu. Root Menu в пределах одного языка в VTS может быть только одно. Остальные меню, как правило, "прикрепляются" к Root Menu и своих атрибутов меню не имеют. Свои атрибуты есть смысл назначать меню, функционально отличным от обычных, о чем подробно рассказано ниже.

Рассмотрим подробнее оба варианта.


DVD Info - Soft intro - Scenarist NT - Inside Scenarist NT - Working with Menu - Working with two levels Menus - Working with PGC

DVD своими руками: Обзор программ: Scenarist NT - Углубленное изучение

Работа с PGC на примере меню PGC

В качестве примера для рассмотрения некоторых возможностей работы с PGC мы используем обычное Title Menu.

Первый прямоугольник является идентификатором PGC нашего меню. Если выбрать его мышью, то мы увидим в Simulation Window такую картину:

Здесь мы можем изменить имя PGC. Обратите внимание, что изменится только имя первой ячейки PGC и более ничего, остальные ячейки сохранят свои имена. Это сделано сознательно, имя принадлежит каждой ячейке PGC независимо. Menu ID изменить в данном случае нельзя. Этот раздел свойств PGC интересен еще и возможностью увидеть назначение таких PGC команд как Next PGC, Prev PGC и Goup PGC. Сейчас мы не будем останавливаться на них подробно, но желательно отложить в своей памяти информацию о том, где можно увидеть значение этих команд. Если выбрать закладку PGC Command, то мы увидим приблизительно такое меню:

Это меню может вполне пригодиться в дальнейшей работе над проектом. В нем можно увидеть и изменить команды из нашего Title меню. Например, если вы соединили ячейку Cell с каким-либо элементом вашего проекта, то брать этот переход можно только здесь, сменив команду Jump to PGC in System Space на No Operation. То же самое можно проделать с переходами с Pre и Post, выбрав нужный тип в ниспадающем меню под закладкой PGC Commands. Поскольку мы начали упоминать некоторые команды PGC, опишем их кратко:

  • Pre - команда выполняется до того, как PGC будет воспроизводиться. Иными словами, соединив флаг Pre PGC с каким либо объектом, мы исключаем проигрывание этой PGC.

  • Post - команда выполняется после завершения проигрывания PGC. Соединив Post с началом самой PGC (для этого достаточно мышью щелкнуть на Post и отпустить затем мышь в любом месте первого прямоугольника PGC), мы получим, например, "петлю", т.е. бесконечное проигрывание PGC.

  • Cell - практически эквивалентно Post, но только для одной ячейки PGC. В данном случае это одно и то же, но если ячеек несколько (так будет, например, в фильме, разбитом на chapters), то это будет далеко не одно и то же. Любое соединение Cell с любым объектом проекта означает безусловный переход к этому объекту по завершении проигрывания Cell.

Выбрав закладку Video, мы увидим:

Самое полезное для нас использование этого раздела свойств PGC - возможность замены видеофайла меню. Нажав в строке File на кнопку ... мы всегда можем заменить видеофайл, не изменяя что-либо еще в конкретном меню или в сценарии в целом. Забегая вперед, можно заметить, что это единственный способ замены именно видеофайла во всех видах объектов Scenarist. Поскольку описанию работы с Subpicture посвящен отдельный раздел, сейчас мы пропустим описание меню по закладке Subpicture and Highlight.

Мы продолжаем рассмотрение элементов PGC в целом и Title меню в частности. Ячейку Program вполне можно пропустить, а на следующей ячейке, с тем же названием (Cell) мы остановимся подробнее. Сама ячейка имеет два флага - NSM и Cell. Что означает флаг Cell, мы выяснили выше - напомним, что соединив флаг Cell с любым другим допустимым объектом сценария, мы создадим безусловный переход к этому объекту по завершении проигрывания нашей ячейки. Что касается флага NSM, то на нем можно остановиться чуть подробнее. NSM расшифровывается как Non-SeaMless, т.е. прерывистое. Все ячейки проекта в Scenarist могут иметь флаг как NSM, так и SM - Seamless, т.е. непрерывное. Флаг NSM присваивается по умолчанию всем одиночным ячейкам, а также любой ячейке в последовательности, перед которой есть переход к другому объекту от предыдущей ячейки. Поясним на примере. На рисунке вы видите главы фильма и все они имеют флаг SM:

Но стоит соединить одну из ячеек с другим объектом, как картина меняется:

Следующая за этой ячейка тут же получает флаг NSM (Not Seamlessly - не непрерывное). Значение этого флага в большей степени информационное и фактически означает, что выполнение любой команды при воспроизведении DVD-Video диска может дать (но может и не дать) паузу в этом воспроизведении. После выбора ячейки Cell нам будет интересна закладка Navigation в Simulation Window:

Кроме уже упоминавшегося параметра Seamless, нам может пригодиться, причем в большей степени, параметр Cell Command, ибо только здесь мы можем отменить неправильно созданную для Cell команду. Для этого достаточно выбрать в ниспадающем меню No Command.

Следующая ячейка PGC - Buttons. К ней "приписываются" функции всех кнопок меню. Эта ячейка всегда отсутствует во всех не-меню PGC. После выбора этой ячейки в Simulation Window появляется новая закладка:

Здесь возможно:

  • Назначение каждой кнопке команд, в том числе и тех, которые нельзя создать простым соединением объектов, таких как выбор аудиодорожки, например. Меню Command задает тип команды, окошко ниже служит для более подробного описания команды.

  • Удаление любой команды с любой кнопки выбором No Operation в ниспадающем меню.

  • Задание параметров выбора звуковой дорожки, камеры и субтитров, а также выполнение перехода при выполнении определенных условий. Об этих возможностях мы расскажем чуть позже.

Конечно, в большинстве случаев, в этой закладке вы будете видеть результаты построения вами связей кнопок меню с другими объектами сценария диска, которые, естественно, также представляют собой команды.


DVD Info - Soft intro - Scenarist NT - Inside Scenarist NT - Working with Menu - Working with two levels Menus - Title Menu

DVD своими руками: Обзор программ: Scenarist NT - Углубленное изучение

Title Menu

После загрузки программы и перехода в экран сценариев мы видим всегда одну и ту же картину:

Прежде чем добавить в проект главное (Title) меню, необходимо определить язык, с которым будет это меню. Никогда раньше мы не объясняли, зачем, собственно, требуется вначале всегда указывать язык и большинство читателей до сих пор считают, что это бесполезная рутинная операция. На самом деле это совсем не так. Во-первых, первое меню возникает на экране до того, как появляется возможность сменить язык. Во-вторых, DVD плееры, как правило, имеют возможность установки в своем Setup языка по умолчанию и среди предлагаемых ими языков, увы, не всегда есть русский, а точнее, его почти всегда нет. Когда используемый язык один и как в VMG так и в VTS установлен один и тот же единственный язык, то язык роли не играет (у плеера нет выбора), но если создается два или более меню на разных языках, а DVD плеер русского не знает, то всегда в качестве первого меню на экране появится то меню, язык которого плеер знает, поэтому надо создавать разноязычные меню и дорожки с учетом этого фактора и не всегда выбирать в Scenarist именно те языки, которые будут реально использоваться.

Итак, добавляем язык по команде Add/Language:

Затем добавляем меню в VMG (здесь и далее мы предполагаем, что вы знакомы как с описанием ReelDVD, так и с кратким описанием Scenarist и все необходимые файлы вами предварительно подготовлены и введены в программу):

Очевидно, вы уже обратили внимание, что элементы Title меню в сущности ничем не отличаются от элементов любой другой PGC проекта. Поскольку PGC была рассмотрена подробно выше, останавливаться опять на этой теме мы не будем. Естественно, что Menu ID для Title Menu так и будет - Title Menu. Title Menu главное на диске - только из него возможен доступ к разным VTS и/или к разным Root Menu в пределах одного VTS. Но, поскольку подавляющее большинство любительских фильмов и большинство коммерческих не используют несколько VTS, и меню на различных языках создают как обычные меню внутри одного Root Menu, Title Menu просто не используется. Такой способ также удобен тем, что зритель попадает всегда в одно и тоже меню, независимо от того, какую кнопку на пульте со словом Menu он нажал. Краткий опрос нескольких владельцев DVD плееров показал, что практически никто из них не знал о существовании двух типов меню, не говоря уже о знании различий между ними.

Для того, чтобы "обойти" Title Menu, достаточно в качестве меню присоединить к иконе языка Title Menu любой графический файл (он займет меньше всего места на DVD-Video диске), а затем соединить флаг Pre получившегося меню с Root Menu. После этого вызов любого меню приведет к попаданию в Root Menu.


DVD Info - Soft intro - Scenarist NT - Inside Scenarist NT - Working with Menu - Working with two levels Menus - Root Menu

DVD своими руками: Обзор программ: Scenarist NT - Углубленное изучение

Root Menu

Root Menu является в подавляющем большинстве случаев обязательным элементом DVD-Video диска. Root Menu в каждом VTS может быть только одно для одного языка. Естественно, если языков в VTS несколько, то и Root меню может быть несколько. При создании нескольких Root menu следует помнить о том, что выбор конкретного меню на конкретном языке можно будет делать только через Title menu. Для создания Root Menu правильнее всего "присоединить" нужное меню к соответствующему Language самым первым - в этом случае Scenarist автоматически присвоит меню атрибут Root. Итак, вначале мы видим:

Установив курсор на иконе VTS_1, по правой кнопке мыши выбираем Add Language.., далее выбираем нужный язык (в подавляющем большинстве случаев это будет русский - Russian) и OK.

На экране Scenarist мы увидим

Теперь можно добавить Root Menu описанным выше способом:

Как видно из рисунка, атрибут Root программа присвоила автоматически. Если подробно рассмотреть "строительные" блоки Root menu, то они не будут отличаться от любой PGC с меню ничем, за исключением Menu ID:

Если необходимо использовать несколько разделов Root Menu, например присоединить к нему меню эпизодов, то следует "наложить" дополнительные меню на ячейку Program Root Menu. Получится сценарий подобного вида:

Не правда ли, картинка очень напоминает вид в сценарии программы Scenarist обычного фильма, разбитого на главы (chapters)? Это действительно так, поэтому создавая таким образом меню диска, не следует забывать, что в этом случае все меню представляет собой главы в одной PGC и после проигрывания одного меню (как бы chapters) плеер автоматически перейдет к проигрыванию следующего меню. Чтобы это не случилось, следует просто "замкнуть" ячейку cell каждого меню на себя. Для этого, выбрав флаг cell и нажав левую кнопку мыши, надо просто переместить курсор вверх и влево в пределах той же ячейки и отпустить кнопку мыши. Программа покажет соединение соответствующей стрелкой:

Обратите внимание, что цвет флагов cell изменился на желтый - это признак назначения команды ячейке. В любой момент времени вы можете проверить команду, примененную к ячейке, выбрав ее (ячейку) мышью - в окне ниже, в поле Cell Command в Окне Свойств (Property browser), можно увидеть команду, примененную к ячейке:


DVD Info - Soft intro - Scenarist NT - Inside Scenarist NT - Working with Menu - Working with two levels Menus - Audio Menu

DVD своими руками: Обзор программ: Scenarist NT - Углубленное изучение

Audio Menu

Audio Menu,по замыслу разработчиков стандарта DVD-Video, предназначалось для управления выбором аудио дорожек, но, строго говоря, необходимости в нем, как и в ряде других специализированных меню, нет. Выбрать нужную аудио дорожку можно в любом меню, но, тем не менее, отдельное Audio Menu может быть напрямую вызвано в большинстве программных компьютерных плееров и более наглядно видно в сценарии диска. Кроме этого, к Audio меню можно обратиться напрямую командой Jump to PGC in System Space. Для ввода в сценарий аудио меню следует "наложить" созданное вами для этого меню на икону Language VTS, как показано на рисунке:

Аудио меню не будет создано автоматически. Для присвоения флага аудио меню следует выбрать мышью верхнюю ячейку (PGC) и в Окне Свойств (Property browser) установить параметр Menu ID в значение Audio Menu.

Аудио меню есть смысл использовать при необходимости установить нужную звуковую дорожку фильма. Делается это следующим образом:

  • В редакторе сценариев в аудио меню выбирается ячейка Buttons

  • В Simulation Window выбирается закладка Button Commands, как показано на рисунке выше

  • Мышью выбирается номер кнопки в Command List, нажатие которой должно вызвать переключение дорожек.

  • В ниспадающем списке команд выбрать Set Angle/Audio/Sub-picture, как показано на рисунке:

  • После этого на экране появится меню установки, где

    • Immediate - установка номера (аудиотрека, субтитров, камеры) в значение, указанное непосредственно в команде

    • GRPM - установка номера в значение, находящееся в выбранном GRPM регистре

    • Set Angle Stream ID to - установка номера камеры

    • Set Audio Stream ID to - установка номера аудиодорожки

    • Display Subpicture - разрешение/запрещение отображения subpicture (здесь подразумеваются субтитры)

    • Set Subpicture Stream ID to - установка номера дорожки субтитров

    • Compare - разрешение сравнения содержимого регистров

    • Link - переход по выполнению команды

  • Выберите желаемый номер аудиодорожки и/или субтитров

Назначение кнопке команды не отменяет переход по нажатию этой же кнопки. Прежде чем назначить кнопке команду, можно соединить ее с нужным объектом. Этот прием особенно удобен именно для аудио меню, поскольку после выбора аудиодорожки разумно автоматически вернуться в главное меню, например, т.е. совместить выбор и переход.


DVD Info - Soft intro - Scenarist NT - Inside Scenarist NT - Working with Menu - Working with two levels Menus - PTT Menu

DVD своими руками: Обзор программ: Scenarist NT - Углубленное изучение

PTT Menu

PTT меню предназначено, как следует из названия, для выбора эпизодов фильма. Никаких дополнительных возможностей, как и в случае с Audio Menu, нет. К PTT меню также можно обратиться напрямую командой Jump to PGC in System Space. Для ввода в сценарий PTT меню следует присоединить созданное вами для этого меню к иконе Language VTS, как показано на рисунке:

PTT меню не будет создано автоматически. Для присвоения флага PTT меню следует выбрать мышью верхнюю ячейку (PGC) и в Окне Свойств (Property browser) установить параметр Menu ID в значение PTT Menu. Применение PTT меню имеет смысл только ради наглядности создаваемого вами сценария.


DVD Info - Soft intro - Scenarist NT - Inside Scenarist NT - Working with Menu - Working with two levels Menus - Subpicture&angle menu

DVD своими руками: Обзор программ: Scenarist NT - Углубленное изучение

Subpicture и angle меню

Никаких особенностей эти типы меню по сравнению с Audio и PTT не имеют. К этим меню также можно обратиться напрямую командой Jump to PGC in System Space. Понятно, что Subpicture меню предназначено для выбора субтитров, поскольку субтитры представляют собой также subpicture, но без единой кнопки, естественно. Как правило, выбор субтитров и аудиодорожек делается в одном меню, которому может быть присвоен атрибут либо Audio menu, либо Subpicture menu. Правила установки желаемой дорожки субтитров аналогичны установки аудиодорожки, поэтому вы можете воспользоваться описанием Audio Menu, где рассказано, как это сделать. В Angle menu смысла нет в принципе - камеры интересно переключать во время просмотра фильма, поэтому, если вы используете съемку несколькими камерами, то соответствующая индикация все равно будет на плеере и телевизоре и зритель сможет увидеть, что в этом фильме можно посмотреть вид с другой камеры.


DVD Info - Soft intro - Scenarist NT - Inside Scenarist NT - Working with Menu - Working with two levels Menus - UOP Enable/Disable

DVD своими руками: Обзор программ: Scenarist NT - Углубленное изучение

Разрешение/Запрещение операций зрителя с PGC (фильмами)

В этом разделе мы расскажем о некоторых возможностях по разрешению/запрещению автором DVD диска выполнения зрителем некоторых операций. Наиболее частый случай применения такой возможности - запрет зрителю на любые действия (переход в меню, переход к другому фильму и т.п.) во время просмотра First Play. На большинстве коммерческих дисков, где First Play обычно представляет собой рекламу или текст грозного предупреждения о незаконности копирования, так и делается в большинстве случаев. В Scenarist операции зрителя называются UOP (User OPeration).

Для доступа к UOP функциям следует:

  • Выбрать икону PGC того фильма, у которого вы хотите изменить разрешения для зрителя.

  • Ниже, в Property Browser Window найти строку UOP, как показано на рисунке:

  • Дважды щелкнуть мышью по этой строке

По завершении этих операций на экране появится полный список UOP, доступный для данной PGC (фильма или меню):

Функции каждого UOP оператора понятны из названий, по умолчанию они все разрешены (Permitted). Например, для запрета во время проигрывания фильма перехода в любое меню следует выбрать Prohibited для всех функций вызова меню - Menu_Call(Title), Menu_Call(Root), Menu_Call(Sub-picture), Menu_Call(Audio), Menu_Call(Angle), Menu_Call(PTT).


DVD Info - Soft intro - Scenarist NT - Inside Scenarist NT - Scenario Editor - Some parts

DVD своими руками: Обзор программ: Scenarist NT - Углубленное изучение

Работа с редактором сценариев

Создание фильма из нескольких фрагментов

Рассмотрим наиболее часто встречающуюся задачу - фильм состоит из нескольких частей, каждая из которых в отдельном файле и необходимо создать DVD-Video диск, зритель которого не смог бы определить, что фильм "сшит" из нескольких файлов. Решение этой задачи не сложно и состоит из нескольких этапов:

Подготовка:

  • все видеофрагменты должны быть сжаты в MPEG формат с общими глобальными параметрами, такими как тип кодирования (VBR или CBR), и плотность потока (bitrate).

  • начало и конец видео и аудио должны совпадать с точностью до кадра в каждом фрагменте.

  • начало каждого фрагмента по смыслу должно быть и началом очередной главы (chapters) - не обязательное требование, однако его невыполнение приведет к различию между количеством глав в меню и в фильме, поскольку начало любого фрагмента автоматически станет главой.

Редактор сценариев

  • Добавить Title_1 в первом VTS, как обычно.

  • Присоединить к иконе Title_1 первый фрагмент, как показано на рисунке:

  • Присоединить к PGC иконе первого фрагмента второй фрагмент.

  • Повторить для всех фрагментов.

  • Найти в цепочке chapters первую chapters второго фрагмента. Она легко обнаруживается по NSM флагу иконы Cell.

  • Выделите эту икону мышью. В появившемся Окне Свойств (Property browser) измените значение параметра Seamless Flag с Default (Not Seamlessly) (c перерывом) на Seamlessly (без перерыва). Если невозможно установить в значение Seamlessly (без перерыва), т.е. программа не предлагает такого выбора, то это означает нарушение какого-либо из условий подготовки фрагментов, описанных выше. Тем не менее, отсутствие возможности установить флаг Seamlessly (без перерыва) в подавляющем большинстве случаев не приводит к паузе при воспроизведении, поэтому очень расстраиваться по этому поводу не стоит.

  • Повторить для всех фрагментов.

Если вы все сделали правильно, то на созданном вами DVD-Video диске весь фильм будет проигрываться со сквозной нумерацией глав (chapters) и сквозной индикацией времени воспроизведения, поэтому зритель никогда не сможет определить, сколько было использовано фрагментов при авторинге диска.

Для перехода к какому-либо объекту (меню, например) по завершении просмотра фильма, соедините флаг Post иконы PGC фильма с желаемым объектом.


DVD Info - Soft intro - Scenarist NT - Inside Scenarist NT - Subtitles

DVD своими руками: Обзор программ: Scenarist NT - Углубленное изучение

Создание субтитров в фильме

Использование субтитров (subtitles) являются одним из интересных преимуществ показа фильма на DVD-Video диске. Субтитры, создаваемые в программе DVD авторинга, не "впечатываются" в картинку фильма, а существуют отдельным потоком, который может быть в любой момент включен или выключен. В этом состоит существенное отличие субтитров на DVD-Video диске от титров, создаваемых в видеоредакторе, которые нельзя изъять из фильма. Субтитры в подавляющем большинстве случаев используются для перевода оригинальных диалогов и титров фильма на другой язык и, кроме этого, для показа текстов песен в караоке-дисках.

Ввод субтитров в фильм состоит из нескольких этапов:

  1. Выбираем Settings/Default Settings/Subtitle Text

    Установки в этом меню следует сделать до ввода любых субтитров в проект, иначе они дадут никакого эффекта. Здесь:

    • Font (Шрифт) - указывается шрифт субтитров. Настоятельно рекомендуем Arial, который отлично читается с экрана.

    • Size (Размер шрифта) - подбирается экспериментально, на ваш вкус, но размер по умолчанию, 24, вполне подходит и шрифт такого размера нормально читается даже на телевизорах с диагональю 37 см.

    • Style (Стиль) - стандартные стили шрифта. Рекомендуется никакие стили не использовать, так как читаемость в большинстве случаев ухудшается.

    • Alignment (Выравнивание) - выравнивание субтитров. Очевидно, что лучше всего подходит Center (По центру).

    • Location (Расположение) - может иметь три значения:

      • Top (Вверху)

      • Middle (Середина)

      • Bottom (Внизу)

      К сожалению, программа имеет ошибку и наилучшее расположение субтитров, внизу экрана, получается при выборе Middle, а не Bottom, как должно было бы быть.

    • Render (Отрисовка) - выбор Full Screen приводит к формированию subpicture с субтитрами в полный размер кадра (для PAL - 720х576), выбор Text - к созданию subpicture чуть большего размера, чем сам текст. Мы рекомендуем оставить Full Screen, поскольку размер каждого файла subpicture увеличится по сравнению с Text ненамного, но с subpicture полного размера работать удобнее.

    • E2(Color 1) - цвет и интенсивность внешней огибающей контур буквы линии

    • E1(Color 2) - цвет и интенсивность внутренней огибающей контур буквы линии

    • P(Color 3) - цвет и интенсивность собственно букв

    • Bg(Color 4) - цвет и интенсивность фона

    • Set as default - нажатие этой кнопки приведет к тому, что установленные параметры станут параметрами по умолчанию для этого и любого следующего проекта.

    По нашему опыту наиболее предпочтительными и легко читаемыми буквы субтитров будут белого цвета с окантовкой черного цвета наружного и внутреннего контура букв на прозрачном фоне. Именно для такого вида на рисунке выше даны настройки. Примеры субтитров с такими же параметрами:

    Темный фон для субтитров

    Светлый фон для субтитров

    Как хорошо видно на этих рисунках, такие субтитры одинаково хорошо читаются как на светлом, так и на темном фоне.

  2. Устанавливаем продолжительность появления на экране субтитров

    Для этого выбираем Settings/Preference и на экране появляется следующее меню:

    В этом меню параметр Default Duration (Продолжительность по умолчанию) как раз и устанавливает продолжительность появления на экране каждого субтитра. Время задается в SMPTE формате, т.е. часы:минуты:секунды:кадры. По умолчанию задано 2 секунды. Как правило, этого времени вполне достаточно, но вы можете увеличить или уменьшить его. Следует только помнить, что здесь устанавливается единое время для всех субтитров проекта, поэтому разумнее всего для титров, которые требуют большее время на прочтение, увеличить время показа индивидуально. О том, как это сделать, мы расскажем ниже.

  3. Выбираем в Track Editor фильм (клип), к которому создаются субтитры

    Далее нажатием кнопки [image] запускаем Simulation Window. Выбираем в нем с помощью кнопок перемещения по клипу [image] то место в клипе, в котором необходимо появление субтитров и нажимаем в кнопку [image]. Окно просмотра плеера немедленно увеличится и на экране появится белый прямоугольник для ввода текста субтитров:

    Независимо от параметров текста, заданных в Settings/Default Settings/Subtitle Text при вводе текст всегда будет выглядеть черным на белом фоне. По завершении ввода текста, НЕ нажимая Enter, кнопками [image] следует перейти к следующему месту клипа, в котором должны быть размещены субтитры, ввести их, перейти к следующим и т.д. По завершении ввода субтитров можно легко "пробежаться" по ним для проверки, используя кнопки, обведенные на рисунке красной линией:

    При необходимости редактирования введенных субтитров следует нажать кнопку [image] и внести необходимые изменения. В принципе возможны изменения шрифта и его размера при вводе и редактировании субтитров, но мы не рекомендуем это делать, поскольку "разномастные" субтитры только затрудняют их чтение - на протяжении всего фильма шрифт и его размер менять не следует. Обведенными на рисунке кнопками можно перемещаться между субтитрами. По завершении ввода каждого субтитра Scenarist создает в каталоге <имя каталога проекта>\ <имя проекта Cache>\Encoded Files графические .bmp файлы с введенными вами субтитрами. Имена файлов имеют вид Subtitle Text_<порядковый номер субтитра>.bmp. Эти файлы полезно сохранить, чтобы в случае кардинальной переделки фильма не набирать их заново.


DVD Info - Soft intro - Scenarist NT - Inside Scenarist NT - Subtitles - Subtitle Script

DVD своими руками: Обзор программ: Scenarist NT - Углубленное изучение

Ввод субтитров с помощью скрипта.

Автоматизированный ввод субтитров возможен с помощью заранее написанного скрипта, который имеет такой вид:

st_format 2
Display_Start non_forced
TV_Type PAL
Tape_Type NON_DROP
Pixel_Area (2 574)
Display_Area (0 2 719 574)
Color (3 3 4 3)
Contrast (15 15 15 0)
E2 (0 0 255 ===)
E1 (255 0 0 ===)
PA (0 0 0 ===)
BG (255 255 255 ===)
Directory D:\VIDEO\CyprDVD\SubFiles
#####################################################
SP_NUMBER START END FILE_NAME
1 00:00:01:18 00:00:05:06 Subtitle Text_1.bmp
2 00:05:16:10 00:05:19:19 Subtitle Text_2.bmp

Для PAL и subpicture в полный экран в этом примере ничего менять не надо, за исключением, конечно, информации о каталоге с файлами ваших subpicture с субтитрами, именах файлов subpictupe и времени их появления в фильме. Файл скрипта должен быть создан в редакторе, не вносящем никакой информации от себя, т.е. в Notepad (Блокнот), например. Расширение имени файла скрипта - .sst.

Благодарим Айдара Туктагулова за помощь при подготовке описания работы с субтитрами в Scenarist.


DVD Info - Soft intro - Scenarist NT - Inside Scenarist NT - DVD disk record

DVD своими руками: Обзор программ: Scenarist NT - Углубленное изучение

Запись DVD диска

Scenarist позволяет записывать результат работы над проектом непосредственно на DVD рекордер. Традиционно профессиональные пользователи применяли DVD рекордеры только одобренных DVD форумом форматов, поэтому нам ничего не известно о поддержке Scenarist'ом приводов "плюсового" DVD+RW/R формата. Scenarist умеет записывать на любые приводы Pioneer, причем начиная с версии 2.7 поддерживается и Pioneer A05/105. Для записи DVD непосредственно на диск следует включить следующие параметры в Layout Editor:

Как вы наверняка заметили из рисунка, для записи DVD диска из Scenarist в обязательном порядке требуется создание образа диска (Create Disc Image). Несмотря на то, что создание образа диска занимает у программы немного времени (около 5-8 минут), это время следует учесть и также иметь ввиду, что не разрешив Delete When Done (удалить по окончании) в Step 2, вы должны для нормального завершения проекта иметь на диске свободное место, не меньше объема 3-х DVD дисков, т.е. 4.4 GBytes x 3 = 13.2 GBytes.

Если вы желаете сохранить данные об авторе диска, авторских правах, датах и т.п., то следует нажать кнопку PVD Editor и на экране появится редактор авторских данных диска:

Что следует писать в полях, понятно из названий, для описания Copyright, Abstract и Bibliograph следует подготовить текстовые файлы с обычными именами файлов и расширениями в формате 8.3 и при написании текстов использовать только большие латинские буквы, цифры, точку и подчеркивание. В поля Creation, Modification и т.д. вводятся даты. В поле Creation программа автоматически подставляет текущую дату в момент записи диска.

После выбора кнопки Start программа попросит установить болванку в привод (даже если она у вас давно там есть),

следует ответить ОК и Scenarist начнет свою работу. Вне зависимости от имени вашего проекта Scenarist создаст в Target Directories (определяется в Choose Target Directories) файл с именем DiscImage.dvd, причем Scenarist сам этот файл удалить не может. Если пробная запись прошла успешно и нужно сделать несколько копий диска, то файл образа вполне подойдет для использования в этих целях без применения Scenarist. В программе VOB Instant, например, для прожига DVD диска из образа, созданного Scenarist, следует проделать такие операции:

  • Выбрать после запуска Instant Disc

  • В появившемся списке шаблонов проектов выбрать UDF Video DVD Image

  • После запроса о типе и емкости носителя VOB попросит ввести имя файла образа. Нажав кнопку Browse, следует обязательно указать All Files (*.*) в поле Files of Type.

  • Найдя нужный каталог, выбрать файл DiscImage.dvd, как показано на рисунке:

На этом процесс закончен. VOB Instant успешно запишет образ DVD-Video диска от Scenarist.

Мы проверяли работу Scenarist ver. 2.7 на запись с приводами Pioneer A04/104 и Pioneer A05/105 - никаких проблем выявлено не было.

(!!!) - ряд наших читателей сообщили нам, что VOB Instant некорректно записывает DVD+R болванки, которые после записи не читаются вообще. Поэтому для работы с "плюсовыми" приводами мы рекомендуем использовать Nero Burning ROM версии НЕ НИЖЕ 5.5.10.7b. Выбор образа для прожига делается в Nero точно также, как и в VOB Instant. Следует также выбрать тип файлов как All files (*.*) и в появившемся окне

выбрать OK. Далее выбрать Write. Если появление окна Foreign image settings хочется избежать, то следует просто предварительно присвоить файлу образа от Scenarist расширении .iso.


DVD Info - Soft intro - Scenarist NT - Inside Scenarist NT - Programming Scenarist

DVD своими руками: Обзор программ: Scenarist NT - Углубленное изучение

Программирование в Scenarist NT

DVD стандарт, кроме возможностей по установке примитивных связей между объектами DVD проекта, разрешает также и программирование действий DVD плеера по воспроизведению DVD-Video диска. Возможности по программированию управления воспроизведением довольно обширны и мы постараемся рассказать о них, пояснив их конкретными примерами. Прежде чем приступить к описанию способов программирования, мы познакомимся с теми объектами, которые используются при программировании.


DVD Info - Soft intro - Scenarist NT - Inside Scenarist NT - Programming Scenarist - System parameters

DVD своими руками: Обзор программ: Scenarist NT - Углубленное изучение

Системные параметры

Задача системных параметров сохранить и сообщить автору состояние DVD плеера в текущий момент времени. Часть системных параметров определяются и устанавливаются DVD плеером, часть просто индикативных и могут быть только прочитаны. Системные параметры обозначаются как SPRM, всего их 24 (три не используются и зарезервированы для возможных будущих применений) и проще и понятнее считать их системными регистрами. Разрядность SPRM регистра 16 бит и, соответственно, максимальное значение регистра может быть 65535 в десятичной системе или FFFFh в шестнадцатиричной. Значения в регистрах SPRM можно просматривать и изменять (конечно, только разрешенные для изменения) во время воспроизведения во вкладке System Params Simulation window. Таблица ниже описывает SPRM регистры:

Номер регистра | Название регистра в Simulation window Scenarist | Наименование | Описание | Доступность по чтению (R) или записи (W) | Значение по умолчанию*
0 | Menu Disk Lang | Код языка меню | Определяет код языка, используемого в меню | R | Не определено
1 | Audio | Номер текущего аудио потока | Содержит номер текущего проигрываемого аудио потока | R/W | 000Fh 15d 1111b
2 | Subpicture | Номер текущего потока subpicture | Содержит номер текущего проигрываемого потока subpicture | R/W | 62d 111110b
3 | Angle | Номер камеры (Angle number) | Содержит номер текущего проигрываемого потока angle (камеры) | R/W | 1
4 | Title # | Номер тайтла | Содержит номер текущего проигрываемого тайтла | R/W | 1
5 | VTS Title # | Номер VTS | Содержит номер текущего проигрываемого VTS | R/W | Равно SPRM 4
6 | Title PGC # | Номер PGC с текущим тайтлом | Содержит номер PGC с текущим проигрываемым тайтлом. Если тайтл включает в себя несколько PGC, то содержимое регистра будет меняться во время воспроизведения. | R/W | Не определено
7 | PTTN | Номер главы или сцены (chapter, Part of Title) | Содержит номер текущей проигрываемой сцены. Номер, естественно, по мере изменения текущей сцены будет также меняться. | R/W | 1
8 | Highlight Btn | Номер последней выбранной кнопки меню | Содержит номер последней выбранной кнопки меню | R/W | 1
9 | Nav Tmr | Таймер для навигации | Параметр определяет время перехода к проигрыванию PGC, номер которой задается значением в SPRM10. Значение SPRM9 определяется автором и уменьшается каждую секунду текущего воспроизведения на единицу. При переходе к меню или выборе зрителем паузы значение SPRM 9 остается неизменным. SPRM 9 и SPRM 10 могут изменяться только в пределах домена VTS командами навигации. | R/W | 1
10 | Nav Tmr PGC # | Номер PGC для перехода по таймеру навигации |  | R/W | Не определено
11 | Audio Mix Mode | Режим караоке DVD плеера | Определяет возможности DVD плеера по микшированию аудио каналов для караоке. Если плеер караоке не поддерживает, то параметр игнорируется. | R/W | 0
12 | Country Code | Код страны для управления правами родителей | Указывает код страны для возможности запрета родителями просмотра нежелательного видео детьми. | R | Не определено
13 | Parental Level | Уровень запрета родителями | Определяет уровень запрета, устанавливаемый в соответствии с кодом страны, заданным в SPRM 12 | R/W | Не определено
14 | Player Config | Конфигурация плеера для просмотра видео | Определяет соотношение сторон кадра и текущий режим показа | R | Не определено
15 | P-CFG for Audio | Поддержка воспроизведения звука | Определяет возможности плеера по поддержке различных форматов звука, таких как Dolby Digital, MPEG, DTS и т.д. | R | Не определено
16 | Initial Lang Code | Стартовый код языка для звука | Определяет код языка и его расширение для текущего проигрываемого аудио потока. | R | FFFFh
17 | Initial Lang Code Ext | Стартовое расширение кода языка для звука |  | R | 00h
18 | INI_LCD for SPST | Стартовый код языка для subpicture | Определяет код языка и его расширение для текущей проигрываемой subpicture. | R | FFFFh
19 | INI_LCD_EXT for SPST | Стартовое расширение кода языка для subpicture |  | R | 00h
20 | Player Region Code | Код региона плеера | Сообщает установленный в плеере код региона. | R | Не определено
21, 22, 23 |  | Резерв |  |  |

*Примечание: если число в этом столбце заканчивается буквой h, то оно приводится в шестнадцатиричной системе счисления, если буквой d - десятичной, буквой b - двоичной.


DVD Info - Soft intro - Scenarist NT - Inside Scenarist NT - Programming Scenarist - GPRM

DVD своими руками: Обзор программ: Scenarist NT - Углубленное изучение

Общие параметры (регистры общего назначения)

Регистры общего назначения (GPRM) отличаются от системных (SPRM) тем, что они находятся в полной власти автора диска и он волен проделывать с ними любые допустимые операции. Разрядность GPRM регистра 16 бит и, соответственно, максимальное значение регистра может быть 65535 в десятичной системе или FFFFh в шестнадцатиричной. Значения в регистрах GPRM можно просматривать и изменять во время воспроизведения во вкладке General Params Simulation window. Всего этих регистров 16 и над ними допускаются следующие операции (выполняются по команде Set):

  • Assign (Присвоение) - присвоение регистру любого числового значения в диапазоне от 0 до 65535, а также значения, находящегося в любом другом GPRM или SPRM регистре.

  • Exchange (Обмен) - обмен содержимого одного GPRM регистра с другим GPRM регистром.

  • Add (Сложить) - прибавление к содержимому GPRM регистра числа или содержимого другого регистра или сложение значений в двух GPRM регистрах.

  • Subtract (Вычитание) - вычитание числа из содержимого GPRM регистра, вычитание из содержимого одного регистра содержимого другого.

  • Multiplay (Умножение) - умножение числа на содержимое GPRM регистра или умножение содержимого двух GPRM регистров.

  • Divide (Деление) - деление содержимого GPRM регистра на число или деление содержимого одного GPRM регистра на другой и запись частного от деления, которое не может быть равно нулю.

  • Remainder (Остаток) - запись остатка от деления числа на значение GPRM регистра или остатка от деления одного регистра GPRM на другой.

  • Random Value (Случайное значение) - присвоение GPRM регистру случайно выбранного числа, которое не может быть равно нулю.

  • Bitwise Product (Побитовое умножение) - присвоение GPRM регистру результата побитовой операции AND (И) одного GPRM регистра с другим, числа с GPRM регистром, регистра GPRM с SPRM и т.д.

  • Bitwise Sum (Побитовое сложение) - присвоение GPRM регистру результата побитовой операции OR (ИЛИ) одного GPRM регистра с другим, числа с GPRM регистром, регистра GPRM с SPRM и т.д.

  • Exclusive OR (Исключающее ИЛИ) - присвоение GPRM регистру результата побитовой операции Exclusive OR (Исключающее ИЛИ) одного GPRM регистра с другим, числа с GPRM регистром, регистра GPRM с SPRM и т.д.


DVD Info - Soft intro - Scenarist NT - Inside Scenarist NT - Programming Scenarist - Scenarist Commands

DVD своими руками: Обзор программ: Scenarist NT - Углубленное изучение

Команды в Scenarist

Собственно говоря, все действия автора по соединению между собой объектов DVD проекта преобразуются программой Scenarist в различные команды. Но кроме автоматически формируемых команд, существует множество команд, которые автор может добавить только вручную. "Прикрепить" команды можно только к таким объектам в PGC:

  • Pre - команды будут выполняться ДО воспроизведения PGC. На один Pre можно "повесить" до 128 команд.

  • Post - команды будут выполняться ПОСЛЕ воспроизведения PGC. На один Post можно "повесить" до 128 команд.

  • Cell - команда будет выполняться после воспроизведения ячейки (Cell) PGC. На одну Cell можно формально "повесить" до 128 команд, но выполнится только первая из них. Если в PGC только одна Cell, то команда в Cell будет выполнена раньше команды (команд) в Post. Команды на Cell рекомендуется назначать только в случае невозможности какого-либо иного пути, поскольку это приведет в большинстве случаев к заметной на глаз задержке при воспроизведении фильма и флаг SM Cell с командой автоматически изменится на NSM.

  • Btns - в этом месте изначально можно "повесить" только команды перехода, которые потом, впрочем, можно изменить. Но добавить какие-либо команды в Simulation Window или еще каким-либо способом нельзя.


DVD Info - Soft intro - Scenarist NT - Inside Scenarist NT - Programming Scenarist - Scenarist Commands - JumpInstructions

DVD своими руками: Обзор программ: Scenarist NT - Углубленное изучение

Команды безусловного перехода (Jump)

Команды перехода (Jump) применяются автором чаще других и чаще всего сам автор об этом и не подозревает, поскольку именно в команды Jump преобразуются большинство действия автора по соединению объектов фильма связями. Команды Jump могут быть такими:

  • Jump to PGC (Переход к PGC) - соединяет меню или тайтл с другим меню или тайтлом внутри одного VTS.

  • Jump to Program (Переход к Program в PGC) - соединяет меню или тайтл с chapter (сценой, главой) внутри одной PGC.

  • Jump to Cell (Переход к ячейке) - соединяет меню или тайтл с ячейкой (Cell) внутри одной PGC.

  • Jump by Sub-Instructions (Переход с выполнением дополнительной операции) - с помощью этой команды можно решить много задач, но самым популярным применением команды является возврат из меню в то же место фильма, откуда выполнялся переход в меню - Jump by Sub-Instructions/Resume. Также может использоваться для изменения содержимого регистра SPRM 8 изменением номера текущей выделяемой кнопки.

  • Jump to Title (Переход к тайтлу) - соединяет меню или тайтл с любым тайтлом внутри одного VTS.

  • Jump to Part of Title (Переход к главе(сцене) - соединяет тайтл с главой (сценой) внутри того же тайтла. Не может быть использована в Pre.

  • Jump to Part of Title in VTS (Переход к главе(сцене) внутри VTS) - соединяет тайтл с любой главой (сценой) в любом тайтле внутри VTS. Может быть использована в Pre.

  • Jump to PGC in System Space (Переход к PGC в проекте) - соединяет тайтл или меню с другим тайтлом или меню в проекте. Необходима для соединения компонентов проекта из разных VTS или, например, для соединений из Video Manager в VTS.


DVD Info - Soft intro - Scenarist NT - Inside Scenarist NT - Programming Scenarist - Scenarist Commands - GroupsAndTypes

DVD своими руками: Обзор программ: Scenarist NT - Углубленное изучение

Группы и типы команд

Группы команд
Группа | Какие основные задачи решают команды группы | Могут быть объединены с командами из групп
Link (Соединить) | Старт видео в текущем домене | Set, Compare и SetSystem
Jump | Старт видео в указанном домене | Compare
GoTo | Переход к другой команде навигации | Compare
Compare | Сравнивает указанные параметры | Jump, GoTo, Set, Link и SetSystem
SetSystem | Устанавливает навигационные параметры | Link и Compare
Set | Задает значения GPRM | Link и Compare
Типы команд

Всего существуют три типа команд согласно DVD стандарту. Это:

  • Первый тип (Type 1) - команды этого типа всегда состоят только из одной инструкции.

  • Второй тип (Type 2) - команды этого типа состоят из 2-х инструкций.

  • Третий тип (Type 3) - команды этого типа включают в себя команды из групп Compare, Set и Link to SubInstruction и тем самым состоят из трех инструкций.

Правила использования команд различных типов сведены в таблицу:

Команда | Тип | Описание | Количество инструкций в команде
GoTo | 1 | Меняет порядок выполнения инструкций | 1
Link | 1 | Начинает выполнение указанного действия внутри домена (включая выделение кнопки) | 1
Jump | 1 | То же самое, что и Link, но в другом домене | 1
Compare GoTo | 1 | Если результат сравнения истина (true), то выполнение команды GoTo | 1
Compare Link | 1 | Если результат сравнения истина (true), то выполнение команды Link | 1
Compare Jump | 1 | Если результат сравнения истина (true), то выполнение команды Jump | 1
SetSystem | 2 | Установка навигационных параметров (регистров) GPRM и SPRM | 2
Set | 2 | Установка GPRM | 2
Compare SetSystem | 2 | Если результат сравнения истина (true), то выполнение команды SetSystem | 2
Compare Set |  | Если результат сравнения истина (true), то выполнение команды Set | 2
SetSystem Link | 2 | Сначала выполнение команды SetSystem, затем Link | 2
Set Link | 2 | Сначала выполнение команды Set, затем Link | 2
Set Compare LinkSIns | 3 | Сначала выполняется команда Set, затем, если результат сравнения по команде Compare истина (true), то переход к выполнению команды LinkSIns | 3
Compare & Set - LinkSIns | 3 | Сначала выполняется команда сравнения Compare и, если результат сравнения истина (true), то затем последовательно выполняются команды Set и LinkSIns | 3
Compare - Set & LinkSIns | 3 | Сначала выполняется команда сравнения Compare и, если результат сравнения истина (true), то затем последовательно выполняются команды Set и LinkSIns, причем LinkSIbs в этом случае игнорирует результат сравнения | 3

Для того, чтобы дальнейшая работа с командами в Scenarist была более понятной, позволим себе напомнить некоторые азы булевой алгебры, без которых освоение программирования в Scenarist будет затруднено. Итак, для начала рассмотрим операцию AND (И), которая в Scenarist (и не только в нем, конечно) также обозначается символом &. Эта операция также может называться логическим умножением. Scenarist всегда подразумевает, что данные в регистрах будут сравниваться побитово. Операция AND для каждого бита выполняется следующим образом:

  • 0 & 0 = 0 (False - ложь)

  • 0 & 1 = 0 (False - ложь)

  • 1 & 0 = 0 (False - ложь)

  • 1 & 1 = 1 (True - истина)

Поясним это на примере. Допустим, вы хотите сравнить значения по AND в двух регистрах. В одном из них десятичное число 25 (оно же двоичное 00011010, оно же шестнадцатиричное 1A) с другим, в котором содержится десятичное число 9 (оно же двоичное 00001001, оно же шестнадцатиричное 09). Результат будет таким:

00011010
00001001
-------------
00001000 = True (Истина)
Результат оказался true, поскольку одна единица появилась в результате. В противном случае результат был бы False (Ложь). Расшифровка обозначений операций сравнения в Scenarist приведена в таблице ниже:

& | Логическое AND (И). Результат будет true (истина), если в нем есть хотя бы одна единица. В противном случае он будет равен false (ложь). Если результат true, то будет выполнена следующая команда.
== | Если сравниваемые значения РАВНЫ, то команда будет выполнена.
!= | Если сравниваемые значения НЕ РАВНЫ, то команда будет выполнена.
>= | Если результат РАВЕН или БОЛЬШЕ, то команда будет выполнена.
> | Если результат БОЛЬШЕ, то команда будет выполнена.
<= | Если результат РАВЕН или МЕНЬШЕ, то команда будет выполнена.
< | Если результат БОЛЬШЕ, то команда будет выполнена.


DVD Info - Soft intro - Scenarist NT - Inside Scenarist NT - Programming Scenarist - Programming Examples

DVD своими руками: Обзор программ: Scenarist NT - Углубленное изучение

Примеры программирования в Scenarist NT

Прежде чем приступить к описанию конкретных примеров использования команд, мы рекомендуем вам создать тестовый проект в Scenarist, весьма удобный для отладки любых сложных проектов и просто для освоения Scenarist. Для создания этого проекта надо проделать такие действия:

  1. Сделать .bmp картинку 720х576 с надписью Тайтл меню. В качестве subpicture сделать надпись "Переход к Root".

  2. Аналогичную картинку сделать с надписью Root меню и в subpicture сделать две кнопки "Просмотр фильма" и "Выбор эпизодов".

  3. Создать три картинки для меню эпизодов, вид которых ясен из рисунка (все надписи, кроме "Первое PTT меню", есть кнопки в subpicture):

    Понятно, что остальные две картинки PTT меню такие же, но номера частей другие.

  4. Для подготовки фильмов в наш тестовый проект в видеоредакторе надо:

    1. Написать в титровальной программе редактора для вступительного клипа слова FirstPlay и с минимальным bitrate закодировать в MPEG-2 на 30 секунд клип. Никакие файлы импортировать в проект не требуется.

    2. Создать проект, в котором написать титры "Часть 1", задав длительность 1 минута, затем "Часть 2" с такой же длительностью и т.д. до части 12-ой включительно. Кодировать полученный фильм с минимальным bitrate. Никакие файлы импортировать в проект не требуется.

Файлы .bmp с меню и subpicture к ним и файлы проектов для FirstPlay и основного фильма для Ulead MediaStudio Pro 7.0 вы можете переписать здесь (~70 кБ). Необходимые пояснения по файлам находятся в readme.txt внутри архива. Далее создадим тестовый проект в Scenarist. Файл сценария тестового DVD для Scenarist также лежит в архиве с остальными файлами проекта, ссылка на который дана выше.

Наш проект имеет такой вид:

В качестве пояснения, если по каким-либо причинам вы не сможете запустить наш готовый сценарий:

  • Основной фильм разбит на двенадцать глав (сцен) по минуте каждый в соответствии с сделанными титрами.

  • В Title меню связь с единственной кнопки идет на Root меню

  • Из Root меню с кнопки "Просмотр фильма" идет связь к фильму, с кнопки "Выбор эпизодов" - к PTT меню

  • В PTT меню от кнопок "Часть 1", "Часть 2" и т.д. идут связи к соответствующим частям (сценам) фильмам, от кнопки "Главное меню" к Root меню, от кнопки "Назад" к предыдущему меню эпизодов (к Root для первого меню эпизодов), от кнопки "Вперед" к следующему меню эпизодов (к Root для последнего меню эпизодов).

  • Post FirstPlay соединен с основным фильмом, а Post основного фильма соединен с Root меню.

Остальные связи вполне понятны из рисунка.
Смысл этого проекта в том, что глядя на экран в Simulation window Scenarist или экран телевизора при просмотре результатов работы, вы всегда будете совершенно точно знать, где вы находитесь. По "живому" фильму это значительно труднее сделать. Кроме этого, весь проект займет на DVD диске менее 200 мегабайт (если вы использовали bitrate при кодировании не более 2000 кбит/сек) и его запись на диск отнимет всего несколько минут. Как мы увидим позже, не все действия Scenarist по выполнению им некоторых команд можно проверить в самом Scenarist - в некоторых случаях потребуется запись на диск. Мы рекомендуем использовать этот проект всем, кто начинает осваивать Scenarist.


DVD Info - Soft intro - Scenarist NT - Inside Scenarist NT - Programming Scenarist - Programming Examples - JumpToResume

DVD своими руками: Обзор программ: Scenarist NT - Углубленное изучение

Пример первый

- возвращение из меню в тот же момент фильма, откуда в меню уходили

Задача: Зритель во время просмотра фильма нажимает кнопку меню, просматривает меню, или просто желает таким способом прервать на время просмотр, но потом, выбирая в меню просмотр фильма, хочет вернуться то же место, откуда он перешел в меню. Кратко это функция называется Resume. Решение этой задачи несложно и для начала рассмотрим именно ее.
При решении любой задачи необходимо руководствоваться обыкновенным здравым смыслом, поэтому первой операцией, которой нам надо сделать, это как-то запомнить тот факт, что мы смотрели фильм и вышли в меню именно из него. Проще всего это сделать, записав какое-нибудь число в GPRM регистр. Для этого щелкнем мышью на ярлыке Pre основного фильма. программа автоматически вызовет Simulation window и на экране появится такой диалог:

Как видно из рисунка, никаких команд на Pre нет. Для ввода команды сначала следует снять флажок у No Command (Нет команды). На экране появится диалог ввода команды:

Поскольку нам надо просто записать в GPRM число, то мы выберем в ниспадающем меню Command (Команда) команду Set to GPRM (Установить GPRM):

По умолчанию команда Set to GPRM настроена на присвоение значения (Assign) одного регистра GPRM другому. Если мы хотели бы присвоить значение SPRM регистра регистру GPRM, то в поле Set следовало бы выбрать SPRM. Нам же требуется занести число и для этого в поле Set нам надо выбрать Immediate (Немедленно):

Занесем в регистр GPRM0 число 100. Для нашего примера совершенно все равно, какое именно число будет занесено, лишь бы оно отличалось от нуля. Тем самым, поскольку мы "повесили" команду на Pre, при любом входе в фильм мы присваиваем GPRM0 значение 100.
Теперь нам надо обнулить это число по окончании фильма. Для этого щелкнем мышью на ярлыке Post фильма (помните, что в нашем сценарии Post был соединен с Root меню):

Как видно из рисунка, после окончания фильма программа дает возможность при использовании функции Resume вернуться к любой главе (сцене) фильма, причем по умолчанию переход происходит к началу фильма, т.е. первой главе (сцене). Для нашей задачи такой автоматический способ возвращения по завершении просмотра подходит, но мы будем считать, что его нет для чистоты эксперимента. Поскольку очередность команд менять нельзя, мы просто заменим команду перехода в Root меню на команду присвоения нулевого значения регистру GPRM0:

Теперь нажмем кнопку Add (Добавить) и введем команду перехода к Root меню:

C фильмом все необходимые действия проделаны, теперь настало время для работы с Root меню. Выберем ячейку Buttons (Кнопки) в Root меню и в Simulation window мы увидим:

Нас интересует как раз первая команда, поскольку она относится к кнопке "Просмотр фильма". Как мы писали ранее, на кнопку можно "повесить" только одну команду, а поскольку реализовать полностью все нужные нам действия никакой единственной командой, даже Type 3, не удастся, надо придумать способ, как обойти это ограничение. Наиболее простое решение в этом случае - просто перейти к Post в Root меню, поскольку на Post можно "повесить" до 128 команд. Так мы и сделаем:

Как видно из рисунка, мы "повесили" на кнопку команду безусловного перехода к Post. Теперь щелкнем мышью на ярлыке Post Root меню:

Снимем флажок с параметра No Command (Нет команды) и выберем команду Jump by Sub-Instructions с подкомандой Resume, как показано на рисунке:

Команда Jump by Sub-Instructions с подкомандой Resume как раз и возвращает зрителя в то место Title, откуда зритель попал в меню. Если оставить все как есть, то переход по Resume будет выполняться всегда, что нам не подходит, поскольку зритель может попасть в Root меню из вступительного клипа (First Play), например и тогда нажатие кнопки "Просмотр фильма" в Root меню приведет к тому, что зритель снова вернется в вступительный клип, а не перейдет к просмотру фильма. Поэтому установим флажок Compare (Сравнить):

Выбор Compare (Сравнение) означает, что действие по команде, в которой вы разрешили сравнение, будет выполнено в том и только в том случае, если результат сравнения - истина (true). Если результат ложь (false), то команда будет просто пропущена и DVD плеер перейдет к обработке следующей по списку команде. Установите в поле Compare Immediate и введите число 100 в соответствующем поле, как показано на рисунке выше. Если в GPRM будет число 100, то переход к точке выхода из фильма (Resume) произойдет, в противном случае нет. Но что означает значение регистра GPRM0, не равное 100? Это означает, что зритель еще не смотрел фильм и нам надо просто перейти к соответствующему Title, что мы и сделаем, добавив по кнопке Add команду Jump to Title (Переход к тайтлу) и выбрав в поле ниже Title_2, как показано на рисунке:

На этом собственно программирование закончено. Следует иметь ввиду, что вы не сможете проверить в Simulation window переход по Resume. Несмотря на то, что программа явно отрабатывает этот переход, в окне Simulation window картинка не меняется. Но, сделав образ DVD-Video на жестком диске, вы можете убедиться в правильности работы заданных вами команд, используя программный DVD плеер, такой как PowerDVD, например. Не забудьте замыкать ячейку Cell Root меню саму на себя, поскольку если вы для Root меню будете использовать видеоклип, то при незамкнутом цикле воспроизведения плеер попадет в Post и перейдет к просмотру фильма.

На этом мы завершили описание первого примера, сценарий которого вы можете переписать отсюда.


DVD Info - Soft intro - Scenarist NT - Inside Scenarist NT - Programming Scenarist - Programming Examples - ReturnToMenu

DVD своими руками: Обзор программ: Scenarist NT - Углубленное изучение

Пример второй

- возвращение из фильма в тот же раздел меню, к какому относится проигрываемый фрагмент фильма

Задача: Зритель во время просмотра фильма нажимает кнопку меню и после нажатия попадает именно в тот раздел меню эпизодов, к которому относился проигрываемый в момент нажатия кнопки меню фрагмент. Это удобно, поскольку зритель сразу может увидеть, в какой части фильма он находится и перейти в любое другое место уже вполне осознанно. Если же пользователь захочет попасть в главное меню, ему надо будет просто нажать кнопку меню еще раз.
При решении любой задачи необходимо руководствоваться обыкновенным здравым смыслом, поэтому первой операцией, которой нам надо сделать, это как-то запомнить тот факт, что мы смотрели фильм и вышли в меню именно из него. Проще всего это сделать, записав какое-нибудь число в GPRM регистр. Для этого щелкнем мышью на ярлыке Pre основного фильма. программа автоматически вызовет Simulation window и на экране появится такой диалог:

Как видно из рисунка, никаких команд на Pre нет. Для ввода команды сначала следует снять флажок у No Command (Нет команды). На экране появится диалог ввода команды:

Поскольку нам надо просто записать в GPRM число, то мы выберем в ниспадающем меню Command (Команда) команду Set to GPRM (Установить GPRM):

По умолчанию команда Set to GPRM настроена на присвоение значения (Assign) одного регистра GPRM другому. Если мы хотели бы присвоить значение SPRM регистра регистру GPRM, то в поле Set следовало бы выбрать SPRM. Нам же требуется занести число и для этого в поле Set нам надо выбрать Immediate (Немедленно):

Занесем в регистр GPRM3 число 100. Для нашего примера совершенно все равно, какое именно число будет занесено, лишь бы оно отличалось от нуля. Тем самым, поскольку мы "повесили" команду на Pre, при любом входе в фильм мы присваиваем GPRM3 значение 100.
C фильмом все необходимые действия проделаны (помните, что по умолчанию флаг Post фильма должен быть соединен с флагом Pre Root Menu), теперь настало время для работы с Root меню. Выберем флаг Pre в Root меню и в Simulation window мы увидим:

Как видно из рисунка, никаких команд на Pre нет. Подумаем, что нужно сделать для перехода к нужной ячейке меню эпизодов:

  1. Записать в GPRM регистр номер текущей главы, который, как нам известно, находится в регистре SPRM7.

  2. Определить, из фильма мы попали в меню или из какого-либо другого места - например, из того же меню эпизодов. Если не из фильма, то никаких действий не предпринимать.

  3. Если из фильма, то сразу перейти к меню эпизодов.

Введем команды для выполнения описанной последовательности:

Как видно из рисунка, мы переписали в регистр GPRM7 содержимое регистра SPRM7 и, тем самым, в регистре GPRM7 теперь хранится номер главы (сцены), которую смотрел зритель перед тем, как нажать кнопку меню. Регистр GPRM7 выбран произвольно, можно выбрать любой другой, за исключением GPRM3, который мы уже используем для запоминания входа в фильм. Далее проверяем, откуда мы пришли в меню и делаем переход к меню эпизодов, если пришли из фильма:

Понятно, что если содержимое GPRM3 не равно 100, т.е. мы не смотрели фильм, то мы просто попадаем в Root Menu. В этом случае все дальнейшие действия зрителя идут обычным путем и нас интересовать не будут. Если же мы переходим сразу к меню эпизодов, т.е. мы пришли из фильма, то нам надо сделать такие операции:

  1. Снова проверить, откуда мы пришли, поскольку зритель может попасть в меню эпизодов и обычным путем через Root Menu. Если не из фильма, то просто перейти к первому меню эпизодов.

  2. Стереть информацию о том, что мы пришли из фильма, поскольку попав потом в меню эпизодов, действия зрителя могут быть любыми и он, в частности, может захотеть попасть в Root Menu. В этом случае, если содержимое GPRM3 останется равным 100, бедный зритель опять попадет в меню эпизодов.

  3. Выполнить операции сравнения содержимого регистра GPRM7 с числовыми константами и в зависимости от результатов сравнения перейти к соответствующей ячейке меню эпизодов.

Проверяем, откуда пришли в меню эпизодов и переходим к первому меню эпизодов и к первой кнопке в этом меню, если пришли не из фильма:

Если условие не было выполнено, то следующим пунктом - обнуление GPRM3:

Теперь выполняем сравнения и переход:

На рисунке в выделенных красным полях указаны значения для последней команды, конечно. В этом примере в качестве кнопки по умолчанию выбрана 5-ая, т.е. кнопка перехода к Root Menu, которая есть в каждом меню эпизодов. Понятно, что может быть выбрана любая другая кнопка. Если же вы хотите, чтобы зритель попал именно на ту кнопку, которая относится к просматриваемой зрителем главе, то это просто потребует большего количества команд. Пример:

Делая свой проект, подобный рассмотренному в нашем примере, вы должны учесть:

  1. Для того, чтобы выбирались заданные вами кнопки, следует установить параметр Nonexistent, как описано в Раздел Highlight.

  2. Если Title Menu реально используется, то на его Pre надо "повесить" обнуление того регистра, который применялся для запоминания факта просмотра фильма (в нашем примере это GPRM3), поскольку при сознательном выборе Title Menu очевидно, что зрителю меню эпизодов не нужно.

На этом мы завершили описание второго примера, сценарий которого вы можете переписать отсюда.


DVD Info - Soft intro - Scenarist NT - FAQ

DVD своими руками: Обзор программ: Scenarist NT - Маленькие хитрости

Маленькие хитрости

Здесь мы будем публиковать информацию по интересным и не указанным явно в документации возможностям программы, а также по решению ряда проблем при ее использовании в виде FAQ.

  • У меня почему-то мерцают различные элементы неподвижных меню. Кроме этого, часто элементы выделения (квадраты, например) "теряют" одну сторону изображения. Можно ли избежать подобных неприятностей и как?

  • Создал проект для освоения возможностей Scenarist из коротких фрагментов видео и обнаружил, что DVD-Video диск, полученный в результате работы над тестовым проектом, совершенно по разному работает на разных плеерах. В чем может быть дело, в ошибке Scenarist?

  • В каждом своем проекте я создаю несколько меню эпизодов, в которых используются одинаковые subpicture, но, тем не менее, для каждого меню мне приходится задавать кнопки отдельно. Нельзя ли автоматизировать этот процесс?

  • Где можно обсудить проблемы с программой Scenarist и задать вопросы по ней?

  • Создал несколько проектов на Scenarist, удалил их с диска за ненадобностью, но до сих пор при запуске программы на новый проект она выводит список всех проектов, которые я когда-либо делал. Как избавиться от старых "хвостов"?

У меня почему-то мерцают различные элементы неподвижных меню. Кроме этого, часто элементы выделения (квадраты, например) "теряют" одну сторону изображения. Можно ли избежать подобных неприятностей и как?

Избежать этих раздражающе неприятных моментов можно, если придерживаться нескольких простых правил:

  • Линии в subpicture всегда рисовать толщиной не менее 2 пикселей

  • Количество пикселей в нарисованном вами графическом элементе subpicture должно быть четным.

  • Большие элементы выделения в меню наиболее правильно делать как подсветку, т.е. красивая и интересная рамка, например, создается по всем правилам подбора цветов, с обязательным сглаживанием (soft) краев и anti-aliasing. Для выделения этой рамки в subpicture следует нарисовать рамку чуть меньшего или такого же размера без размытия краев и anti-aliasing, но с условием установки яркости в меню НЕ БОЛЕЕ 50-60%. Тоже относится и к тексту - нельзя присваивать 100% яркость тексту в качестве элемента выделения - он получится практически всегда "размытым" на экране телевизора.

  • Если изображение рисуется в графическом редакторе с "нуля", то она должно быть размером 768х576.

  • Если вы планируете нарисовать текст, рамки и т.п. в графическом редакторе и хотите в качестве фона использовать кадр из DV клипа, этот кадр должен быть приведен также к размеру 768х576 и только после этого вставлен как фон для меню.

  • По завершении создания меню его картинка и subpicture должны быть сохранены с разрешением 720x576 с обязательной отменой параметра Keep Aspect Ratio (или аналогичного ему).

  • Если вы сомневаетесь в правильности созданного вами неподвижного меню, настоятельно рекомендуем создать из файла меню DV клип и просмотреть его на экране телевизора через видеокамеру. Если мерцания и других артефактов не будет, то их не будет и после авторинга диска.

  • Крайне редко, но в артефактах бывают виноваты встроенные MPEG кодеры программ DVD авторинга. Это обнаруживается в том случае, если меню как DV клип воспроизводилось нормально, а после авторинга, уже на DVD диске, появились артефакты. Если такой эффект появился, то "переведите" ваше неподвижное меню в motion, поскольку motion menu никак не меняется программой DVD авторинга.

К сожалению, эти правила полностью применимы только к некоторым программам DVD авторинга, таким как ReelDVD или Scenarist. Мерцающие меню, "усеченные" рамки и т.п. при авторинге в этих программах могут появиться только благодаря небрежному отношению автора диска к своей работе. В массовых, недорогих программах, которые не дают автору прямой доступ к subpicture, таких как Ulead DVD Workshop, Dazzle DVD Complete, Pinnacle Studio 8 и т.п. артефакты возможны и безвсякой вины автора, из-за несовершенства алгоритмов генерации subpicture и встроенных кодеров MPEG.

Правила по размерам меню в 768х576 мы уже приводили, но считаем не лишним их снова повторить.

Наверх

Создал проект для освоения возможностей Scenarist из коротких фрагментов видео и обнаружил, что DVD-Video диск, полученный в результате работы над тестовым проектом, совершенно по разному работает на разных плеерах. В чем может быть дело, в ошибке Scenarist?

Нет, Scenarist делает все правильно. Дело в том, что каждый минимальный фрагмент (Cell) файла с видео, используемый для создания DVD диска, должен быть продолжительностью не менее 6 VOBU (VOB Unit), каждый из VOBU, в свою очередь, может быть от 0.4 до 1 секунды. Если это условие не выдержать, то проблемы с совместимостью вам гарантированы. Еще раз обращаем ваше внимание, что речь идет о Cell, т.е. минимальном объекте DVD-Video диска. Отсюда следует и то, что chapters (scenes) нельзя ставить чаще, чем 1 раз в 7 секунд. Мы же рекомендуем использовать Cell продолжительностью не менее 15 секунд. Кстати, компонуя диск, Scenarist сообщает о слишком коротких Cell таким образом:

Warning The Prev Cell<sp-16-t-scn-cell>, the Current Cell<sp-Costa-Dourada-t-scn-ce> and the Next Cell<sp-17-t-scn-cell> are connected seamlessly and the Current Cell<sp-Costa-Dourada-t-scn-ce>(VOBU:5) has less than 6 VOBU.(PGC:<sp-01-t-pgc> (Title:<Title_2> VTS:<VTS_1>) )

Warning Some DVD players have problems with this limitation.

Благодарим Валерия Комягина за помощь в подготовке этого ответа.

Наверх

В каждом своем проекте я создаю несколько меню эпизодов, в которых используются одинаковые subpicture, но, тем не менее, для каждого меню мне приходится задавать кнопки отдельно. Нельзя ли автоматизировать этот процесс?

Конечно, можно и, добавим к этому, нужно, тем более что это очень просто. Сначала необходимо указать кнопки для первого меню, задать правила перемещения курсора, после чего выбрать в Track Editor содержимое Hightlight дорожки. Затем по правой кнопке мыши в появившемся меню выбрать Copy, открыть дорожку с другим подобным меню, выбрать курсором дорожку Highlight, нажать правую кнопку мыши и выбрать Paste. Далее проделать тоже самое для остальных меню.

Наверх

Где можно обсудить проблемы с программой Scenarist и задать вопросы по ней?

Это можно сделать в конференции по Scenarist http://boris.al-ko.ru/sc/.

Наверх

Создал несколько проектов на Scenarist, удалил их с диска за ненадобностью, но до сих пор при запуске программы на новый проект она выводит список всех проектов, которые я когда-либо делал. Как избавиться от старых "хвостов"?

Очень просто. Надо найти в директории, в которой установлен Scenarist, файл scenarist.ini и с помощью Notepad (Блокнот) удалить строчки в последней секции [Recent Files List] этого файла.

Совет прислан Борисом Прохоровым.

Наверх


DVD Info - Technical Information - DVD Media Compability

DVD своими руками: Техническая информация: Совместимость DVD носителей

Совместимость DVD носителей

Какие носители с какими устройствами совместимы - экспериментальные данные

  • Первое тестирование: октябрь-ноябрь 2001 года

  • Второе тестирование: декабрь 2001 года

  • Данным журнала DV Magazine

  • Совместимость DVD-R болванок - информация к размышлению

  • Данные пользователей


DVD Info - Technical Information - DVD Media Compability - First test

DVD своими руками: Техническая информация: Совместимость DVD носителей - Первый тест

Первое тестирование: октябрь-ноябрь 2001 года

В связи с выявленными проблемами совместимости дисков DVD-R/RW и DVD+R/RW мы решили сообщить имеющиеся у нас данные по этой проблеме.

Мы проводили тестирование на одном и том же любительском фильме, сначала записанном на DVD-R, а затем скопированном через жесткий диск на DVD+RW. Сам диск был создан полностью на Ulead DVD Plug-in к программе Ulead MediaStudio Pro 6.5, в котором используется MPEG кодер от Ligos.

 | Модель устройства | DVD+RW | DVD-R
Компьютерные DVD-ROM | Panasonic SR 8585-B | Нет | Да
 | Philips 5200 | Нет | Нет
 | Hitachi JD 2000 | н/д | Да
 | HP DVD 100i | Да | Да
 | Pioneer 113 | н/д | Да
 | Pioneer A03 | Да | Да
 | Creative 1241E | н/д | Да
Бытовые DVD плееры | Pioneer 525 | Нет | Да
 | Philips 712(722) | Нет | Да
 | Philips 7002 | Нет | Нет
 | Philips 950 | н/д | Нет
 | SONY 505 | Нет | Да
 | Panasonic 320 | н/д | Да
 | Pioneer 535 | Да | Да
 | Pioneer 34х | н/д | Да

В этой таблице:

  • Да - диск нормально читается и воспроизводится

  • Нет - диск не распознается устройством

  • Н/д - нет данных, не проверялся


DVD Info - Technical Information - DVD Media Compability - Second test

DVD своими руками: Техническая информация: Совместимость DVD носителей - Второй тест

Второе тестирование: декабрь 2001 года

Как мы тестировали:

  1. Все RW диски создавались на полностью предварительно стертых болванках, для чего выполнялась процедура Full Erase.

  2. Копия лицензионного диска (он не имел защиты от копирования) создавалась с помощью последней на момент тестирования программы RecordNow, рекомендуемой компанией Hewlett-Packard для работы со своим приводом DVD100i.

  3. Кроме копии оригинального фильма и одной копии любительского фильма, все остальные диски записывались с помощью программы Sonic DVDit! PE версии 2.5. Эта программа поддерживает как Pioneer A03, так и Hewlett-Packard DVD100i.

  4. Одна из копий любительского фильма создавалась и записывалась программой Ulead DVD Movie Factory, поддерживающей привод Pioneer A03.

 |  | Вид DVD носителя
 |  | DVD+RW HP | DVD+RW HP | DVD-RW | DVD-RW | DVD-R
 |  | Содержание диска и способ создания
 |  | Фильм "Крепкий орешек" (копия 1:1 лицензионного фильма) | Ligos MPEG Encoder, DVDit PE 2.5 DVD Authoring program. Любительский фильм | CCE Encoder, Ulead Movie Factory DVD authoring - Любительский фильм | Ligos MPEG Encoder, DVDit PE 2.5 DVD Authoring program - Любительский фильм | Ligos MPEG Encoder, DVDit PE 2.5 DVD Authoring program - Любительский фильм
DVD плеер | Pioneer 535 | да | да | да | да | да
 | Pioneer 515 | да | да | да | да | да
 | SONY 7700 | да | да | нет | н/д | да
 | SONY 725D | да | да | да | да | да
 | SONY 700 | да | да | да | да | да
 | SONY 300 | да | да | да | да | да
 | Pioneer 626 | да | да | да | да | да
 | SONY 505 | нет | нет | нет | нет | отдельные главы
 | Panasonic 320 | да | да, со 2-го раза | да, со 2-го раза | да, с 3-го раза | да
 | Denon 2500 | нет | нет | нет | нет | да, с зависаниями
DVD-ROM | Hitachi JD 2000 | читает, замедленная работа с меню | читает, замедленная работа с меню | нет | нет | отдельные главы
 | Philips 5200 | нет | нет | нет | нет | да, изредка притормаживая
 | Pioneer 113 | да | да | да | да | да, изредка притормаживает

В этой таблице:

  • Да - диск нормально читается и воспроизводится

  • Нет - диск не распознается устройством

  • Н/д - нет данных, не проверялся

Данное тестирование показало значительно лучшие результаты для привода HP DVD100i по сравнению с более ранними тестами. Правильный подход к записи DVD дисков на этом устройстве способен улучшить читаемость DVD+RW дисков и добиться совместимости, близкой к DVD-R.


DVD Info - Technical Information - DVD Media Compability - DV Magazine

DVD своими руками: Техническая информация: Совместимость DVD носителей - Данные DV Magazine

Совместимость DVD носителей по данным журнала DV Magazine

Введение

В апреле-мае 2002 года весьма авторитетный журнал DV Magazine провел серьезное исследование совместимости DVD носителей различных типов и выпущенных различными производителями. Результаты были сначала опубликованы в бумажной версии журнала и только 14 июня были выложены в online. Руководил тестированием известный профессионал в DVD мире Ralph LaBarge, автор около 200 DVD проектов. В тестировании участвовало 5 компаний, так как было необходимо проделать огромный объем работы с сотнями болванок и десятками моделей плееров. Поскольку это первая серьезная работа по проверке совместимости различных носителей, выполненная профессионалами своего дела, мы сочли необходимым сообщить краткую выжимку результатов тестирования от DV Magazine. Желающие ознакомиться с полной версией результатов могут легко это сделать по ссылке выше (для этого необходима только бесплатная регистрация).

В тестировании участвовали следующие модели DVD плееров (в скобках указан год выпуска)

Модели тестируемых DVD-Video плееров
Akai | DVP1000 (1998)
Apex | AD500W (2001), AD600A (2001), AD660 (2000)
Denon | DVD1000 (1998)
GE | GE1105P (2000)
Hitachi | DVP305U (2000), DVP315U (2000)
JVC | XV511BK (1999), XV523GD (2000), XVD723GD (2001)
Kenwood | DVD404 (2001)
KLH | DVD221 (2000)
Magnavox | DVD611 (2001)
Microsoft | XBox (2001)
Oritron | DVD100 (1999), DVD200 (2000)
Panasonic | DVDA100 (1998), DVDA300 (1999), DVDA350 (1998), DVDRP56 (2001), DVDRV20 (2001), DVDRV31 (2001)
Philips | DVD621 (2002), DVD711 (2000)
Pioneer | DV333 (1999), DV341 (2001), DV414 (1998), DV434 (2000), DV500 (1997), DV505 (1998), DVC302D (1999), DVS9 (1998), DVDV7400 (2000), PDVLC10 (2000)
Proscan | PS8680Z (1999)
RCA | RC5200P (1997), RC5215P (2000), RC5220P(2000), RC5400P (2002)
Samsung | DVDM301 (2001), DVD511 (2000), DVD611 (2000), DVD709 (2000)
SMC | DVD3308 (1999)
Sony | DVPNC600 (2001), DVPS315 (1998), DVPS330 (1999), DVPS345 (2000), DVPS360 (2001), DVPNS400 (2002), DVPS550 (1999), DVPNS700P (2001), DVPS7000 (1997), DVPS7700 (1999), Playstation 2 (2001)
Thompson | DTH1000 (1998)
Toshiba | SD1700 (2001), SD2300 (2000), SD2700 (2001), SD3000 (1996), SD3006 (1997), SD4700 (2002), SD6109C (2000), SD6200 (2000)
Zenith | DVD2100 (1999), DVD2200 (1999)


DVD Info - Technical Information - DVD Media Compability - DV Magazine - Manufactures Compability

DVD своими руками: Техническая информация: Совместимость DVD носителей - Данные DV Magazine

Совместимость по производителям носителей

В тестировании участвовали следующие производители DVD носителей:

Производители записываемых DVD носителей различных типов
DVD-R для Authoring (3.95GB) - диски этого формата не могут быть записаны на обычных недорогих DVD рекордерах | DVD-R для Authoring (4.7GB) - диски этого формата не могут быть записаны на обычных недорогих DVD рекордерах | DVD-R для General (4.7GB) - именно этот формат используется обычными пользователями | DVD-RW (4.7GB) | DVD+RW (4.7GB)
Mitsui Pioneer Ridata TDK Verbatim | Maxell Mitsui Pioneer Ridata Ritek Taiyo Yuden TDK Verbatim | Apple CD-Recordable.com Imation Maxell Memorex Mitsui Panasonic Pioneer Ridata Ritek Sony TDK Verbatim Vivastar | JVC Memorex Pioneer Ridata Ritek Sony TDK Verbatim | HP Memorex Sony Verbatim

Результаты тестирования по DVD-R такие:

  1. Maxell - 80% DVD-R прошли все тесты
  2. TDK - 76% DVD-R прошли все тесты
  3. Sony - 76% DVD-R прошли все тесты
  4. Mitsui - 73% DVD-R прошли все тесты
  5. Apple - 73% DVD-R прошли все тесты
  6. Imation - 71% DVD-R прошли все тесты
  7. Ridata - 69% DVD-R прошли все тесты
  8. Verbatim - 69% DVD-R прошли все тесты
  9. Panasonic - 69% DVD-R прошли все тесты
  10. Vivastar - 63% DVD-R прошли все тесты
  11. Memorex - 59% DVD-R прошли все тесты
  12. Pioneer - 58% DVD-R прошли все тесты
  13. Ritek - 51% DVD-R прошли все тесты

По остальным типам носителей результаты сведены в таблицу:

Результаты тестирования носителей от разных производителей
DVD-R for Authoring (3.95GB) | DVD-R for Authoring (4.7GB) | DVD-RW (4.7GB) | DVD+RW (4.7GB)
Mitsui (98%) Pioneer (98%) Ridata (98%) TDK (96%) Verbatim (90%) | Maxell (76%) Mitsui (69%) Pioneer (65%) Ridata (69%) Ritek (71%) Taiyo Yuden (63%) TDK (67%) Verbatim (59%) | JVC (59%) Memorex (55%) Pioneer (61%) Ridata (55%) Ritek (59%) Sony (61%) TDK (61%) Verbatim (61%) | HP (57%) Memorex (57%) Sony (57%) Verbatim (55%)


DVD Info - Technical Information - DVD Media Compability - DV Magazine - Media Types Compability

DVD своими руками: Техническая информация: Совместимость DVD носителей - Данные DV Magazine

Совместимость по типам носителей

Совместимость для всех плееров, независимо от даты выпуска:

  1. DVD-R для authoring 3.95gb: 96%
  2. DVD-R для authoring 4.7gb: 67%
  3. DVD-R для general 4.7gb: 66%
  4. DVD-RW 4.7gb: 58%
  5. DVD+RW 4.7gb: 56%

Совместимость для новых плееров, выпущенных с 2001 года:

  1. DVD-R для authoring 3.95gb: 100%
  2. DVD-R для authoring 4.7gb: 94%
  3. DVD-R для general 4.7gb: 93%
  4. DVD-RW 4.7gb: 89%
  5. DVD+RW 4.7gb: 80%


DVD Info - Technical Information - DVD Media Compability - DV Magazine - Final

DVD своими руками: Техническая информация: Совместимость DVD носителей - Данные DV Magazine

Заключение

По результатам тестирования авторы сделали следующие выводы:

  1. DVD-R для авторинга (3.95 GB) является наиболее совместимым форматом из тех, что применяются для профессиональных целей.

  2. DVD-R для общего использования наиболее совместим среди форматов, применяемых обычными пользователями.

  3. DVD-RW и DVD+RW имеют приблизительно одинаковую совместимость с небольшим преимуществом DVD-RW.

  4. DVD-RW и DVD+RW нежелательно использовать для распространения своих фильмов из-за меньшей, по сравнению с DVD-R, совместимости.

  5. Совместимость DVD-RW и DVD+RW практически не зависит от фирмы-производителя носителя.

  6. Однократно записываемые носители, выпущенные известными производителями, более совместимы, чем носители от малоизвестных производителей.

  7. Если используется носитель от малоизвестного производителя, то чем меньше скорость записи на диск, тем выше совместимость полученной записи.

  8. Использование при кодировании фильма bitrate менее 7 mbit/s повышает совместимость полученного диска.

От себя можем заметить, что это тестирование наконец-то покончило с мифом о лучшей в мире совместимости DVD+RW. Миф этот усиленно раздувается некоторыми компаниями и отдельными "независимыми" сайтами в сети, хотя с самого начала выпуска DVD+RW было понятно и неспециалистам, что их совместимость будет на уровне DVD-RW - это следовало просто из объявленных самими же производителями параметров DVD+RW.


DVD Info - Technical Information - DVD Media Compability - DVD_R Compability Facts

DVD своими руками: Техническая информация: Совместимость DVD носителей - Совместимость DVD-R болванок

Совместимость DVD-R болванок - информация к размышлению

Введение

Обратить внимание на качество DVD-R нас заставили проблемы с совместимостью записанных как нами так и многими пользователями DVD-Video дисками, причем в последнее время эти проблемы обострились и количество жалоб возросло. Причины общего ухудшения качества DVD-R дисков в целом понятны.

Во-первых, по оценкам IDC к концу 2002 года будет продано 3.2 миллиона пишущих "минусовых" DVD приводов и рынок болванок к ним становится все более "вкусным" (для справки - конкурирующих "плюсовых" приводов будет продано в 2.2 раза меньше). Во-вторых, всегда в момент бурного роста рынка желающих получить свою долю пирога очень много, а надлежащей квалификации у многих игроков нет. В третьих, легкость и небольшие затраты для перевода производства с CD-R на DVD-R делает этот бизнес как бы легким. В четвертых, мелкие и средние игроки не хотят тратить деньги на хоть какое-то плотное тестирование своей продукции, поскольку такое тестирование стоит времени и денег. Поэтому нам пришлось самим провести подобное исследование качества DVD-R болванок, результаты которого и предлагаем вниманию читателей.

Для тестирования мы использовали brand name DVD плееры Pioneer и Panasonic, а также плееры BBK различных моделей. Плееры Pioneer отличаются очень хорошей читаемостью, плееры Panasonic в этом плане хуже, плееры BBK намного лучше читают то, что не читает Pioneer'ы и наоборот, как это не странно.

Для точного определения марки DVD-R болванки мы использовали небольшую программу advdinfo, которая считывает такой параметр болванки, как Pre-recorded Information in Lead-In, в котором есть информация о производителе и конкретном типе болванки этого производителя. Для записи в качестве оригиналов мы использовали два образа DVD-Video дисков с фильмами, причем один диск был заполнен до 4 701 000 000 байт, другой до 4 667 000 000 байт. Записи на все болванки производились с этих образов на Pioneer 104 с firmware 1.20. Записи на болванки, начиная с 20 позиции, выполнялись на Pioneer 105 с firmware 1.21.

Кроме наших собственных тестирований, мы анализировали многочисленные отзывы наших партнеров и клиентов. Количество проверенных болванок колеблется от 2 до 10 каждого типа при наших собственных тестированиях и эти данные суммируются в соответствии с отзывами наших читателей. Таким образом, согласно закону больших чисел, картина оказывается достаточно приближенной к реальности.

Результаты исследования мы свели в таблицу


DVD Info - Technical Information - DVD Media Compability - Strange Results

DVD своими руками: Техническая информация: Совместимость DVD носителей - Совместимость DVD-R болванок

Удивительное - рядом!

Мы совершенно случайно, даже можно сказать нечаянно, проделали такой эксперимент:

  • Создали из одних и тех же MPEG и .ac3 файлов два практически одинаковых проекта, один в Sonic DVDiT! Professional Edition, другой в ReelDVD 2.5.1.

  • Размер проекта был выбран максимально возможным, для того, чтобы на записанном диске осталось не более 40 MBytes свободного места.

  • Оба проекта в виде образов DVD-Video дисков были записаны на один и тот же жесткий диск.

  • Каждый образ был записан на этом же компьютере DVD рекордером Pioneer 104 на болванки № 1 из таблицы выше программой VOB Instant CD/DVD ver. 6.4.

Результат анализа совместимости нас просто поразил - болванка, записанная образом от ReelDVD показала прекрасные результаты по беспроблемной читаемости на различных DVD плеерах. Никаких подтормаживаний и квадратов даже в самом конце диска! Про результаты совместимости после Sonic DVDiT PE см. комментарии к болванке № 1. Надо заметить, что плохая совместимость оказалась не только у DVDiT. Диски, созданные программами от Ulead, например, ничуть не лучше в этом плане. Мы с достаточными основаниями подозреваем, что и у других скороспелых программ, появившихся в последний год-два, совместимость не лучше.

Несмотря на заголовок этой главки, ничего удивительного здесь, как не странно, нет. VOB Engine у программ Scenarist NT и ReelDVD (в обеих программах VOB Engine одинаков) отрабатывался с 1996 года на сотнях наименований коммерческих DVD-Video дисков и результаты очевидны - совместимость лучше и намного.

Мы завершили этот эксперимент записью обоих образов на болванки Verbatim. Результат был легко прогнозируемым - оба диска читались везде и всюду.


DVD Info - Technical Information - DVD Media Compability - Selfmade testing

DVD своими руками: Техническая информация: Совместимость DVD носителей - Совместимость DVD-R болванок

Как определить качество болванки самому?

Резонный вопрос - если в таблице выше нужного мне типа болванки нет, как понять, хорошие ли болванки мне предлагают? Рецепт здесь очень простой. Надо купить хотя бы пару болванок для теста, записать их до заполнения, причем совершенно неважно, каким видом данных. Можно просто заполнить ее различными файлами по максимуму. Затем следует запустить программу Nero CD Speed, которая входит в обычный комплект поставки Nero Burning ROM. Если болванка, на которую вы записывали, хорошего качества, то после теста картинка будет примерно такой:

На некачественной болванке тест вообще может не дойти до конца, но в любом случае всегда возникают заметные зубцы на графике и ближе к концу болванки скорость чтения резко падает:

К сожалению, тест с помощью Nero Burning ROM может быть полезен в том и только в том случае, если результат его отрицательный. Компьютерные DVD-ROM намного лучше читают диски, чем бытовые DVD плееры, поэтому хорошие результаты по этому тесту совершенно не означают, что записанный на такую болванку DVD-Video диск будет нормально проигрываться на бытовом плеере. Мы неоднократно убеждались в справедливости этого правила на практике. Отрицательный же результат, наоборот говорит о том, что раз компьютерный DVD-ROM плохо читает болванку, то ждать нормального проигрывания на бытовом плеере не приходится.


DVD Info - Technical Information - DVD Media Compability - Comments

DVD своими руками: Техническая информация: Совместимость DVD носителей - Совместимость DVD-R болванок

Комментарии

Результаты тестирования, которое реально шло достаточно долгое время, произвели на нас удручающее впечатление. Особенно расстроила особенность всех дешевых болванок (и дорогой Memorex) давать дефекты при воспроизведении записи в конце диска. Это плохо тем, что не все авторы DVD дисков просматривают их после записи до конца и могут не знать о том, что на самом деле конец фильма может не проигрываться нормально. Из реально доступных в России болванок приличными можно назвать только Verbatim и TDK (поскольку DVD-R от Pioneer есть тоже Verbatim). Цена Verbatim в 1.5-2 раза выше no brand болванок, но стоит тщательно подумать перед приобретением дешевых болванок, поскольку поговорка "не гонялся бы ты поп за дешевизной" может быть в данном случае очень актуальной.

Единственная, на наш взгляд, область применения дешевых болванок - это резервное хранение данных, поскольку сам Pioneer 104/103 их читает нормально, а если не записывать данные до заполнения диска, то и другие DVD-ROM смогут их читать. Кроме этого, есть еще одна крайне неприятная особенность дешевых болванок - недолговечность параметров. Мы столкнулись с тем, что у ряда пользователей, купивших дешевые DVD-R болванки полгода тому назад, резко ухудшилось качество чтения их на бытовых DVD плеерах. К сожалению, здесь тестированием нельзя определить, как долго читаемость болванки будет сохраняться на высоком уровне.

Кроме этого, можно сделать еще один вывод - если по каким-то причинам вы используете no brand DVD-R болванки, то создавать DVD-Video диски для них настоятельно рекомендуется программами Scenarist NT или ReelDVD.

Но ситуацию не стоит драматизировать. Подобная картина лет 5 назад была и среди CD-R болванок, но сейчас она изменилась и разительной разницы в качестве CD-R нет. Рынок выдавит некачественные болванки, но пока следует быть очень осторожными. Мы с удовольствием разместим информацию о не упомянутых в этой заметке болванках и ее можно присылать на main@spline.ru.


DVD Info - Technical Information - DVD Media Compability - From users

DVD своими руками: Техническая информация: Совместимость DVD носителей - Данные пользователей

Данные пользователей

Если кто-то из наших читателей ЛИЧНО проверил на совместимость какие-либо плееры или компьютерные DVD-ROM с DVD-R/RW и/или DVD+R/RW, то просьба сообщить нам результат в таком виде (дано для примера):

Пример
Модель устройства | Кодер MPEG | Bitrate | Программа создания DVD | Носитель | Результат тестирования | Прислал
Pioneer 535 | Ligos, Ulead MediaStudio Pro 6.5 | VBR, 5900 в среднем | Ulead DVD Plug-in | DVD-RW | Читается, меню работает, артефактов (дерганий, запинаний и т.п. нет) | dvdguru@guru.ru

Сообщения с subject DVD Media Testing просьба присылать на main@spline.ru. Мы будем публиковать эту информацию по мере поступления. Такая информация поможет всем выбрать как бытовой DVD плеер, так и DVD рекордер для создания своих DVD-Видео дисков. Кроме этого, из присланных данных видны особенности работы различных программ для создания DVD-Video дисков.

Таблица совместимости по данным, присланным пользователями:

Модель устройства | Кодер MPEG | Bitrate | Программа создания DVD | Носители | Результат тестирования | Прислал
BBK-903 | TMPGEnc 2.02 | VBR, 5000 в среднем | UleadDVD MovieFactory | DVD-R/ DVD-RW | Читаются только DVD-R, но с небольшими сбоями в меню. Само видео показывается нормально. DVD-RW не воспринимаются вообще. | seravkin@yandex.ru
BBK-908S | CCE 2.62/Ligos | VBR, 5000- 6000 в среднем | UleadDVD Movie Factory, UMSP6.5, Sonic DVDit! PE 2.5, Ulead DVD Workshop | DVD-R/ DVD-RW/ DVD+RW | Читаются все диски без каких-либо проблем, не воспринимаются меню, сделанные программами DVD-Autoring от Ulead | Собственное тестирование
BBK-919PS | CCE 2.62/Ligos | VBR, 5000- 6000 в среднем | UleadDVD Movie Factory, UMSP6.5, Sonic DVDit! PE 2.5, Ulead DVD Workshop | DVD-R/ DVD-RW/ DVD+RW | Читаются все диски без каких-либо проблем | Собственное тестирование
BBK-921S | CCE 2.50 & TMPEG 2.54 | VBR, 6000 в среднем, 8000-8500 peak | Sonic DVDit! PE 2.5 | DVD-R/ DVD-RW | Никаких проблем, все нормально с чтением. Странности с кнопкой Next. PowerDVD и Hollywood+ делают то, что заказано в авторинге, а BBK перескакивает на Prev/Next клип в том порядке, в котором они записаны на диск. Порядок этот, кажется, соответствует порядку присоединения линков на клипы к кнопкам. (Прим. от Сплайн - это особенности DVDit! и не связаны с оборудованием) | baitsur@parascript.ru
D-Pro (Lenoxx) 9000M | CCE 2.62 | VBR, 6000 в среднем | Sonic DVDit! PE 2.3 | DVD-R/ DVD-RW | Читаются только DVD-R, но с ними проблем никаких | fanatnle@hotmail.com
D-Pro DVD-9200 | CCE 2.62/Ligos | VBR, 6000 в среднем | Sonic DVDit! PE 2.3 | DVD-R/ DVD-RW/ DVD+RW | Читаются только DVD-R, DVD-RW/ DVD+RW не воспринимаются вообще. | Собственное тестирование
D-Pro DVD-3200 | CCE 2.62/Ligos | VBR, 6000 в среднем | Sonic DVDit! PE 2.3 | DVD-R/ DVD-RW/ DVD+RW | Читаются только DVD-R, DVD-RW/ DVD+RW не воспринимаются вообще. | Собственное тестирование
Kenwood DVT-7000 | CCE 2.62/Ligos | VBR, 5500 в среднем | Sonic DVDit! PE 2.3 | DVD-R/ DVD-RW | Читаются превосходно, без артефактов | Тестирование клиента с предоставленными нами DVD дисками.
Panasonic DVD-RV20EU | CCE 2.62/Ligos | VBR, 5000- 6000 в среднем | UleadDVD Movie Factory, UMSP6.5, Sonic DVDit! PE 2.5, Ulead DVD Workshop | DVD-RW/ DVD-R/ DVD+RW | Никаких проблем, все нормально с DVD-RW/ DVD-R, но DVD+RW не понимаются вообще | Тестирование плеера, принесенного в компанию клиентом boris@al-ko.ru
Panasonic DVD-RV31EU | CCE 2.62 | VBR, 6000 в среднем | Sonic DVDit! PE 2.3 | DVD-RW/ DVD-R | Никаких проблем, все нормально | fanatnle@hotmail.com
Philips DVD-622 | DV500 v1.2, шаблон DVD PAL из-под Premiere 5.1c | CBR, 6000, звук PCM | MyDVD 2.3 | DVD-RW | Читается, меню работает, глюков вроде нет | videoing@mtu.ru
Philips DVD 722 | TMPGEnc 2.02 | VBR min 2000; Max 9500; средний 8500 | Ulead DVD Plug-in | DVD-R/ DVD-RW | Читаются превосходно, без артефактов | guslik@mail.ru
Philips DVD 711 | CCE 2.62, CCE 2.50, TMPGEnc Plus 2.54 | 2000 - 8000, CBR, VBR (несколько тестов с разными параметрами) | SpruceUp | DVD-R/ DVD-RW | Всё прекрасно читается (меню, фильм). Однако плеер требует, чтобы на диске было более 4 Гб данных. Если меньше - диск не распознаётся вообще. | FM
Samsung DVD-909/XEV | Pro-ONE v.1.5 under Premiere 6.02 | CBR, 8000, звук AC3 | Sonic DVDIt! PE2.3 | DVD-R/ DVD-RW | DVD-RW не понимает, DVD-R иногда на долю секунды подтормаживают | videoing@mtu.ru
Samsung DVD-909/XEV | Tsunami 2.54 | 352х288 VBR, в среднем 2000, звук MP2 | Ulead DWD Workshop 1.0 | DVD-R/ DVD-RW | См. выше, и ещё выделение в меню не работает! | videoing@mtu.ru
Sony NS700 | Pinnacle Express 1.10 | CBR, 8400, звук PСM | Pinnacle Express 1.10 | DVD-R/ DVD-RW Запись на Pioneer A04 | Всё прекрасно, только при разбиении на чаптеры создаются разные VOBы --> в этих местах видео притормаживает. | videoing@mtu.ru
Sony NS700 | Pinnacle Studio 7.13 | CBR, 6000/ 8000, звук MP2 | Sonic DVDit! PE 2.3 | DVD-R/ DVD-RW Запись на Pioneer A04 | ОК, на этом плеере, похоже, прочитается всё | videoing@mtu.ru
Panasonic DVD-RV32EU | CCE 2.62, Canopus ProCoder | VBR, 6000 в среднем | Sonic DVDit! PE 2.3/Reel DVD 2.5.1 | DVD-R/ DVD-RW/ DVD+RW | Никаких проблем, все нормально с DVD-R/RW. DVD+RW не распознаются вообще | Собственное тестирование


DVD Info - Glossary

DVD своими руками: Глоссарий

Глоссарий

# A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

В этом разделе разъясняются многие термины из материалов на нашем сервере. Он постоянно пополняется по мере появления новых терминов, требующих комментариев.

По терминам 3D графики лучше обратиться к "3D глоссарию", по терминам SCSI - к "SCSI глоссарию", по терминологии DVD - к "DVD Глоссарию".


DVD Info - Glossary - A

DVD своими руками: Глоссарий - A

Глоссарий

# A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

A

ACPI - Advanced Configuration and Power Interface - современный интерфейс конфигурирования и управления энергопотреблением - стандарт, разработанный фирмами Intel, Microsoft и Toshiba для унификации функций управления энергопотреблением компьютера. Является ключевым элементом Operating System Directed Power Management (OSPM - непосредственное управление энергопотреблением операционной системой). Стандарт претерпел существенные изменения по сравнению с ранее применявшимся стандартом Advanced Power Management (APM) BIOS Specification, Revision 1.2. ACPI учитывает даже температуру материнской платы и процессора, позволяет "усыплять" компьютер программно в режиме, например, ожидания приема факса ночью и т.п. Стандарт требует обязательной поддержки со стороны как BIOS материнской платы, так и операционной системы. Для правильного функционирования система должна иметь возможность поддержки механизма NVS, который позволяет восстановить работу системы после потери питания или глубокого "сна".

ADC - Analog Digital Convertor - аналогово-цифровой преобразователь (АЦП). Предназначен для преобразования аналогового сигнала в цифровой код, т.е. каждому значению напряжения входного аналогового сигнала соответствует определенное значение выходного цифрового кода. АЦП, например, есть в каждой звуковой карте и используется при записи с внешнего источника звука на жесткий диск.

Adaptive Caching - адаптивное кэширование - метод работы с кэш-памятью (буфером) для жесткого диска, позволяющий изменять во время работы как размер сегмента кэш-памяти, так и количество сегментов для повышения производительности работы диска. Применение адаптивного кэширования всегда подчеркивается производителями жестких дисков как очевидное достоинство их продукции.

AGRAS - Anti-Glare anti-Reflection AntiStatic - антибликовое, антиотражающее и антистатическое покрытие - вид специального покрытия на современных мониторах с диагональю от 17" и выше. Поэтому "народная" примета - чем экран темнее, тем лучше - соответствует истине. Кинескопы с AGRAS покрытием выглядят практически черными и не требуют в принципе никаких дополнительных фильтров для подавления бликов и отражений.

API - Applications Programmer's Interface (API) - интерфейс прикладного программирования - спецификация набора функций, которую должны выдержать разработчики программного обеспечения для совместимости своих программ с соответствующими операционными системами.

APIC - Advanced Programmable Interrupt Controller (Продвинутый программируемый контроллер прерываний) - Контроллер прерываний (interrupt), позволяющий использовать 24 аппаратных прерывания вместо 16. Ограничение в 16 аппаратных прерываний, не менявшееся с 1982 года, сдерживало установку в персональный компьютер дополнительных устройств. В конце 2001 года появились первые материнские платы с APIC.

ATX - AT eXtension - расширение формата AT - разработанный несколько лет назад конструктив корпуса персонального компьютера и, соответственно, форм-фактор материнской платы. Начал массово использоваться после появления процессоров Pentium II, так как материнские платы для этого процессора выпускаются в большинстве своем в формате ATX (за очень редким исключением). Основные отличия от классического конструктива:

  • Плата крепится только на винтах, что повышает надежность и жесткость ее крепления.

  • Разъемы всех портов ввода/вывода (принтерный, COM1, COM2 и т.д.) жестко крепятся на материнской плате в ее правом верхнем углу, причем могут устанавливаться друг над другом.

  • Процессор (процессоры) и его "обвязка" устанавливаются справа от интерфейсных разъемов, что позволяет устанавливать полноразмерные платы расширения.

  • Блок питания вырабатывает также напряжение 3.3 V, что избавляет от необходимости формировать это напряжение на материнской плате

  • Блок питания запускается/выключается от специального сигнала, который может быть выработан как кнопкой включения компьютера, так и BIOS через соответствующую схему на материнской плате. Это позволяет программно выключать блок питания (например, при выходе из Windows 95/98) и включать его по команде от BIOS или от модема, сетевой карты и т.п.

  • Напряжение 5 V (слаботочное) всегда есть на материнской плате, если 220 V подано на блок питания, для управления запуском блока питания. Поэтому на "правильных" ATX блоках питания всегда есть выключатель 220 V, расположенный на самом блоке питания с обратной стороны системного блока. При любых действиях, требующих снятия крышки системного блока, 220 V требуется ОБЯЗАТЕЛЬНО ОТКЛЮЧАТЬ от блока питания.

  • Разъем для подключения ATX блока питания на материнской плате один и имеет 20 контактов

  • Допускается (но не является обязательным) вывод и подключение на материнскую плату сигналов с датчика скорости вращения вентилятора блока питания и включения/выключения вентилятора через отдельный разъем от блока питания. Через этот же разъем возможна запитка устройств на шине IEEE-1394.

В процессе развития формата ATX появились два совместимых снизу вверх дополнительных формата - MicroATX и FlexATX.

AMR - Audio Modem Rising - слот для аудио и/или видео - разъем для подключения аналоговой части программного модема и/или звуковой карты. Используется в материнских платах с мощными процессорами класса Pentium II/III. В этом случае вполне возможно, например, программное формирование кодов любых звуков, а плата, которая устанавливается в AMR, содержит только цифроаналоговый преобразователь и усилитель без каких-либо схем формирования собственно звуков.


DVD Info - Glossary - B

DVD своими руками: Глоссарий - B

Глоссарий

# A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

B

Buffer underrun - не заполненность буфера - ошибка, иногда возникающая при записи на CD-R, в том случае, если в буфере устройства записи нет данных, а они уже требуются для обеспечения непрерывности записи на однократно записываемый диск.

Bus Master - Хозяин шины - возможный режим работы устройства на любой шине (в том числе и на PCI). Для работы в таком режиме устройство выдает запрос арбитру шины, сообщая о своем требовании на получение управления шиной. Арбитр, в соответствии с приоритетом и/или очередностью арбитража на данной шине через определенное в документации на шину время после запроса отдает запрашивающему устройству управление шиной. Выполнив все необходимые ему операции, устройство сообщает арбитру об освобождении им шины.

На современных шинах, таких как PCI, для получения доступа к шине ВСЕ устройства проходят процедуру арбитража, в том числе и центральный процессор. Возможность быть Bus Master'ом должна быть обязательно реализована аппаратно при разработке устройства. Реализация механизма Bus Master позволяет общаться между собой только тем компонентам компьютера, которым это в данный момент нужно и не занимать понапрасну ненужные им для этого общения устройства. Этот механизм используется, например, для передачи TV-тюнером на PCI данных в видеокарту, также находящуюся на этой шине, без участия центрального процессора, системной памяти и т.п.


DVD Info - Glossary - C

DVD своими руками: Глоссарий - C

Глоссарий

# A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

C

Cache Memory - Кэш-память - Память, необходимая для того, чтобы центральный процессор меньше простаивал из-за низкого быстродействия основной памяти, расположена между процессором и основной памятью. Изготавливается на микросхемах статической памяти (не требующей регенерации), значительно более быстродействующей, чем память типа DRAM. Играет роль буфера между процессором и медленной динамической памятью. Кэш-память значительно дороже DRAM, поэтому ее объем, как правило, не превышает 512 KBytes. Объем и быстродействие кэш-памяти является определяющими параметрами быстродействия материнской платы и/или центрального процессора для подавляющего большинства задач, решаемых на компьютере. Цифры впечатляющей разницы в быстродействии между различными видами DRAM уменьшаются в десятки раз при оценке производительности компьютера в целом из-за кэш-памяти. Для еще большего увеличения быстродействия кэш-памяти она часто встраивается в собственно кристалл процессора и работает при этом на той же тактовой частоте, что и сам процессор.

Capture (Захват) этим термином обычно обозначается запись видеоданных на жесткий диск компьютера.

CAS - Column Address Strobe - строб адреса столбца - сигнал, используемый при работе с динамической памятью (DRAM), предназначен для запоминания в микросхеме DRAM адреса столбца.

CCD - Charge-Coupled Devices - устройство с поверхностно-зарядовой связью (ПЗС) - элемент приема видеоинформации, используемый в видеокамерах и цифровых фотоаппаратах. Основная характеристика CCD - количество элементов разрешения, или пикселей.

CDDI - Copper Distributed Data Interface - он же TPDDI - Twisted Pair Distributed Data Interface - чисто электрическая реализация архитектуры FDDI на витой паре 5 категории с разъемами RJ-45. Существенно дешевле оптической реализации, но длина сегмента ограничена 100 м, применяется в локальных кольцах. Корректное взаимодействие аппаратуры различных производителей при таком монтаже не гарантируется.

CD-R (Recordable) - CD-WORM - Write Once Read Many times - CD-WO -Write Once - устройства, записывающие данные на CD. Технология записи на золотое напыление отличается от массовой (штамповки), что теоретически не влияет на считывание, однако некоторые приводы CD-ROM не читают диски с многократными сеансами записи. Вся информация до записи должна быть предварительно сформирована на другом устройстве массовой памяти.

CD-ROM - Compact Disk-Read Only Memory - устройство для считывания компакт-дисков (CD disk). Диск диаметром 5 дюймов емкостью 660 Мбайт имеет всего одну спиральную дорожку. Время доступа относительно велико (у лучших моделей - 80 nc), чувствителен к вибрациям при работе. Интерфейсы: SCSI, IDE (E-IDE, IDE ATAPI); специальные на старых моделях - Sony. Panasonic, Mitsumi. Исполнение - внутреннее и внешнее (SCSI, LPT- порт). Могут отличаться как по поддержке различных форматов так и по следующим возможностям:

  • Multisession CD-ROM - позволяют считывать данные, записанные за несколько сеансов на записывающем CD-ROM (не более 9). В противном случае читаются данные только первой сессии.

  • XA-Ready CD-ROM позволяют читать ХА-диски, но не имеют собственного ADPCM-декодера.

  • Caddy-Type - приводы, у которых CD укладывается в специальную защитную кассету, аналогичную защитному чехлу дискеты. Сохраняет диски от внешних повреждений, но при частой смене диска желательно иметь несколько кассет.

  • CD-changer - устройства, в которые можно одновременно установить несколько CD, текущая работа возможна только с одним, смена текущего диска - автоматическая (1-5 секунд).

CD-ROM Disk - носитель информации для приводов CD-ROM. Может быть записан в ряде форматов

  • CD-DA - Digital Audio - классический аудио диск. Поддерживается практически всеми приводами.

  • High Sierra Format - HSF, или HSG - High Sierra Group - фактический стандарт на доступ к данным из среды DOS, UNIX и других ОС. Начальная дорожка содержит информацию об организации диска - VTOC - Volume Table Of Contents.

  • ISO 9660 - первый стандарт (1988 г.) для хранения данных на CD-ROM, файловая система аналогична MS-DOS, имена файлов по схеме 8 символов имя, 3 расширение имени, глубина вложенности каталогов до 8.

  • PhotoCD - разработан фирмой Kodak для хранения высококачественных изображений.

  • CD-I - CD Interactive - видеозапись со звуковым сопровождением для воспроизведения на видеоплейере со стандартным телевизором. Некоторыми приводами не поддерживается.

  • CD-ROM XA - eXtended Architecture - расширенная архитектура, совместима с ISO 9660 и High Sierra дисками. При создании оригинала используется Interleaving - чередование сегментов данных, аудио- и видеоинформации. Аудиосигнал сжимается по методу ADPCM (Adaptive Differential Pulse Code Modulation).

  • Video CD - высококачественная цифровая видеозапись в MPEG формате, может воспроизводиться на компьютере с программным или аппаратным MPEG-декодером.

  • CD Plus - музыкальные мультимедиа диски, содержащие две сессии - аудио (воспроизводится также на любом стандартном аудиоплейере) и CD-ROM.

CD-RW - CD ReWritable - перезаписываемые диски - оптические диски, допускающие многократную запись информации. Как правило, возможно выполнить до 1000 циклов записи на один диск.

Crossover (разделитель) устройство, всегда имеющееся в многополосных акустических системах. Предназначено для разделения сигнала на полосы в соответствие с заданными частотами раздела. Как правило, если есть сабвуфер (низкочастотный динамик), то для него частота раздела принимается в 150 Hz.

CSA - Canada Standards Association - организация в Канаде, отвечающая за сертификацию электронного оборудования на безопасность.

Cyclic Redundacy Check (CRC) - циклический контроль с избыточностью - метод проверки целостности принимаемых/передаваемых данных. Применяется, например, при обмене данными в высокоскоростных вариантах таких интерфейсов как SCSI и IDE.


DVD Info - Glossary - D

DVD своими руками: Глоссарий - D

Глоссарий

# A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

D

DAT - Digital Audio Tape - цифровая аудио лента - этот термин в компьютерной среде понимается как обозначение типа стримера с кассетами, формат которых был унаследован от цифровых аудио магнитофонов. Теперь формат кассет именно для стримеров этого типа называется DDS.

DDC - Display Data Channel - интерфейс обмена данными между компьютером и монитором. Существуют два варианта этого интерфейса:

  • DDC 1 - односторонняя, от монитора к компьютеру, передача данных о модели монитора и параметрах поддерживаемых видеорежимов.

  • DDC 2 - двусторонний обмен данными.

DDR SDRAM - Double Data Rate SDRAM - SDRAM с удвоенной скоростью обмена данными - новый вид памяти, наилучший по соотношению цена/качество. Как видно из названия, пропускная способность DDR SDRAM в два раза выше обычной. Несмотря на немного меньшую пропускную способность по сравнению с Rambus DRAM, она значительно дешевле ее.

DDS - Digital Data Storage - хранение цифровых данных - обозначение формата кассет для DAT стримеров.

DIMM - Dual In-line Memory Module - двухсторонний модуль памяти - конструктив модуля памяти, становящиеся с 1997 года фактическим стандартом для компьютеров. Имеет по 84 вывода с каждой стороны. Собственно память, размещенная на модуле, может быть как FPM или EDO так и SDRAM. Память в DIMM имеет разрядность 64 (с четностью 72) бита и может использоваться поодиночке, а не парами, как обычные SIMM.

Dynamic Range - динамический диапазон - характеристика качества аудио тракта. Измеряется в децибелах и показывает отношение уровня выходного сигнала при номинальной выходной мощности к уровню наименьшего слышимого звука. Такие параметры, как динамический диапазон и отношение сигнал/шум связаны между собой - не может быть у устройства высокое соотношение сигнал/шум и узкий динамический диапазон. Для высококачественных аудио устройств значение динамического диапазона не может быть хуже 95 dB.

DirectX - набор драйверов, образующий интерфейс между программами в среде Windows и аппаратными средствами. Развитие этого набора происходит непрерывно и сейчас выпущены следующие версии (каждая следующая включает в себя возможности предыдущих):

  • DirectX 1.0 состоял из DirectDraw, DirectInput, DirectPlay и DirectSound.

  • DirectX 2.0 - появился Direct3D.

  • DirectX 3.0 - отмечен появлением в DirectInput специальной программы управления джойстиком и обновлением драйвера виртуального сопроцессора для поддержки MMX технологии. К DirectSound появился свой API.

  • DirectX 3.0a имел небольшие корректировки в части поддержки MMX технологии.

  • DirectX 3.0b содержал исправления ошибок, выявленных в японской версии Windows.

  • DirectX 5.0 содержал ряд нововведений, таких как поддержку игровых контроллеров с обратной связью - feedback - (например, отдачей от стрельбы), новую панель управления для игровых контроллеров, существенно улучшенную поддержку технологии MMX и улучшенный интерфейс управления для пользователя. Этот набор изначально входил в состав Windows 98 и поддерживает в этой системе работу с несколькими мониторами одновременно.

  • DirectX 5.2 содержит исправления некоторых мелких ошибок и новую версию DirectPlay.

  • DirectX 6.0 включает в себя поддержку нескольких новых 3D функций, таких как однопроходное мультитекстурирование, сжатие текстур и т.п. Также повышено быстродействие драйверов набора и добавлена поддержка технологии 3DNow! фирмы AMD.

  • DirectX 6.1 включает в себя новый API, названный DirectMusic.

  • DirectX 7.0 отмечен такими нововведениями:

    • в DirectDraw добавлена поддержка вывода на стерео дисплеи

    • в Direct3D добавлена поддержка аппаратной трансформации объектов и их подсветки

    • в DirectSound добавлена поддержка аппаратного управления голосовыми функциями

    • в DirectInput добавлена поддержка единой модели Windows драйверов (WDM)

    • в DirectPlay улучшена производительность

  • DirectX 8.0 выпущен в ноябре 2000, и в него введены следующие усовершенствования:

    • для упрощения разработки приложений совмещены входы в DirectDraw и Direct3D.

    • для упрощения разработки приложений совмещены входы в DirectSound и DirectMusic.

    • для большей реалистичности улучшено затенение объектов.

    • в DirectInput улучшено отображение устройств для упрощения работы с ними.

    • в DirectPlay улучшено масштабирование и производительность, а также добавлена поддержка передачи голоса

    • в DirectShow добавлена поддержка формата Windows Media Audio и Video (WMA и WMV), а также введена поддержка редактирования аудио и видео файлов в реальном времени, т.е. timeline direct playback.

    Кроме этого, в DirectX 8 версии фактически была завершена замена интерфейса Video for Windows на DirectShow и обновлены практически все аудио и видео кодеки Windows, которые до 8 версии в DirectX просто не входили.

Direct3D - в силу бурного развития 3D технологий, пожалуй, наиболее известная часть DirectX. Решает две задачи:

  1. Программную обработку 3D изображения для систем без 3D ускорителей с полной поддержкой всего 3D конвейера

  2. Обеспечение прозрачного доступа прикладных программ ко всем аппаратным ресурсам 3D ускорителей.

В отличие от OpenGL состоит из жесткого набора функций, определяемых фирмой Microsoft. Расширение этого API третьими фирмами не разрешается.

DirectDraw - часть набора драйверов DirectX, поддерживающих непосредственную работу с видеокартой и позволяющих, например, прямую запись в видеопамять. Фактически, DirectDraw - это менеджер видеопамяти. Используя DirectDraw, любая программа может манипулировать видеопамятью, не привязывая эти действия к конкретной модели видеокарты.

DirectInput - часть набора драйверов DirectX, поддерживающих непосредственную работу с аналоговыми и цифровыми джойстиками. Драйвера DirectInput используют реестр Windows для сохранения параметров джойстика и результатов его калибровки.

DirectMusic - часть набора драйверов DirectX версии 6, поддерживающая три функции:

  • программная генерация волновой таблицы для MIDI звуков

  • интерактивное сочинение музыки

  • загрузка музыкальных файлов из сети

DirectPlay - программный интерфейс для доступа игровых программ к коммуникационным средствам Windows, ликвидирующий зависимость конкретной игры от сетевого протокола и транспорта.

DirectShow - программный интерфейс для работы с новой периферией, такой, например, как цифровые видеокамеры. Постепенно должен заменить устаревший Video for Windows.

DirectSound - аудио составляющая набора DirectX, позволяющая микширование в реальном времени, прямой доступ к звуковой карте.

DMA - Direct Memory Access - прямой доступ к памяти - режим обмена данными между памятью и устройством ввода/вывода, управляемый специальным устройством (контроллером DMA) и выполняемый без участия центрального процессора. Использование этого режима значительно ускоряет пересылку данных, так как исключает пересылки данных в процессор и обратно.

Dolby Pro Logic - система объемного звучания, разработанного инженерами фирмы Dolby Laboratories. Запись и воспроизведение звука выполняется для пяти каналов - левого, центрального и правого фронтальных каналов, а также левого и правого тыловых каналов. Отличается от системы Dolby Surround большим разделением фронтальных и тыловых каналов.

Dolby Surround - одна из первых систем объемного звучания, разработанных инженерами фирмы Dolby Laboratories. Запись и воспроизведение звука выполняется для четырех каналов - левого и правого фронтальных каналов, а также левого и правого тыловых каналов. Сигнал для тыловых каналов кодируется вместе с сигналами для фронтальных каналов. При воспроизведении стерео сигнал требует декодирования для извлечения информации тыловых каналов.

DPMS - Display Power Management Signaling - сигналы управления энергопотреблением монитора - стандарт, созданный ассоциацией VESA для многостадийного снижения энергопотребления монитора. Для реализации стандарта его должен поддерживать монитор. В стандарте оговорены четыре уровня:

Уровень | Определение | Результат
0 | DPMS Mode On | Монитор используется как обычно
1 | DPMS Mode Standby | Изображения нет, потребление снижено
2 | DPMS Mode Suspend | Изображения нет, потребление еще более снижено
3 | DPMS Mode Off | Изображения нет, потребление снижено до минимума

DRAM - Dinamic Random Access Memory - динамическая память прямого доступа - память, схемотехнически выполненная в виде двумерной матрицы (строки х столбцы) конденсаторов. Очень дешева, но требует постоянного "освежения" или регенерации (refresh) заряда на конденсаторах. Регенерация выполняется как "пустое" чтение памяти. Этот процесс отнимает значительное время, так как в этот период никакое устройство не может получить доступ к памяти, кроме контроллера регенерации.

DV - Digital Video - формат представления видеоданных, используемый для обмена видео между цифровыми видеокамерами, видеомагнитофонами и компьютерами. В качестве транспорта для передачи DV обычно используется интерфейс IEEE-1394 (FireWire). У DV фиксированный коэффициент сжатия видеосигнала 5:1 и, соответственно, поток 3.515 MBytes/s. Разрешение для PAL 720x576, для NTSC 720x480. Стандарт также предусматривает передачу команд управления устройствами записи/воспроизведения видео по интерфейсу IEEE-1394. Поддерживается запись/воспроизведение звука либо по 4 каналам с частотой дискретизации 32 kHz и разрядностью 12 бит, либо по 2 каналам с частотой дискретизации 48 kHz и разрядностью 16 бит. В DV используется как intraframe компрессия, при которой каждый кадр сжимается сам по себе, без учета информации в соседних кадрах, так и interfield компрессия, применяющая анализ статичных изображений на соседних полях с использованием одинакового фона для соседних полей. Такие алгоритмы компрессии дают очень незначительное количество артефактов.

DV Type-1 - Digital Video Type-1 - оригинальный (native) вариант DV формата, совершенно несовместимый с Video for Windows и поддерживаемый только через DirectShow. Поток (файл) формата Type-1 содержит видео и аудио (стерео, 48 kHz, 16 bit) в одном потоке, т.е. с чередованием видео и аудио. Именно этот формат является официально рекомендуемым для захвата и последующей обработки видео DV формата на компьютере. Но в реальности Type-1 оказался не очень удобным для редактирования видео, поскольку видеоредакторы вынуждены полностью "вычленять" звук из файла и в результате места на диске требуется не меньше, чем при работе с Type-2, а времени на обработку даже больше, особенно в начале работы над проектом.

DV Type-2 - Digital Video Type-2 - старый вариант DV формата, обратно совместимый с Video for Windows - программа, понимающая Video for Windows, может прочитать файл формата Type-2 (но сохранить в нем не может без специального кодека). Поток (файл) формата Type-2 содержит видео и от одного до четырех потоков (каналов) для аудио (максимально 2 стереоканала, по 32 kHz, 12 bit каждый). По сравнению с Type-1 требует больших затрат на декодирование и микширование, но совместимость с Video for Windows в меньшей степени и удобство редактирования в большей степени привели к тому, что Type-2 стал более востребованным форматом для редактирования. Единственный серьезный редактор, полностью работающий только с Type-1, Ulead MediaStudio Pro, начиная с 7 версии, стал работать в Type-2 с полной поддержкой всех своих возможностей. Поэтому, очевидно, что Type-2 останется наиболее удобным форматом для обработки на компьютере и в будущем.

DVI - Digital Video Interactive - система аппаратного сжатия движущихся видеоизображений с коэффициентом сжатия до 160:1 и записи звукового сопровождения по методу сжатия ADPCM.

DVD - Digital Versatile Disk - цифровой универсальный диск -самый современный стандарт хранения информации на оптическом (лазерном) диске. Отличается от обычного CD-ROM увеличенной почти в 30 раз емкостью (до 17 GB). Для DVD принят другой стандарт на единицу скорости, так объем информации на диске значительно больше. За одну скорость принято считать скорость считывания DVD диска 1352 kBytes/sec. Поэтому диск с 5x DVD скоростью, например, имеет максимальную скорость считывания 6760 kBytes/sec. Возможны следующие варианты изготовления DVD дисков:

  1. Односторонний однослойный с емкостью 4.7 GB.

  2. Односторонний двухслойный с емкостью 8.5 GB.

  3. Двухсторонний однослойный с емкостью 9.4 GB.

  4. Двухсторонний двухслойный с емкостью 17 GB.

Существует также ряд типов DVD дисков в зависимости от назначения:

  • DVD-ROM - диск, доступный только для чтения; может считываться только на приводе DVD.

  • DVD-Video - предназначен для записи видеофильмов и может воспроизводиться как в приводах DVD в компьютерах, так и в DVD плеерах.

  • DVD-R - диски с однократной записью - предназначены для архивации данных.

  • DVD-RAM - перезаписываемые DVD диски

  • DVD-Audio - новый стандарт на аудио диски - за счет увеличенной емкости диска увеличена частота дискретизации до 48/96/192 kHz (также 44.1/88.2/176.4 kHz) и разрядность до 16/20/24 бит.

DVD-1 - условное название первого поколения приводов для DVD дисков. Имеют скорость чтения обычных CD-ROM дисков не выше 8-ми, и, кроме этого, не могут читать CD-R и CD-RW диски.

DVD-2 - условное название второго поколения приводов для DVD дисков. Имеют скорость чтения обычных CD-ROM дисков до 24-х, и, кроме этого, могут читать CD-R и CD-RW диски.


DVD Info - Glossary - #

DVD своими руками: Глоссарий - #

Глоссарий

# A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

#

10BaseT - Twisted-Pair Ethernet - Ethernet на витой паре. Кабель выполнен на неэкранированной витой паре UTP 3-5 категории, топология - звезда, в центре которой находится хаб (Hub). Преимущества по сравнению с шиной:

  • к каждому узлу подходит только один гибкий кабель;

  • повреждение одного лучевого кабеля приводит к отказу соединения только одного узла;

  • несанкционированное "прослушивание" пакетов в сети затруднено.

Сейчас новые сети создаются в большинстве своем на основе этой технологии


DVD Info - Glossary - DVD

DVD своими руками: Глоссарий - DVD

DVD Глоссарий

Bitrate - количество бит - характеристика скорости потока видео и/или аудио информации. Измеряется в тысячах килобит за секунду. Чем больше bitrate, тем больше места на диске занимает данная информация. Bitrate в 8000 kbit/s соответствует 1 мегабайту в секунду. Например, 60 секунд видео, закодированного с bitrate 8000 kbit/s, займет на диске 60 мегабайт.

Cell - ячейка. В DVD-Video минимальный адресуемый элемент DVD проекта. Если фильм разбить на главы, например, то фрагмент от начала главы до ее конца также является ячейкой (cell).

Constant Bit Rate (CBR) - постоянная скорость при кодировании - термин, применяемый для описания параметров кодирования в ряде вариантов MPEG формата и означает, что при кодировании в MPEG формат скорость получаемого на выходе кодера MPEG потока всегда постоянна и не зависит от вида кодируемой видеоинформации.

Dolby Digital AC-3 - в общем случае система кодирования (сжатия) звука, разработанного инженерами фирмы Dolby Laboratories. Звуковая дорожка Dolby Digital может содержать моно звук, стерео звук, а также 5.1 звук, запись и воспроизведение которого выполняется для 6 каналов - левого, центрального и правого фронтальных каналов, низкочастотного LFE общепринятое название subwoofer) а также левого и правого тыловых каналов. Подробнее о Dolby Digital как системе объемного звучаения можно прочитать здесь.

Dolby Pro Logic - система объемного звучания, разработанного инженерами фирмы Dolby Laboratories. Запись и воспроизведение звука выполняется для пяти каналов - левого, центрального и правого фронтальных каналов, а также левого и правого тыловых каналов. Отличается от системы Dolby Surround большим разделением фронтальных и тыловых каналов.

Dolby Surround - одна из первых систем объемного звучания, разработанных инженерами фирмы Dolby Laboratories. Запись и воспроизведение звука выполняется для четырех каналов - левого и правого фронтальных каналов, а также левого и правого тыловых каналов. Сигнал для тыловых каналов кодируется вместе с сигналами для фронтальных каналов. При воспроизведении стерео сигнал требует декодирования для извлечения информации тыловых каналов.

Dynamic Range - динамический диапазон - характеристика качества аудио тракта. Измеряется в децибелах и показывает отношение уровня выходного сигнала при номинальной выходной мощности к уровню наименьшего слышимого звука. Такие параметры, как динамический диапазон и отношение сигнал/шум связаны между собой - не может быть у устройства высокое соотношение сигнал/шум и узкий динамический диапазон. Для высококачественных аудио устройств значение динамического диапазона не может быть хуже 95 dB.

Dynamic Range Compression (DRC) - сжатие динамического диапазона - применяется в DVD плеерах с собственными декодерами звука и ресиверах. Сжатие (или уменьшение) динамического диапазона применяется для ограничения пиков звука при просмотре фильмов. Если зритель желает смотреть фильм в котором возможны резкие изменения уровня громкости (фильм о войне, например), но не хочет причинять беспокойство членам своей семьи, то режим DRC следует включить. Субъективно, на слух, после включения DRC в звуке уменьшается доля низких частот и высокие звуки теряют, прозрачность, поэтому без необходимости режим DRC не стоит включать.

DV - Digital Video - формат представления видеоданных, используемый для обмена видео между цифровыми видеокамерами, видеомагнитофонами и компьютерами. В качестве транспорта для передачи DV обычно используется интерфейс IEEE-1394 (FireWire). У DV фиксированный коэффициент сжатия видеосигнала 5:1 и, соответственно, поток 3.515 MBytes/s. Разрешение для PAL 720x576, для NTSC 720x480. Стандарт также предусматривает передачу команд управления устройствами записи/воспроизведения видео по интерфейсу IEEE-1394. Поддерживается запись/воспроизведение звука либо по 4 каналам с частотой дискретизации 32 kHz и разрядностью 12 бит, либо по 2 каналам с частотой дискретизации 48 kHz и разрядностью 16 бит. В DV используется как intraframe компрессия, при которой каждый кадр сжимается сам по себе, без учета информации в соседних кадрах, так и interfield компрессия, применяющая анализ статичных изображений на соседних полях с использованием одинакового фона для соседних полей. Такие алгоритмы компрессии дают очень незначительное количество артефактов.

DV Type-1 - Digital Video Type-1 - оригинальный (native) вариант DV формата, совершенно несовместимый с Video for Windows и поддерживаемый только через DirectShow. Поток (файл) формата Type-1 содержит видео и аудио (стерео, 48 kHz, 16 bit) в одном потоке, т.е. с чередованием видео и аудио. Именно этот формат является рекомендуемым для захвата и последующей обработки видео DV формата на компьютере.

DV Type-2 - Digital Video Type-2 - старый вариант DV формата, обратно совместимый с Video for Windows - программа, понимающая Video for Windows, может прочитать файл формата Type-2 (но сохранить в нем не может без специального кодека). Поток (файл) формата Type-2 содержит видео и от одного до четырех потоков каналов) для аудио (максимально 2 стереоканала, по 32 kHz, 12 bit каждый). По сравнению с Type-1 требует больших затрат на декодирование и микширование, поэтому область применения этого формата постепенно, по мере перехода программ видеомонтажа на формат Type-1, будет сокращаться.

DVD - Digital Versatile Disk - цифровой универсальный диск - самый современный стандарт хранения информации на оптическом (лазерном) диске. Отличается от обычного CD-ROM увеличенной почти в 30 раз емкостью (до 17 GB). Для DVD принят другой стандарт на единицу скорости, так объем информации на диске значительно больше. За одну скорость принято считать скорость считывания DVD диска 1352 kBytes/sec. Поэтому диск с 5x DVD скоростью, например, имеет максимальную скорость считывания 6760 kBytes/sec. Возможны следующие варианты изготовления DVD дисков:

  1. Односторонний однослойный с емкостью 4.7 GB.

  2. Односторонний двухслойный с емкостью 9.4 GB.

  3. Двухсторонний однослойный с емкостью 9.4 GB.

  4. Двухсторонний двухслойный с емкостью 17 GB.

Существует также ряд типов DVD дисков в зависимости от назначения и способов записи информации на них:

  • DVD-ROM - диск, доступный только для чтения; может считываться только на приводе DVD.

  • DVD-Video - предназначен для записи видеофильмов и может воспроизводиться как в приводах DVD в компьютерах, так и в DVD плеерах.

  • DVD-R, DVD+R - диски с однократной записью - предназначены для однократной записи данных. Емкость 4.7 GBytes. Диски совместимы с обычными DVD-Video плеерами и DVD-ROM приводами компьютеров.

  • DVD-RW, DVD+RW - диски с многократной записью - предназначены для однократной записи данных. Емкость 4.7 GBytes. Диски совместимы с обычными DVD-Video плеерами и DVD-ROM приводами компьютеров.

  • DVD-RAM - перезаписываемые DVD диски, несовместимые с обычными DVD-Video плеерами и DVD-ROM приводами компьютеров.

  • DVD-Audio - новый стандарт на аудио диски - за счет увеличенной емкости DVD диска увеличена частота дискретизации до 48/96/192 kHz (также 44.1/88.2/176.4 kHz) и разрядность до 16/20/24 бит.

DVD-1 - условное название первого поколения приводов для DVD дисков. Имеют скорость чтения обычных CD-ROM дисков не выше 8-ми, и, кроме этого, не могут читать CD-R и CD-RW диски.

DVD-2 - условное название второго поколения приводов для DVD дисков. Имеют скорость чтения обычных CD-ROM дисков до 24-х, и, кроме этого, могут читать CD-R и CD-RW диски.

DVD Structure - структура DVD-Video диска. Структура DVD-Video диска показана на рисунке:

Linear PCM - линейный PCM - формат несжатого (т.е. без потери качества) звука, используемый для записи звука в некоторых DVD-Video дисках. Отличается от PCM звука на обычных аудио компакт-дисках повышенной частотой дискретизации от 48 до 96 kHz и разрядностью 16, 20, или 24 бит. Этот формат используется в основном только на DVD-Video дисках с записями выступлений различных музыкантов. Широкому использованию этого формата в DVD-Video дисках мешает его высокий bitrate (иными словами, звук в таком формате занимает слишком много места), составляющий минимально около 1500 кбит/сек.

Motion Menu - видео меню - меню в DVD-Video дисках, включающее в себя видеофрагменты.

Multi-angles - под несколькими углами - показ одного и того же изображения, снятого разными камерами. Такая возможность заложена в стандарт на DVD-Video диск, но она практически никогда не применяется. Объясняется это тем, что слишком много места на диске требует каждая видеодорожка и, кроме этого, дополнительными затратами при съемке самого фильма.

PGC - Program Chain (программная цепочка). Основной элемент структуры содержания DVD-Video диска, состоит из нескольких program, связанных вместе для последовательного воспроизведения. На DVD-Video диске обязательно должна быть хотя бы одна PGC.

Program - программа - под программой в DVD среде понимается набор аудио и видео фрагментов. Включает в себя несколько ячеек (cell).

PTT - Part of Title - фрагмент тайтла - часть тайтла, иными словами глава или сцена.

RF modulation - Radio Frequency Modulation - частотная модуляция - в эпоху проигрывателей лазерных видеодисков цифровой звук передавался с таких проигрывателей на усилитель в частотно-модулированной форме. Во многих современных DVD плеерах есть возможность вывода звука в таком же виде для совместимости с различными усилителями (ресиверами).

Seamless playback - непрерывное (дословно бесшовное) воспроизведение - возможность перехода внутри program без перерыва в воспроизведении видео.

Slide Show - последовательный показ статичных изображений DVD плеером, причем длительность показа каждого изображения определяется автором DVD диска при его создании. Вместе с картинками можно дать звуковое сопровождение.

Still Menu - неподвижное меню - меню в DVD-Video дисках, не имеющее подвижных элементов.

Still Show - последовательный показ статичных изображений DVD плеером. Отличается от Slide Show тем, что изображения меняют друг друга только после нажатия кнопки на пульте DVD плеера и Still Show не может иметь звукового сопровождения.

Subpicture - в DVD-Video дисках основополагающий способ представления тех элементов меню, которые могут изменять свой вид на экране в зависимости от действий пользователя. Создавая subpicture в программе DVD-Authoring, автор DVD-Video диска фактически указывает DVD плееру, каким образом он должен отображать на экране элементы управления в меню DVD-Video диска. В простейших программах DVD-Authoring subpicture создается самой программой по собственному усмотрению, поэтому в таких программах неизбежны ограничения возможностей автора в разработке меню.

Title- тайтл - наибольший элемент компоновки в DVD-Video диске. DVD-Video диск может содержать до 99 тайтлов, выбрать которые можно через title меню.

Variable Bit Rate (VBR) - переменная скорость при кодировании - термин, применяемый для описания параметров кодирования в ряде вариантов MPEG формата. В отличие от CBR скорость выходного потока MPEG кодера будет зависеть от вида кодируемого видеоматериала. Как правило, при использовании VBR режима кодеру указываются средняя, максимальная и минимальная скорость потока. В этом случае кодер подбирает оптимальную скорость потока в зависимости от динамики конкретного фрагмента фильма, сохраняя среднюю скорость потока постоянной. Поскольку режим VBR позволяет уменьшить размер получаемого MPEG файла без ущерба для его качества, он применяется в подавляющем большинстве случаев для кодирования фильмов для DVD-Video дисков. Режим CBR применяется только для кодирования коротких фильмов, которые и при наивысшей скорости потока помещаются на DVD-Video диск.

VMG - Video Manager - видео менеджер - меню диска, служит для доступа ко всем titles на диске. Тем не менее реально может не использоваться, если на диске только один VTS. Если VTS больше, чем один, то только через VMG можно получить доступ к любому VTS.

VTS - Video Title Set - набор тайтлов - контейнер для практически всех составляющих DVD-Video диска. Именно внутри VTS устанавливаются строгие ограничения по единому стандарту применяемых файлов. Может содержать до 99 тайтлов.


DVD Info - Glossary - E

DVD своими руками: Глоссарий - E

Глоссарий

# A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

E

ECC - Error Control Correction - режим контроля функционирования памяти с восстановлением ошибок. Применяется в некоторых материнских платах с соответствующими наборами микросхем для особо критичных к надежности функционирования компьютеров. В основном это сервера и мощные графические станции с большими объемами памяти. Для этого обязательно должны быть установлены планки памяти с истинной четностью. В этом режиме возможно исправление только ОДИНОЧНЫХ ошибок, т.е. ошибку в одном бите из 64, которые считывает процессор.

ECP - Enhanced Capability Port - порт с расширенными возможностями - отличается от стандартного принтерного порта с интерфейсом Centronics, тем, что передаваемая информация разделяется на команды и данные с поддержкой режима DMA и кодирования по методу RLE (Run-Length Encoding - кодирование повторяющихся последовательностей данных).

EPP - Enhanced Parallel Port - расширенный параллельный порт - двунаправленный вариант принтерного порта с максимальной скоростью приема/передачи данных до 2 MB/c. Стало возможным адресация нескольких устройств, ввод 8-ми разрядных данных. Для буферизации данных используется память с FIFO организацией объемом в 16 байт.

ESCD - Extended System Configuration Data - расширенные конфигурационные данные системы - сохраняемые в энергонезависимой памяти на материнской плате параметры Plug&Play устройств. Блок данных ESCD обновляется только в случае изменения аппаратной конфигурации компьютера, т.е. либо замены каких-либо компонент, либо изменения соответствующих параметров BIOS (например, прерываний). Задача ESCD - ускорить конфигурирование компьютера BIOS'ом при включении компьютера или его перезагрузке.

Ethernet - архитектура сетей с разделяемой средой и широковещательной передачей (все узлы получают пакет одновременно), метод доступа - CSMA/CD. Стандарт определен документом IEEE 802.3. Физическая топология - шина для экранированного коаксиального кабеля (коаксиала), звезда - для витой пары, двухточечное соединение - для оптоволоконного кабеля (оптоволокна).

Extended Data Output DRAM - при работе на запись не дает никаких преимуществ по сравнению с FPM DRAM, но требует существенно меньше времени при чтении за счет того, что данные удерживаются на выходе микросхемы EDO DRAM дольше, чем в FPM DRAM. EDO (как и FPM) не дает никаких преимуществ при произвольной выборке данных из памяти, но такая ситуация возникает крайне редко. На микросхемах EDO DRAM указывается время доступа в наносекундах к данным в случайном порядке.


DVD Info - Glossary - F

DVD своими руками: Глоссарий - F

Глоссарий

# A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

F

Fast Page Mode DRAM - самый старый вид памяти, который стал применяться еще в 80-х годах. Отличается от стандартной тем, что позволяет сократить чтение/запись данных, расположенных один за другим в памяти, но при этом на каждое слово требуется не менее трех тактов системной шины. На микросхемах Fast Page Mode DRAM указывается время доступа в наносекундах к данным в случайном порядке.

FCC - Federal Communication Commission - организация в США, сертифицирующая любую электронную аппаратуру на предмет опасности ее излучения для людей и/или для другой электронной техники. Два типа сертификатов выдаются этой организацией - FCC-Class A - разрешается только для профессионального применения и FCC-Class B - разрешается использовать везде.

FDDI - Fiber Distributed Data Interface - стандартизированная спецификация ANSI X3T9.5 для сетевой архитектуры высокоскоростной передачи данных в основном по оптоволоконным линиям. Скорость передачи - 100 Мбит/с. Топология - либо кольцо (двойное) либо гибридная (включение звездообразных или древовидных подсетей в главную сеть через концентратор). Метод доступа - маркерный с возможностью одновременного циркулирования множества кадров в кольце. Максимальное количество станций - 1000, расстояние между станциями до 2 км при многомодовом и до 45 км при одномодовом кабеле, затухание сигнала между станциями 11 дБ, длина кольца до 100 км (может увеличиваться за счет применения дополнительных повторителей. В некоторых случаях вторичное кольцо используется для удвоения пропускной способности. Реализация сети в настоящее время стоит достаточно дорого.

FlexATX - гибкий ATX - подмножество самого массового форм-фактора корпусов и материнских плат. Таблица ниже описывает основные параметры этого формата:

Особенности | Что дает пользователю
Размер материнской платы не более 229х191 мм | Позволяет применять небольшие дешевые корпуса
Совместимость с задней панелью под ввод/вывод для обычных ATX корпусов | Возможна установка материнской Flex ATX платы в обычный ATX корпус
Совместимость по крепежу с обычной ATX материнской платы | Возможна установка материнской Flex ATX платы в обычный ATX корпус
Допускает установку процессоров только в Socket конструктиве | Снижение стоимости готовой системы

FIFO - First Input First Output - первый вошел и первый вышел - способ организации памяти, при котором записанные данные сдвигаются вперед при поступлении новых данных. Как правило, память с такой организацией используется в качестве буферной при приеме/передаче данных.

FM Music Synthesizer - синтезатор MIDI с частотной модуляцией (Frequency Modulated) имеет несколько каналов (голосов). Каждый канал содержит два и более синусоидальных генератора (оператора), управляющих параметрами (частота, амплитуда) друг друга. Качество звука при чистом синтезе среднее даже при 20-ти голосом синтезаторе, так как все звуки инструментов создаются искусственно. Для более качественного звучания используется синтезатор на таблице волн.

Frequency Response - диапазон частот - одна из основных характеристик аудиоаппаратуры, в том числе и звуковых карт компьютеров. Определяется как возможность воспроизведения указанных частот с отклонением от плоской амплитудно-частотной характеристики не более чем на +- 3 dB. Диапазон воспроизводимых частот для качественной аудиоаппаратуры должен быть не уже 20 Hz - 20 kHz.

Full-Duplex - полный дуплекс - протокол, при котором прием и передача данных может быть выполнена одновременно, в отличие от Half-Duplex.


DVD Info - Glossary - G

DVD своими руками: Глоссарий - G

Глоссарий

# A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

G

Giant Magnetoresistive Heads (GMR) - головки на эффекте гигантской магниторезистивности (устойчивости) - технология, позволившая создать головки для жестких дисков с высокой чувствительностью к изменению магнитного поля, что дало возможность резко повысить плотность записи на жесткий диск.


DVD Info - Glossary - H

DVD своими руками: Глоссарий - H

Глоссарий

# A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

H

Half-Duplex- полу дуплекс - протокол, поддерживающий передачу данных в обоих направлениях, но не одновременно. При Full-Duplex возможно вести одновременно прием и передачу данных.

HDTV - High-Definition TV - телевидение высокой четкости, использующее (или, точнее, которое должно использовать) исключительно цифровые методы обработки и получения телевизионной информации.

HRTF - Head-Related Transfer Functions - функции передачи звука, зависящие от головы человека - концепция передачи звука, основанная на специфических особенностях восприятия звуков человеком. Человеческое ухо имеет нелинейную амплитудно-частотную характеристику, причем с уменьшением уровня громкости звука нелинейность возрастает.

Hub - хаб является обязательным (кроме двухточечной сети) соединительным элементом сети на витой паре и средством расширения топологических, функциональных и скоростных возможностей для любых сред передачи. Простейшие хабы являются многопортовыми повторителями. Хабы могут иметь набор разъемов BNC, RJ-45, AUI, обеспечивая выбор кабеля для передачи от источника к приемнику. К порту хаба можно подключить как отдельный узел, так и другой хаб. Хабы с набором разнотипных портов позволяют объединять сегменты сетей с различными кабельными системами. Существуют более сложные и дорогие варианты Switching HUB, Stackable HUB.


DVD Info - Glossary - I

DVD своими руками: Глоссарий - I

Глоссарий

# A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

I

Interrupt (hardware) - прерывание (аппаратное) - механизм, позволяющий периферийному устройству сообщить о необходимости его срочного обслуживания. Запрос от устройства поступает в контроллер прерываний, а он, в свою очередь, сообщает о запросе процессору. Процессор в этом случае прерывает свою работу и переходит к программе обслуживания данного запроса.

Interrupt (software) - прерывание (программное) - команда процессора, позволяющая выполнить безусловный вызов подпрограммы, адрес точки входа в которую однозначно определяется номером программного прерывания.

I2S - стандарт на обмен цифровыми данными и командами, разработанный для бытовой аудио и видео аппаратуры. В компьютерной периферии иногда применяется для подключения соответствующих источников (например, MPEG-2 декодеров) к звуковым платам. Разъем I2S имеет четыре контакта.


DVD Info - Glossary - J

DVD своими руками: Глоссарий - J

Глоссарий

# A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

J

JEDEC - Joint Electron Device Engineering Council - организация, определяющая ряд стандартов в электронной промышленности.

JPEG - Joint Photographic Expert Group - метод сжатия неподвижных изображений, основанный на одновременной обработке информации матрицы пикселей (например, 8х8) в пространстве Y-U-V с приоритетом сохранения яркостной информации. Изображение восстанавливается с некоторыми небольшими потерями качества. Степень сжатия зависит от характера изображения и размера матрицы квантования. Этот формат стал фактическим стандартом в Internet для обмена изображениями, в основном фотографиями.


DVD Info - Glossary - M

DVD своими руками: Глоссарий - M

Глоссарий

# A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

M

MIDI - Music Instrument Device Interface - стандарт на язык и аппаратуру представления звуков различных инструментов. Команды MIDI сообщают аппаратуре, у какого инструмента, на какой октаве и какая нота должна звучать. Поэтому запись мелодии в MIDI командах очень компактна. Существует много разновидностей этого стандарта - General MIDI, Roland MT-20 и т.д.

MIDI Interface - порт подключения внешних MIDI-устройств. Интерфейс - токовая петля с питанием от передатчика и гальванической развязкой входных цепей, выведен на контакты 12, 15 разъема игрового адаптера (джойстика).

M-JPEG - Motion JPEG - метод сжатия для обработки движущихся изображений. Используется в ряде устройств среднего (по стоимости) уровня для ввода в компьютер видеоинформации.

MicroATX - уменьшенный ATX - подмножество формата ATX, отличается уменьшенным размером материнской платы - 244х244 мм. Допускает установку процессоров в любых коструктивах.

MPEG - Motion Picture Expert Group - организация-разработчик стандартов на типы кодирования видео- и аудио сигналов.

MPEG-1 - также стандарты ISO/IES 11172 - тип кодирования видеоизображения и/или звука, позволяющий при потоке данных на уровне 1.5 Mbit/s (170 kBytes/s) передавать изображение с качеством бытового кассетного видеомагнитофона стандарта VHS (Video Home System) со стереофоническим звуковым сопровождением. Исходное изображение - 352х240 пикселей, 30 кадров в секунду. В стандарт также входит программная реализация кодера и декодера на языке С. Низкая скорость потока данных позволяет использовать в качестве носителя видеоинформации обыкновенный четырех- и более скоростной CD-ROM. Диски в MPEG-1 формате обычно обозначаются как Video CD.

MPEG-2 - ISO/IEC 13818 - стандарт на кодирование для высококачественной передачи и хранения изображений в вещательном формате (720х480 пикселей), аудиоинформации и данных при потоке 28 Mbit/c (3.5 MBytes/s). Стандарт предусматривает одновременную передачу множества TV-каналов с возможностью шифрования для ограничения доступа к информации. Допускается многоканальная передача аудио данных (2 канала аудио потока MPEG-2 эквивалентны потоку MPEG-1). Этот формат пока не имеет массового применения, но с появлением DVD накопителей CD-ROM началось расширение сферы его использования.

MP3 - MPEG Audio Layer 3 - третий аудио слой в MPEG - популярная технология сжатия звука, являющаяся неотъемлемой частью стандартов MPEG-1 и MPEG-2. Позволяет сохранить качество звучания, подобное качеству обычных аудио компакт-дисков, даже при сжатии в соотношении 1:12. Стал широко применяться именно как способ компрессии аудио (а не только для записи звука на видеодисках MPEG форматов) в Internet из-за малых размеров сжатых аудио файлов. Возможно, благодаря MP3, обычные аудио плееры постепенно будут замены на MP3 плееры, не имеющие никакой механики, с малым энергопотреблением и высоким качеством звука.

MPR-II - Стандарт безопасности мониторов, разработанный Национальной лабораторией измерения и тестирования Швеции в 1987 году. Стал активно поддерживаться производителями мониторов с 1990 года. Этим стандартом устанавливается максимальный уровень излучения на расстоянии 50 см от монитора 2.5 V/m.


DVD Info - Glossary - N

DVD своими руками: Глоссарий - N

Глоссарий

# A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

N

NorthBridge - северный мост - принятый среди изготовителей chipset (наборов микросхем) термин, обозначающий системный контроллер, в который входит контроллер системной шины, шин AGP и PCI, памяти и кэш-памяти (для наборов под обычный Pentium). Как правило, это одна микросхема и именно по ней называется весь набор.

NVS - Non-Volatile Sleep - неразрушающий сон - функция ACPI, позволяющая восстановить систему в случае как потери питания, так и полного "засыпания". Если операционная система поддерживает эту функцию, возможно сохранение всей структуры данных на диск с последующим отключением питания даже от оперативной памяти. Недостаток данного способа - медленное "пробуждение".


DVD Info - Glossary - O

DVD своими руками: Глоссарий - O

Глоссарий

# A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

O

Obstruction - преграда, препятствие - это понятие используется в современных системах трехмерного звучания, поддерживаемых многими PCI звуковыми картами. Зная характеристики преграды, программа и/или процессор звуковой карты может правильно отобразить звук от источника, находящегося за преградой, но в той же акустической среде.

Occlusion - это понятие также используется в современных системах трехмерного звучания, поддерживаемых многими PCI звуковыми картами. Оно характеризует свойства стены, такие как материал и толщина, таким образом, что программа и/или процессор звуковой карты может правильно отобразить звук от источника, находящегося за этой стеной.

OLGA - Organic Land Grid Array - массив выводов на органической основе - вид металлического корпуса для интегральных микросхем, в том числе процессоров. Несмотря на такое название, изготовлен на медной основе, что существенно улучшает теплоотвод по сравнению с PLGA. Применение OLGA оправдано для микросхем с высоким уровнем тепловыделения, т.е. с частотой 500 MHz и более.


DVD Info - Glossary - P

DVD своими руками: Глоссарий - P

Глоссарий

# A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

P

PD/CD - комбинированный накопитель, записывающий диски на специальный носитель (и их же считывающий) по методу изменения фазы вещества. Пока значительного распространения не имеет и вряд ли будет иметь. Устройство также может читать и обычные CD.

PLGA - Plastic Land Grid Array - массив выводов на пластиковой основе - вид корпуса из пластика для интегральных микросхем, в том числе процессоров. Очень дешев в изготовлении, но имеет не лучшие параметры по теплоотводу.

PMPO - Peak Music Power Output - выходная пиковая музыкальная мощность - показатель выходной мощности аудиоаппаратуры, который, строго говоря, необъективен. Оценить пиковую мощность очень трудно. Некоторые производители определяют PMPO как выходную мощность при 10% нелинейных искажений, другие вообще никак не определяют. Поэтому надпись PMPO = 240 Wt на акустических колонках с номинальной (RMS) мощностью 10 Wt вполне может иметь место.


DVD Info - Glossary - R

DVD своими руками: Глоссарий - R

Глоссарий

# A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

R

RAID - Redundant Array of Inexpensive Discs - избыточный массив дисков: распределенная избыточная запись данных одновременно на несколько физических накопителей, позволяющая при считывании исправлять ошибки; начиная с 3 накопителей возможна замена любого диска без потери данных (так называемая "горячая замена"). Более подробная информация - в "SCSI Глоссарии".

RAMBUS DRAM - новый вид памяти, разработанный компанией Rambus. Этот тип памяти официально поддержан фирмой Intel. Rambus память имеет чрезвычайно высокую пропускную способность. Сама фирма Rumbus является чисто инженерной и не производит память, а только продает лицензии на ее производство.

RAMDAC - Random Access Memory Digital Analog Converter - оперативная память и преобразование цифрового кода в аналоговый сигнал. Этим термином обозначают устройство вывода информации от видеопамяти на монитор компьютера. RAMDAC может быть как встроенным в видеопроцессор, так и выполнен в виде отдельной микросхемы. Чем выше тактовая частота RAMDAC, тем более высокое разрешение и частоту кадров может поддержать видеокарта. Лучшие видеокарты имеют RAMDAC до 350 MHz. Частота в 230 MHz уже стала обычной даже в сегменте недорогих (до $100) видеокарт.

RAS - Raw Address Strobe - строб адреса строки - сигнал, используемый при работе с динамической памятью (DRAM), предназначен для запоминания в микросхеме DRAM адреса строки.

RMS - Root Mean Square - среднеквадратичное значение - показатель, применяемый для оценки выходной мощности усилителей, а также акустических систем. Определяется как среднеквадратичное значение для синусоиды сигнала на частоте 1000 Hz, причем для усилителей измеряется при номинальном уровне входного сигнала, для акустических систем, как правило, при достижении уровня 1% нелинейных искажений. RMS является значительно более объективным показателем, чем PMPO.


DVD Info - Glossary - S

DVD своими руками: Глоссарий - S

Глоссарий

# A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

S

SCA - Single Connector Architecture - архитектура с одним разъемом - разъем для подключения жесткого диска, в котором совмещены как сигналы интерфейса Wide SCSI, так и шины питания. Как правило, такой разъем используется в серверах с "горячей" заменой жестких дисков.

SB-Link - технология, разработанная совместно фирмами Creative Technology и Intel. Суть ее в том, что для совместимости аудиокарт с PCI интерфейсом с классическими аудиокартами с ISA интерфейсом на материнской плате устанавливается специальный джампер, после включения которого реакция системы на запрос DMA и IRQ от PCI звуковой карты становится такой же, как и от обычной ISA звуковой карты. Необходимость такого способа вызвана отсутствием на шине PCI сигналов IRQ и DMA, аналогичных шине ISA. Таким образом возможно использование PCI звуковой карты с любыми MS-DOS программами (в основном играми). Для реализации этой технологии требуется, конечно, не только джампер, но и поддержка со стороны chipset (Intel) и звуковой карты (Creative Technology). Сейчас данная технология поддерживается для звуковой карты Creative AWE64D PCI и материнских плат с chipset ASUSTeK серии P2B.

SNR - Signal-To-Noise Ratio - отношение сигнал/шум - один из важнейших показателей качества аудиоаппаратуры, в том числе и звуковых карт. Измеряется в децибелах как отношение уровня полезного сигнала к уровню собственного шума аппаратуры. Для высококачественных аудиоустройств значение сигнал/шум не может быть хуже 95 dB.

SIMD - Single Instruction Multiple Data - Одна команда с множеством данных - основный принцип построения MMX команд для микропроцессоров. Эти команды в качестве операндов используют регистры сопроцессора, предназначенные для хранения операндов в 80-ти разрядной сетке.

SIMM - Single In-line Memory Module - односторонний модуль памяти - конструктив модуля памяти, постепенно уходящие в 1997 году с рынка. Имеет 72 вывода с каждой стороны, но пары выводов с одной и другой стороны замкнуты между собой, поэтому они считаются односторонними. Собственно память, размещенная на модуле, может быть как EDO. Память в SIMM имеет разрядность 32 (с четностью - 36) бита и может использоваться в компьютерах с процессорами Pentium только парами.

SMBus - System Managment Bus - шина управления системой - двухпроводная шина, предложенная совместно компаниями Intel и Duracell в начале 1995 года для подключения цепей управления так называемых "умных" батарей (Smart Battery), устанавливаемых в переносные компьютеры. Интерфейс базируется на шине I2C. Основное назначение шины - связывать между собой различные устройства для управления ими без использования, как было ранее, индивидуальных сигналов. Разъемы для этой шины уже устанавливаются на современных материнских платах, таких как ASUSTeK P2B, но пока неизвестны способы ее использования в настольных компьютерах для подключения внешних устройств. Только для обращения к SPD блокам на модулях памяти пока применяется SMBus. Подробные спецификации на шину могут быть получены здесь.

SMP - Symmetric Multi-Processing - симметричная многопроцессорная обработка - метод, позволяющий более чем одному процессору распределять между собой вычислительную нагрузку. В настоящее время Intel Pentium и Pentium II поддерживают такой режим только для двух процессоров, Intel Pentium Pro - для четырех. Процессоры Intel Pentium II Xeon и Intel Pentium III Xeon могут работать в 8-ми процессорных материнских платах.

SPD - Serial Presence Detect - устройство определения присутствия с последовательным доступом - изготавливается на специальной микросхеме (как правило, это электрически перепрограммируемая память), содержащей информацию о типе устройства и его основных характеристиках. Объем такой памяти - 512 байт. SPD устанавливается на модулях памяти DIMM, доступ к ней осуществляется по шине SMBus.

SouthBridge - южный мост - обозначение периферийного контроллера в chipset (наборе микросхем), включающего обычно контроллер EIDE, клавиатуры, моста PCI-to-PCI, последовательных/параллельного портов, шины USB и других подобных устройств.

S/PDIF - Sony/Philips Digital Interface - цифровой интерфейс от компаний Sony и Philips - фактический стандарт интерфейса связи компьютерного оборудования с бытовой аудиоаппаратурой и электронными музыкальными инструментами. Такой интерфейс, в частности, служит для подключения выхода аппаратного DVD декодера к аудиоаппаратуре. Для обмена данными в S/PDIF может использоваться обычный экранированный аудио кабель.

SPP - Standard Parallel Port - стандартный параллельный порт - классический принтерный интерфейс, называемый, как правило, Centronics, по имени давно ликвидированной фирмы, разработавшей этот интерфейс. Интерфейс позволяет передавать данные по байту со скоростью до 80 KB/c. При необходимости приема данных можно использовать четыре линии сигнала от принтера (обрыв бумаги, буфер принтера полон и т.д.).

Stackable Hub - наращиваемый хаб - имеет специальные средства соединения нескольких хабов в стек, выступающий в роли единого целого. При этом обычно интеллектуальность одного хаба делает интеллектуальным весь стек. Расстояние между хабами в стеке может быть коротким (локальный стек) и длинным, до сотен метров (распределенный стек, более гибкий элемент для оптимизации кабельной системы).

Synchronous DRAM (SDRAM) - относительно новый вид памяти, который также показывает свои преимущества только при последовательной выборке данных из памяти. Но при последовательной выборке (или потоке, конвейере - burst) чтение/запись выполняются в два раза быстрее, чем для EDO DRAM На микросхемах SDRAM указывается время доступа в наносекундах к данным при последовательной выборке. Реально же цифры на корпусах микросхем синхронной памяти фактически сообщают максимальную тактовую частоту системной шины, на которой данная память может работать. Соответствие между быстродействием SDRAM и тактовой частотой шины дано в таблице:

Быстродействие памяти, nc | Максимальная частота шины, MHz
12 | 83
10 | 100
8 | 125
7 | 133

SDRAM выпускается сейчас только в 168-ми выводных 64-разрядных модулях DIMM. В отличие от обычных модулей SIMM эти могут устанавливаться на материнской плате поодиночке. В соответствии с JEDEC стандартом на модуле DIMM должна быть установлена специальная микросхема SPD устройства. Некоторые материнские платы, например фирмы Intel на наборе 440LX и более поздних, не запускаются, если установлена планка памяти без SPD. Микросхемы SDRAM так же широко используются в качестве локальной памяти видеокарт.

SGRAM - синхронная графическая память - разновидность обычной синхронной памяти, применяемая в качестве локальной памяти на видеокартах. Отличается наличием регистра страницы, который позволяет выполнять запись в несколько адресов одновременно, что дает возможность быстрого заполнения областей экрана или очистки их же. SGRAM дает основной выигрыш при работе с двумерной графикой.

Switching Hub - коммутирующий хаб - дальнейшее развитие технологии Ethernet, повышающее производительность работы сети. В этом случае управление доступом к среде практически переносится с узлов в центральное коммутирующее устройство, обеспечивающее установление виртуальных выделенных каналов между парами портов - источниками и получателями пакетов. От узлов-передатчиков коммутирующий хаб почти всегда готов принять пакет либо в свой буфер, либо практически без задержки передать его в порт назначения (коммутация с таким хабом двух компьютеров, обменивающиеся "на лету" - On-the-fly Switching). Используя обмен данными между собой через коммутирующий хаб, компьютеры не будут загружать общий трафик. Такие хабы также применяются для соединения между собой сетей Ethernet и Fast Ethernet.


DVD Info - Glossary - T

DVD своими руками: Глоссарий - T

Глоссарий

# A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

T

TCO 92, 95, 99 - стандарты, утвержденные Федерацией профсоюзов Швеции (The Swedish Confederation of Professional Employees). По сравнению с MPR-II устанавливают более жесткие нормы на излучение от мониторов. Максимально допустимый уровень излучения по TCO-92 установлен в 1 V/m на расстоянии в 30 см. Это в несколько раз более жесткие требования, чем в MPR-II. Стандарт TCO-95 предъявляет такие же требования по излучению, но обязывает также изготавливать монитор из материалов, подлежащих вторичной переработке и не наносящих вред окружающей среде. Еще более жесткие требования по излучению введены в новом стандарте TCO'99, в котором по сравнению с TCO 95 ужесточены следующие параметры:

  • Минимально допустимая частота кадров не менее 85 Hz

  • Уменьшен вдвое уровень потребления электроэнергии в режиме Standby

  • Время восстановления из Standby в рабочий режим не более 3 секунд

  • Стандарт впервые предъявляет жесткие требования к качеству самого изображения - должна быть минимальной расфокусировка изображения по углам экрана по отношению к центру, оговаривается уровень отражения света от экрана (блики) и т.п.

Более подробную информацию можно получить на www.tco-info.com.

На мониторе, удовлетворяющем условиям стандарта TCO-92 должен быть знак | tco92.gif (6129 bytes)
На мониторе, удовлетворяющем условиям стандарта TCO-95 должен быть знак | tco95.gif (6141 bytes)
На мониторе, удовлетворяющем условиям стандарта TCO-99 должен быть знак | tco99.gif (3859 bytes)

TouchPad - Панель, чувствительная к касанию - специальная панель, размером приблизительно 6х6 см, заменяющая мышь. Панель отслеживает как перемещение пальца, так и нажатие им (щелчок). Применяется в мобильных компьютерах и встраивается в некоторые модели клавиатур.

TrackBall - Шар с отслеживаемым перемещением - специальное устройство в виде шара и 2 или 3 кнопок, служащих для замены мыши. Вращение шара пальцем эквивалентно перемещению мыши.

TUV - Technical Supervision Bureau - организация в Германии, отвечающая за сертификацию электронного оборудования в Германии.


DVD Info - Glossary - U

DVD своими руками: Глоссарий - U

Глоссарий

# A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

U

UDF - Universal Disk Format - универсальный дисковый формат - формат, первоначально разработанный для перезаписываемых CD-RW дисков. Необходимость в этом формате возникла именно после появления CD-RW дисков, так запись на них может быть многократной и в любые свободные места на диске, аналогично записи на обычный жесткий диск. Формат UDF не привязан к какой-либо конкретно операционной системе и может использоваться не только в IBM PC совместимых компьютерах. Для чтения дисков в формате UDF на приводах CD-ROM, изначально этот формат не поддерживающих, предназначены специальные программы и некоторые из них можно переписать здесь.

UL - Underwriter's Laboratory - организация в США, определяющая безопасность различных приборов. Устройства, соответствующие ее требованиям, включаются в специальный перечень, издаваемый этой организацией.

UMA - Unified Memory Architecture - унифицированная архитектура памяти - используется в недорогих видеокартах, размещенных, как правило, на материнских платах. Принцип действия основан на использовании видеокартой обычной памяти компьютера как памяти экрана и, соответственно, удешевления компьютера. При этом выделенная для видеокарты память не видна операционной системе типа DOS и доступ к ней возможен только через BIOS видеокарты, поэтому такие видекарты значительно медленнее обычных PCI карт. Под операционными системами типа Windows разница существенно меньше, но она все равно есть.


DVD Info - Glossary - W

DVD своими руками: Глоссарий - W

Глоссарий

# A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

W

WARM - White And Read Many times - многократная запись и считывание.

Write Back - обратная запись - термин применяется при описании устройств кэш-памяти. Если установлен режим обратной записи, то в случае изменения данных, находящихся в кэш-памяти, процессор меняет их только в кэше, но не в основной памяти. Только при замене одной области данных в кэше на другую процессор сохраняет данные из кэш-памяти в основную память. Реально это означает, что данные кэшируются на запись и на чтение и именно такой режим применяется сейчас в подавляющем большинстве компьютеров.

Write Combining - объединенная запись - термин применяется при описании устройств кэш-памяти и означает накопление записываемой информации в кэш-памяти с последующим "выстреливанием" готового пакета данных на шину. Этот режим позволяет ускорить запись информации, например, в память видеокарты.

Write Through - сквозная запись - термин применяется при описании устройств кэш-памяти. Если установлен режим сквозной записи, то в случае изменения данных, находящихся в кэш-памяти, процессор одновременно меняет их как в кэше, так и в основной памяти. Реально это означает, что данные кэшируются только по чтению, поэтому этот способ кэширования применяется в редких случаях при сознательной необходимости.

WT Music Synthesizer - синтезаторы с табличным синтезом (Wave Table), хранящие в своей постоянной памяти образцы (волновые таблицы - цифровые последовательности выборок) сигналов настоящих "живых" инструментов для нескольких нот диапазона по каждому инструменту. Как правило, минимальный объем таблицы - 1 MB. На многих звуковых картах возможна установка дополнительной памяти для загружаемых таблиц, которые могут быть созданы самим пользователем. Качество волнового синтеза высокое, но при более высокой цене.


DVD Info - Technical Information - DVD Media Compability - DVD_R Compability Facts

DVD своими руками: Техническая информация: Совместимость DVD носителей - Совместимость DVD-R болванок

Результаты исследования совместимости DVD-R болванок

NN | Информация в Lead-in | Производитель по маркировке | Производитель реальный
1 | 00 42 00 00 01 40 C1 FD 9E D8 50 00 02 87 0D 14 .B...@....P..... 88 88 80 00 03 47 53 43 30 30 31 00 04 20 20 20 .....GSC001.. 20 20 20 00 05 CC C0 00 00 00 00 00 00 00 00 00 ............. | Universal Asia или Digitex Co, Ltd | Giga-storage
 | Очень дешевые и очень некачественные болванки. Читаются нормально только на некоторых моделях DVD плееров Pioneer (хотя не читаются на многих DVD-ROM той же фирмы). Основной дефект - подтормаживание при воспроизведении как видео, так и звука по всему диску. Оценка - 2 балла
2 | 00 42 00 00 01 40 C1 FD 9E D8 50 00 02 79 0E 0B .B...@....P..Y.. FE FF 80 00 03 52 49 54 45 4B 47 00 04 30 31 00 .....RITEKG..01. 00 00 00 00 05 88 80 00 00 00 01 00 00 00 00 00 ................ | Ritek, но может быть Digitex | Ritek
 | Тоже недорогие болванки. Качество не очень хорошее. Читаются практически на всех плеерах и компьютерных приводах, но во многих случаях возникают различные дефекты изображения и звука. Оценка - 2+ балла
3 | 00 42 00 00 01 40 C1 FD 9E D8 50 00 02 79 0E 0B .B...@....P..Y.. FE FF 80 00 03 52 49 54 45 4B 47 00 04 30 33 00 .....RITEKG..03. | отсутствует | Ritek
 | Болванки имеют хорошую совместимость и читаемость, но только в том случае, если записанный объем не превышает приблизительно 4 400 000 байт. В противном случае проигрыватель, дойдя до этого места, либо зависает, либо продолжает читать но с непрерывными остановками и рассыпанием изображения на квадраты. Что будет происходить, зависит от конкретного проигрывателя. Оценка - 3 балла.
4 | 00 42 00 00 01 40 C1 FD 9E D8 50 00 02 87 0D 13 .B...@....P..... 88 99 80 00 03 4D 43 43 20 30 30 00 04 52 47 32 ....MCC 00..RG2 30 30 20 00 05 00 00 00 00 00 01 00 00 00 00 00 00 ............. | Verbatim DataLife Plus | Verbatim
 | Высококачественные болванки. Найти не читающие их устройства не удалось. При чтении никаких дефектов нигде не наблюдалось. Мы записали первые болванки от Verbatim летом 2001 года. По состоянию на январь 2003 года читаемость их не ухудшилась. Оценка 5 баллов.
5 | 00 42 00 00 01 40 C1 FD 9E D8 50 00 02 87 0D 13 .B...@....P..... 88 99 80 00 03 43 4D 43 30 30 52 00 04 47 32 30 ...CMC00R..G20 30 00 00 00 05 00 00 00 00 00 01 00 00 00 00 00 0............... | Memorex - Part Number 854110 | н/д
 | Несмотря на практически ту же цену, что и у Verbatim, качество значительно хуже. Основной дефект - проблемы с чтением последней 1/5 части диска. На DVD плеере Pioneer, например, просто рассыпалась картинка в конце фильма. Только плееры BBK показывали на концах этих дисков дефекты изображения и звука, но хоть как-то проигрывали. Оценка - 3 балла
6 | 00 42 00 00 01 40 C1 FD 9E D8 50 00 02 87 0D 13 .B...@....P..... 88 99 80 00 03 4D 43 43 20 30 30 00 04 52 47 32 ...MCC 00..RG2 30 30 20 00 05 00 00 00 00 00 01 00 00 00 00 00 00 ............. | Pioneer DVS- R470SDF/N | Verbatim
 | См. описание Verbatim с аналогичным кодом Lead In.
7 | 00 42 00 00 01 40 C1 FD 9E D8 50 00 02 7A 0C 15 .B...@....P..Z.. 77 78 90 00 03 50 6C 61 73 6D 6F 00 04 6E 2D 47WX.PLASMO.N-G 65 6E 00 00 05 CC C0 00 00 00 01 00 00 00 00 00 EN.............. | MERITLINE | Plasmon Data
 | Плохая читаемость на многих плеерах. Те плееры, которые их распознают, читают нормально, но если не распознают, то все - ни прочитается ничего. Кроме этого, при прожиге может быть испорчена часть болванок. Оценка - 3 балла.
8 | 00 42 00 00 01 00 C1 FD 9F D1 50 00 02 87 0D 13 .B........P..... 88 99 80 00 03 52 45 43 30 30 31 00 04 00 00 00 .....REC001..... 00 00 00 00 05 00 00 00 00 00 01 00 00 00 00 00 ................ | н/д | н/д
 | Плохая читаемость как на новых, так и на старых плеерах. Оценка - 2+ балла
9 | 00 42 00 00 01 40 C1 FD 9E D8 50 00 02 87 0D 13 .B...@....P..... 88 99 80 00 03 4C 65 61 64 20 44 00 04 61 74 61 .....LEAD D..ATA 20 20 20 00 05 00 00 00 00 00 01 00 00 00 00 00 ............. | Compusa | Lead Data
 | Вполне приличные недорогие болванки. Обладают хорошей читаемостью и не портятся при прожиге. Оценка - 4 балла.
10 | 00 42 00 00 01 40 C1 FD 9E B3 50 00 02 7A 0C 15 .B...@....P..Z.. 77 78 90 00 03 4C 44 00 00 00 00 00 04 00 00 00 WX...LD......... 00 00 00 00 05 CC C0 00 00 00 01 00 00 00 00 00 ................ | Compusa | н/д
 | То же, что и Compusa выше.
11 | 00 42 00 00 01 40 C1 FD 9E D8 50 00 02 89 0E 13 .B...@....P..... 87 88 80 00 03 50 56 43 30 30 31 00 04 30 30 31...PVC001..001 00 00 00 00 05 CC C0 00 00 00 01 00 00 00 00 00 ................ | Pioneer DVS- R470AE | Pioneer
 | Читаемость вполне приличная, но уступает Verbatim, причем заметно. Оценка 4 с "минусом". Отзыв прислан компанией Стоик.
12 | 00 42 00 00 01 40 C1 FD 9E D8 50 00 02 58 0E 11 .B...@....P..X.. 98 99 80 00 03 4D 58 4C 20 52 47 00 04 30 31 00 ....MXL RG..01. | Plasmon | н/д
 | "Самые кривые болванки всех времен и народов". Читаются средне (кроме как на самом приводе). То есть компьютерные приводы их читают полностью (хотя и со скрипом: установив количество retrain'ов побольше можно "вытащить" полные 4.38Gb, но в нормальном режиме в конце "залипает"), некомпьютерные - даже лучше (почти без квадратов), но... если опознают. А вот с этим - проблемы. Сам Pioneer DVR-A03 их опознает с 20-й попытки. В среднем (вставили, он минуту поморгал лампочками и успокоился помаргивая желтой лампочкой, вынули, вставили - и так пока не загорится зеленая), куча других player'ов (как компьютерные, так и standalone) их вообще не опознают, но пара приводов (ASUS E616 и Pioneer DVD-116) их опознают с первой попытки (а ASUS E616 даже и читает с первой попытки без retrain'ов), что позволило мне приспособить их под backup'ы. Отзыв прислан Виктором Хименко. Оценка 2.
13 | 00 42 00 00 01 40 C1 FD 9E D8 50 00 02 37 0E 0B .B...@....P..7.. FE FF 80 00 03 52 49 54 45 4B 47 00 04 30 33 00 .....RITEKG..03. | Universal Asia | Ritek
 | Новые 2x болванки от Ritek. Несмотря на незначительные отличия по коду от болванок № 3, качество отличается заметно. Для записи их на скорости 2x Pioneer выпустил обновление firmware (v.1.31) как для A03, так и A04. Вполне приличные по качеству болванки. Записанные "до последнего мегабайта" диски нормально воспроизводились до самого конца диска. Оценка 4 с "минусом", поскольку некоторые экземпляры все-таки имели спад по скорости чтения на конце диска.
14 | 00 42 00 00 01 40 C1 FD 9E D8 50 00 02 8A 0D 14 .B...@....P..... 88 88 80 00 03 54 44 4B 47 30 32 00 04 30 30 30 .....TDKG02..000 30 30 30 00 05 CC C0 00 00 00 00 00 00 00 00 00 000............. | TDK, Meritline, Princo и т.д. | TDK или Princo
 | *** Болванки от TDK. Никаких изъянов не обнаружено, запись на двойной скорости работает. Оценка 4. Если болванки с таким кодом в родной jewel упаковке (не на шпинделе, в бумажном пакетике и т.п.), то это оригинальные болванки от TDK (которые, в свою очередь, могут быть и с кодом Verbatim), в противном случае это болванки от Princo или иных тайваньских производителей и НЕ являются оригинальными TDK дисками. Данный тест был болванок Princo.
15 | 00 42 00 00 01 40 C1 FD 9E D8 50 00 02 A7 0C 15 .B...@....P..... 77 78 90 00 03 44 56 44 2D 52 20 00 04 34 2E 37 WX..DVD-R ..4.7 2D 30 31 00 05 CC C0 00 00 00 01 00 00 00 00 00 -01............. | н/д | н/д
 | *** Болванки неизвестного происхождения. Качество никуда не годится, вне зависимости от программы DVD авторинга. Даже в начале диска есть задержки при считывании. Плохо читаются как на no brand плеерах, так и на brand name плеерах. Оценка 2.
16 | 00 42 00 00 01 40 C1 FD 9E D8 50 00 02 89 0E 13 .B...@....P..... 87 88 80 00 03 56 49 56 41 53 54 00 04 41 52 00 .....VIVAST..AR. 00 00 00 00 05 88 80 00 00 00 01 00 00 00 00 00 ................ | н/д | Vivastar
 | *** Неустойчивое качество записи. На одном из двух тестовых дисков, созданных в ReelDVD, есть задержки при считывании, причем на BBK или аналогичных в начале диска, на Pioneer, Panasonic и т.п. - в конце. Вполне возможно, что это дефект конкретного экземпляра. В остальном претензий нет. Оценка - 3 балла
17 | 00 42 00 00 01 40 C1 FD 9E D8 50 00 02 98 0C 13 .B...@....P..... 76 78 80 00 03 50 52 49 4E 43 4F 00 04 00 01 00 VX...PRINCO..... 00 00 00 00 05 88 80 00 00 00 01 00 00 00 00 00 ................ | Princo | Princo
 | *** Болванки приличного качества, замечаний нет. Оценка 4 балла. Но мы также получили мнение одного из наших читателей, которое заметно отличается от нашего: Получил их непосредственно с завода и записывал их на: - DVD рекордере Panasonic DMR-E20; - DVD writer Panasonic LD-D311 (Ulead VideoStudio 6.0). Диски, записанные на рекордере, без проблем и до самого конца на нем же воспроизводятся. На бытовых плеерах последние полчаса записи идут с дефектами. DVD writer вообще с очень большой неохотой признает их как blank media." Отзыв прислал Сергей Сетракян Наши комментарии: Отрицательный отзыв со стороны пользователя и положительный наш говорит о том, что качество болванок от Princo нестабильно. Кстати, аналогичная информация была обнаружена и в конференциях, обсуждающих DVD-R болванки - Princo многие хвалят, но многие и ругают.
18 | 00 42 00 00 01 40 C1 FD 9F B7 50 00 02 7A 0C 15 .B...@....P..Z.. 77 78 90 00 03 4C 44 30 31 00 00 00 04 00 00 00 WX...LD01....... 00 00 00 00 05 CC C0 00 00 00 01 00 00 00 00 00 ................ | н/д | н/д
 | *** Проблемы с последним гигабайтом - чтение конца фильма идет на большинстве плееров с остановками. Оценка - 3 балла.
19 | 00 42 00 00 01 40 C1 FD 9E D8 50 00 02 89 0E 13 .B...@....P..... 87 88 80 00 03 41 75 76 69 73 74 00 04 61 72 00 .....AUVIST..AR. 00 00 00 00 05 88 80 00 00 00 01 00 00 00 00 00 ................ | н/д | н/д
 | *** Болванки приличного качества, замечаний нет. Оценка 4 балла.
20 | 00 42 00 00 01 40 C1 FD 9E D8 50 00 02 8A 0D 14 .B...@....P..... 88 88 80 00 03 50 52 4F 44 49 53 00 04 43 47 30 .....PRODIS..CG0 31 00 00 00 05 CC C0 00 00 00 00 00 00 00 00 00 1............... 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................ | н/д | н/д
 | Nero (5.5.9.17 ) при записи на данные болванки пару раз перед непосредственно записью выдавал окошечко про возможные ошибки записи из-за ошибок чтения , но записывалось без ошибок( где-то 4 600 000 байт). Всего было записано порядка 10 дисков. На бытовой технике (Pioneer и Panasonic) диски воспроизводятся. Диски создавались не Scenarist-ом , а перемультиплексированием оригиналов. Pioneer A05 (firmware 1.0) в отличие от A04 данные диски вообще не видит. Отзыв прислан Зиганченко Константином.
21 | 00 42 00 00 01 40 C1 FD 9E D8 50 00 02 98 0C 13 .B...@....P..... 76 78 80 00 03 54 44 4B 47 30 32 00 04 30 30 30 VX...TDKG02..000 30 30 30 00 05 88 80 00 00 00 01 00 00 00 00 00 000............. | TDK, Item Code DVD-R47EA | TDK
 | Оригинальные болванки от TDK. Никаких претензий к качеству, запись на Pioneer 105 на 2-х скоростях, совместимость такая же, как и у Verbatim, т.е. отличная.

Примечание:

  1. н/д - нет данных
  2. Болванки, отмеченные ***, предоставлены на тестирование компанией www.dvd-rw.ru, за что приносим ей искреннюю благодарность.